Skip navigation
CLennon420
Currently Being Moderated

Adobe Reader X won't open PDF from web browser.

Feb 23, 2011 1:18 PM

We have a .Net application that loads .pdf files into a .Net web browser control to view them.  With Adobe Reader 9 and below, there is no issue whatsoever.  Adobe Reader X just shows a blank screen.  Any ideas on how to correct this?

 
Replies
  • Currently Being Moderated
    Feb 23, 2011 6:24 PM   in reply to CLennon420

    I'm suffering from a similar issue. If I click on a link to a PDF with Chrome or IE, and have Adobe Reader X, the screen is blank. If I do the same but with an older version of Adobe Reader then the pdf loads in the browser without any issues.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 24, 2011 2:16 AM   in reply to robbpjr

    Hi,

     

    You can try repairing your Application from Control Panel -> Add/ Remove Programs.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 24, 2011 8:44 PM   in reply to PankhriS

    I have a macbook pro & since updating to adobe 10, i can't get the web browser (firefox) to open pdf files. any suggestions? have removed & reloaded, but still no change.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 21, 2011 8:01 PM   in reply to CLennon420

    Realize this is late, but I came across the same problem just recently.  I just found this in another non-adobe forum: Edit->Preferences->General->uncheck "Enable Protected Mode At Start Up"

     

    I have been trying to cure this bug for a client for three days. Will be trying this fix tomarrow.  I'll report back on if'n it works or not.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 22, 2011 4:34 PM   in reply to CLennon420

    i was having the sam problem as you, im using an online math book for my school and i towuldn display in either google chrome( the latest version) or Internet Explorer 9. My teacher told me that you shoukd use firefox, so i did and firefox displayed it, the problem is that im an internet explorer fan and on top of that i hat APPLE with all of my hearty, but leaving my personal opinons aside, firefox works, BUT THERE IS NO INFO ON HOW TO GET IT TO WORK IN INTERNET EXPLORER 9, WHICH IS REALLY frustrating!!!!!!!!!!!!!!!!!

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 22, 2011 5:51 PM   in reply to CLennon420

    Create a small  new PDF and check the PDF

     

    If its working fine there is smoe problem with the original

     

    Regards

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 22, 2011 7:08 PM   in reply to CLennon420

    I am back to report that setting protection off worked for my situation.  Happy client, even happier me!

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 22, 2011 7:15 PM   in reply to CLennon420

    For clarity,  Edit->Preferences->General->uncheck "Enable Protected Mode At Startup" means in Reader X, not IE.

     
    |
    Mark as:
  • Currently Being Moderated
    Calculating status...
    Mar 22, 2011 11:09 PM   in reply to CLennon420

    We do have the same problems with IE and Reader X, and disabling protected mode was a workaround for this.

    However: We are now at risk because adobe does not patch reader x with security updates which protected mode does mitigate.

     

    So: Either basic functionality like opening a PDF in a Browser (!!!) or security... 

    I think I will be looking around for alternative PDF readers out there

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 23, 2011 9:12 PM   in reply to CLennon420

    After I downloaded Adobe X, I got a black screen with a blue bar and done at the bottom. No pdf's would open from the internet. However, I have many pdf's that are documents downloaded from library and they open perfectly well. So problem is with browser (in my case Firefox) and not with Adobe.

     

    The solution for this problem in Firefox is to go into Firefox site, click on Help and in Seach area, type Adobe. They have a section dealing with this problem. I followed the suggestions and now I have no problem.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 24, 2011 12:53 PM   in reply to diatmascot

    Congratulations   -- --- ---  ---   ---  u did it

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 28, 2011 9:03 PM   in reply to CLennon420

    However, I have many pdf's that are documents downloaded from library and they open perfectly well. So problem is with browse...

     

     

    Not necessarily.  Glad you worked out your situationm but RDP'd into my client's pc I, too, could download and open.  The confounding part was that I could also open other PDFs on other sites (using IE), including those here on Adobe's.  But my client was trying to open an apply-on-line fill-in form PDF on some Fed Gov site so downloading wasn't an option.  

     

    I'm guessing: depends more on what/how the PDF was created.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 29, 2011 1:18 AM   in reply to CLennon420

    Guys try this

     

    Choose Edit > Preferences > Internet, Deselect Display PDF In Browser, and then click OK

     

    And  should be Enabled - Display in Read Mode by Default,

                                         Allow fast web view

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 30, 2011 11:57 PM   in reply to MjM2011

    But my client was trying to open an apply-on-line fill-in form PDF on some Fed Gov site so downloading wasn't an option.

     

    I had a similar problem when I used Google Chrome as browser to fill in Medicare claim form. No problem in Firefox.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 31, 2011 12:26 AM   in reply to diatmascot

    Yes,it will download the PDF document in case you are not able to open the PDF in browser.

     

    This setting used for only viewing the document

     

    Guys try this

     

    Choose Edit > Preferences > Internet, Deselect Display PDF In Browser, and then click OK

     

    And  should be Enabled - Display in Read Mode by Default(It will be grayed out when you are deselcting the first option but it is enabled),

                           Enabled - Allow fast web view

                          Diselect - Allow Speculative doenloading in the background

     

     

     

     

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 3, 2011 12:41 AM   in reply to diatmascot

    You can try this

     

    Choose Edit > Preferences > Trust Manager > Change setting > Enable Allow PDF files to access all web sites

     

     

    Then u can try to open internet online form

     

     

     

    But my client was trying to open an apply-on-line fill-in form PDF on some Fed Gov site so downloading wasn't an option.

     

    I had a similar problem when I used Google Chrome as browser to fill in Medicare claim form. No problem in Firefox.

     

     

     

     

     

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 2, 2011 5:48 AM   in reply to CLennon420

    When it just shows a blank screen, try pressing F5 (refresh) and see if it comes up then.  It just did on my test machine.

     

    Darren.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 2, 2011 7:58 AM   in reply to CLennon420

    ... also see if this option is checked in IE (IE7 & Win XP):

     

    Tools / Internet Options / Advanced tab / Security section / 'Do not save encrypted pages to disk'

     

    ... we have that checked in our environment (it is not the IE default) and it was preventing Adobe Reader X from opening PDF files.

     

    Darren.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 2, 2011 10:53 AM   in reply to CLennon420

    using Internet Explorer 8 (64 bit) I am noticing that web pages with embeded PDFs (like in an iFrame) are not displaying, but instead a popup prompt to Save or Cancel is being shown.  What is the fix for this issue?  (yes the Windows User acount I am using does have permission to view the files)

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 5, 2011 5:01 AM   in reply to DCollins, Oxford

    Thanks Darren, after weeks of trawling forums and trying numerous advice this is the one that worked for me.

     

    I guessed that it probably wasn't Adobe that was the issue but just couldn't work out what in IE was preventing the PDF from opening.

     

    Great work and thanks for sharing..

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 8, 2011 9:08 PM   in reply to MjM2011

    When I closed my browser and clicked on the Adobe Reader X icon on my desktop to open it - it asked to you want the following program to make changes on your computer. I can't open it to try out your suggestion of edit-preferences-general / Uncheck enable protected mode at startup.

     

    I found a temporary fix - a way to go around the problem. I found it at http://kb2.adobe.com/cps/836/cpsid_83688.html#main_save%20to%20desktop under

    Open PDF directly in Reader or Acrobat (quick fix)

    If the PDF appears as a clickable link, you can  often save the file to your desktop and open it directly. Downloading  the file is a quick solution to get you going without further  troubleshooting.

    1. Right-click (Windows) or Control-click (Mac OS) the link to the PDF file.
    2. Choose the appropriate save or download option. The options vary depending on your browser:
      • (Internet Explorer) Save Target As
      • (Firefox) Save Link As
      • (Safari) Download Linked File           

    1. Make sure Adobe Acrobat Document is selected for the file type, and save the file.            
      Note: If you don't see a Save As dialog box, your  browser could have opened a separate downloads window and downloaded the  file automatically.           

    1. Locate  the saved PDF, and double-click the file to open it. If your browser  opened a downloads window, double-click the PDF in the downloads list.
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 23, 2011 7:29 AM   in reply to CLennon420

    I do not know if this helps anyone but I resolved this problem by doing the following:

     

    Edit --> Preferences --> General --> Select Default PDF Handler -->  A pop up window will open and you need to select Adobe Reader X as the default reader.  When you press Apply it will relaunch and installer, do its thing and then reboot.

     

    After the reboot I was not only able to successfully select the option to not display Adobe in Web Browser, Adobe also opened properly in IE.

     

    Before I was getting the Adobe Plug-in Error.

     

    Hope this helps you!

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 20, 2012 9:19 AM   in reply to DCollins, Oxford

    This worked for me. 

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 20, 2012 2:16 PM   in reply to CLennon420
     
    |
    Mark as:
  • Currently Being Moderated
    Mar 1, 2013 12:03 AM   in reply to CLennon420

    Hi, Clennon420,

     

    Recently, I came up with the same problem. Did you find the solution ?

     

    Thanks

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 1, 2013 12:47 AM   in reply to Mak Un Pong

    Several people did, yes.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points