Skip navigation
amm7777
Currently Being Moderated

Photoshop Elements 8 Error Not Responding

Mar 1, 2011 6:18 AM

I am trying to get assistance in getting my photoshop back up and running.  I have called Adobe and there is no sympathy all they want is money to fix it.  They have sent me here to speak to an Adobe Tech.  I am finding that this is a very common issue but none of the resolutions have worked.  Everytime I try to enter my organizer my program stops working and gives the message "not responding".  I am running on Windows 7.  Please help, I am getting very frustrated with Adobe...

 
Replies
  • 99jon
    12,806 posts
    Jan 6, 2010
    Currently Being Moderated
    Mar 1, 2011 7:40 AM   in reply to amm7777

    Try right clicking on the Organizer desktop icon and then choosing “Run As administrator”

     

    If you don’t have a desktop icon, this is how to create one.

    On Windows right click on the desktop and select New >> Shortcut

    Browse to Computer OS C:

    And find the PSE Organizer application in Program Files or Program Files (x86) on Windows 7 - 64 bit.

     

    Inside the Adobe >> Photoshop Elements Organizer (yellow folder) you are looking for an application file

    PhotoshopEementsOrganizer with six small icons (e.g. representing thumbnails)

    Select it and click OK

    Click next

    Rename by taking out Photoshop Elements leaving just the word Organizer

    Then click finish

     

    You should now be able to launch directly form the desktop by double clicking on the icon.

     

    You can set up a similar direct link to the Editor application (.exe file which has the blue PSE icon). As before take out Photoshop Elements just leaving the description Editor and it will show up clearly on the desktop.

     

     

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 2, 2011 3:49 AM   in reply to 99jon

    Start PSE to get to the Welcome screen.

     

    Hold down the Ctrl, Alt, and Shift keys and click Organize. Keep holding down the keys until you see the Catalog window.

     

    Select your catalog and click Repair.  Select “repair anyway” even if PSE doesn’t find problems.

     

    Then you may also can click Optimize.

     

    If repairing resolves your issue then fine else repeat the above steps, but click New to create a new catalog.  If you’re able to import photos into the new catalog and the Organizer works fine, then problem can be old catalog.

     

    In that case you can try regenerating the thumbnails.  Do Show All, Edit > Select All, and then Edit > Update Thumbnail.

     

     

     

    try and let me know your comments.

     

     

     

    -Garry

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 31, 2013 4:03 PM   in reply to ukgaurav

    I too have received no help from Adobe and cannot even get PSE to open to the Welcome Screen / Organize or Edit screens.  I have tried right-clicking and run as admin, but nothing happens.  All I am getting is the busy mouse for a second and then, nothing.  Does anyone know of a repair file?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 31, 2013 9:54 PM   in reply to Go Ask Debbie

    Hi Debbie,

     

    Which part you are having trouble with? Editor or Organizer. Some more info arounf would help. Also please try solution from my last post in this thread.

     

    Thanks,

    Garry

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 1, 2013 5:58 PM   in reply to ukgaurav

    @Ukgaurav,

     

    It is neither - The program will not even open to the Welcome window to allow me to select the Edit or Organize.  I have also tried to run those .exe files directly and it will not do anything.  I need the original setup.exe file to reinstall, but Adobe will not provide it for me.

     

    Any help would be greatly appreciated!

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 1, 2013 10:13 PM   in reply to Go Ask Debbie

    Try this:

     

    Solution 1:

     

    Hold down the Ctrl + Alt + Shift keys and click on PhotoshopElementsEditor.exe. Continue to hold the keys until you see a message box asking if you want to delete Photoshop Elements settings file; click Yes. Elements will open with default preferences.

     

    Solution 2:

     

    On the drive on which you have installed PSE,on my machine it is on C:

     

    Go  to C:\Program Files\Adobe\Photoshop Elements  10\Locales\<locale>\Plug-Ins\Import-Exportand you will find twain  plug-in. Remove that plug-in from that location and copy it somewhere  else. Now launch PSE and check if it works.

       

    For related post for Twain please see this:http://forums.adobe.com/message/2954743#2954743

     

    Let me know your comments.

     

    Thanks,

    Garry

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 2, 2013 8:27 PM   in reply to ukgaurav

    @ukgaurav,

     

    Thank you, I was given a link to redownload the setup.exe (install file).  So I am good now.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points