Skip navigation
55555Sparky
Currently Being Moderated

3.3 Bug: Win32 API Error 2 - Please help

Mar 7, 2011 10:57 AM

Wondering if anyone may be able to help with the following error message:

 

"An internal error has occured: Win32 API error 2 ("The system cannot find the file specified") When calling ShellExecuteExW from AgWorkspace.shellExecute".

 

The wonderfully unhelpful persons at the helpline said they could not help me but indicated If I reload the version 3.3 in a different location the problem would go away since some plug-in from v1.4 had infected the new install.

 

I have no custom add-ins/plug-ins, everything is default.

 

I followed these instructions, however still have the same error. I removed then re-installed 3.3 on another drive away from C:\Progfiles......

 

Any suggestions?

 
Replies
  • Currently Being Moderated
    Mar 8, 2011 3:20 AM   in reply to 55555Sparky

    ... and your OS version is .. ?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 8, 2011 12:51 PM   in reply to 55555Sparky

    The installer indeed does not remove everything. It does not remove your preferences, the catalogs and it does not touch the images of course. It would be a good idea to clean all residues of 3.3, reboot and reinstall at its default location. I don't have 1.x but I have 2.7 and 3.3 in parallel without any issues so far.

     

    You can find the location of all the files with this help: http://kb2.adobe.com/cps/843/cpsid_84313.html

     

    If the error comes up again after the clean install, a screenshoot of the error would be helpful as well as the entries in the windows logs if there are any. I'm sorry, I don't really have another solid idea for the source nor for a solution of the issue.

     

    HTH

    McL

     
    |
    Mark as:
  • Currently Being Moderated
    May 18, 2012 5:45 AM   in reply to F. McLion

    I had the same problem and the solution was rather simple. I just had to check "take no action" in the very last field in the export window. I have the german version, it's called "post processing" or "further treatment" or so. The field was filled in by default but for some reason suddenly empty. After I clicked "take no action" the error message was gone and did not return.

     

    Greets

    Deri

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 20, 2012 2:22 PM   in reply to Gabriella Wetli

    This worked for me.  That field was filled with a blank.  Changed it to "do nothing" and now it works fine.

    Thanks

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 22, 2013 10:13 AM   in reply to Gabriella Wetli

    Hi Gabriella, I war so frustriert, da ich nichts exportieren konnte, nachdem ich Lightroom 4 gekauft hatte. Deine Hilfe rettet mein Tag.(obwohl noch viel Schnee liegt. Vielen Dank.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points