Skip navigation

System requirements for Premiere Pro CS5

Mar 13, 2011 10:03 AM

  Latest reply: roddiehorton, Feb 19, 2014 8:42 AM
Replies 1 2 3 Previous Next
  • Currently Being Moderated
    Aug 11, 2011 6:09 PM   in reply to blackrosekiller

    Get rid of the partitioning, Drive are cheap

     

    You have the OS, applications and the project on the same disk drive = very bad setup.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 11, 2011 6:37 PM   in reply to blackrosekiller

    I just spoke with Western Digital tech support and read them your comment about RAID 0.  They said they never heard of this issue with either RE4 or Caviar. RE4 and Black drives both have TLER specifically so they don't drop off RAID arrays.  The tech support guy went as far as saying RE4 stands for RAID Edition 4.  Now I'm more confused.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 11, 2011 7:17 PM   in reply to blackrosekiller

    WD support in this case is clueless!

     

    Here's the scoop...

     

    RAID stands for Redundant Array Independent Disks (somebody correct me if I got this a little wrong, I'm going from memory), and the intent was to have an array where a drive, or 2 drives in the case of RAID 6, could fail and NO data would be lost.

     

    Enter RAID 0; some people even call it non-RAID or AID 0 (missing the R, which stands for redundant), because there is nothing redundant about it. RAID 0 is all about speed, and if either drive fails, all is lost.

     

    WD, and their competitors, manufacture and market drives for both markets. In WD's case I understand the differences to be:

    1) RAID drives are advertised, and maybe are or are not, using better hand picked platters with less defects; also likely better overall QA and testing

    2) Firmware is generally a bit different, optimized slightly for use in RAID arrays for network server applications vs. single workstation drive needs

    3) RAID drives are said to have better bearings, and designs that are less bothered by neigboring drives in a long hot-swap bank where heads are all seeking at the same time and in the same direction

    4) Finally, TLER; WD calls it TLER, other drive manufacturers do something similar for their RAID drives but call it something different. TLER stands for Time Limit Error Recovery; it means that the drive will limit how long it will try to recover an error. [Sidebar: I have some RE drives and also some older Blacks that allow for this feature to be toggled on and off, and the number of seconds to be set for "TLER" to take place]. The actual purpose is to have a drive "fail" and drop off of the RAID quickly (default is set to 7 seconds), so that the performance of the RAID will continue to serve its users instead of hunting, seeking, and trying to recover of what was "lost" on just one drive; at this point either an IT person or hot-spare drive gets added back to replace the "dropped" drive and the array auto-rebuilds (without the "dropped" drive).

     

    For desktop users the needs are quite different; for example, I had a failing laptop HD one time, which never lost one single thing, but before I replaced it opening or saving a file could take 30 seconds instead of 1 second while the drive would use its built in ECC (error correction) to get the job done. If this drive were to have had a TLER feature, I would definitely have lost data and files instead of just having to wait.

     

    This may be a bit confusing, but TLER is a great feature for a RAID array used for enterprise business purposes. It is terrible for RAID 0 or single-disk installations.

     

    Whew!

     

    Hope this helps - bottom line, drives intended for RAID are BAD for RAID 0.

     

    Jim

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 11, 2011 7:19 PM   in reply to Bill Gehrke

    No, the OS and project file is on a WD Black Drive.  The capture files are on a RAID 0 array and the render files are on a 2nd RAID 0 array.  The OS drive has a dual boot hence the 2 partitions.  The RAID drives are single partitions.

     

    I was confused because I read a few posts suggesting putting the project file on the capture drive.  I only put my render files on the same drive as my captured clips temporarily because my render array just died.

     

    Now that I'm putting in 2 completely new replacement arrays I was wondering what the best setup and drives were.  I know RAID 0 is not as reliable since there is no mirror but I still want to get as stable and speedy a setup as possible.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 11, 2011 7:33 PM   in reply to JEShort01

    One more thing, WD definitely does not allow for TLER to be turned on for any of their non-RAID, non-Enterprise, drives manufactured in approx. the past 2 years. They may or may not allow for RAID drives to have TLER turned on/off and allow for the user to adjust the timeout. RE3 drives for certain allow for this to be done, I can't speak for RE4 drives.

     

    So, it may be possible to turn off TLER on the RE4 drives and then they would work fine with RAID 0. If you want to try, Google TLER to find the utility; I don't think that WD has given it to users for at least 3 years now.

     

    I was upset, as were many hobbiests building RAIDs with WD Blacks on the cheap, when WD stopped allowing their TLER utility to work for their early 32MB cach 1TB Black series drives; however, so far as I know, no other vendor ever had a utility where this could be done by users. I did not mention it, but all HD suppliers charge a huge premium for their "RAID" drives, even when they sometimes appear to be awfully similar, as was the case 3 years ago with WD 1TB RE3 drives vs. 1TB Blacks.

     

    Jim

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 11, 2011 7:37 PM   in reply to JEShort01

    Thanks so much Jim.  This really clarifies things.  That said, what 1TB drives would you recommend if I still wanted to do RAID 0?

     

    I have an Adaptec 5405 RAID controller and want to use (4) 1 TB drives with it.  What RAID configuration would you suggest that would be best suited for DV and AVCHD editing?  I'm a little fuzzy on the types of RAID setups.

     

    Is there a RAID option that would give me the performance of RAID 0 with (2) 1 TB drives combined and then mirrored for better data protection?  The result would be that render and capture files would be on the same array.  Would this be a performance issue for HD video editing or in general?

     

    Thanks for your patience:)

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 11, 2011 7:40 PM   in reply to JEShort01

    When I spoke to WD they said that TLER can't be disabled or adjusted for the Black or RE4 drives.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 12, 2011 5:58 AM   in reply to blackrosekiller

    What you want for your four drives is RAID 10, theorticlly gives you the speed of two drives in RAID 0 with two drives mirroring those two.  After you set it up you might want to test it to check the performance as I do not know what the Adaptec is capable of doing.  Of course you could ao try it with your onboard Intel controller.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 12, 2011 6:31 AM   in reply to blackrosekiller

    Actually, TLER is permanently disabled on the Black drives - and all of the other "consumer" desktop WD drives - manufactured since October 2009. (The manufacturing date is the date on the drive's label, not the date of purchase.) There is no way at all whatsoever to enable TLER on the Black or on any other "consumer" desktop WD drive made recently.

     

    That makes the WD desktop drives ill-suited for use in a parity RAID (RAID 3, 5 or 6) since most RAID controllers themselves give up reading after 8 seconds when they encounter a read error - and they mark the entire drive as "failed" even though it is actually still good. That's bad.

     

    The RE-series drives are not recommended for RAID 0 (which Harm calls "aid0") simply because they offer no advantages at all whatsoever over a conventional desktop drive for this purpose. In fact, if one drive has a read error, the entire RAIDed pair or coupling may be dropped, resulting in possible loss of all of the data in the array.

     

    Message was edited by: RjL190365

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 12, 2011 8:08 AM   in reply to RjL190365

    ONLY the desktop drives have TLER disabled (thank goodness)

    RE most certainly have TLER.

     

    desktop for Raid 0,1,10 (only 0 makes sense)

    for parity raid (5,6) RE drives are needed

     

    for those on a budget (dont want to buy an 8 drive raid array and "good" raid card)

    2x 2 drive raid 0 is the best option and more than enough for most peoples needs.

     

    Raid 10 is a waste unless you want low budget redundacy using the onboard raid

    problem with that is its slower than 2 x 2 raid 0

     

    you should never read and write from the same drive set this slows your exports by a good amount.

     

    nothing replaces a good external back up regardless of what your drive config is.

     

    Scott

    ADK

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 12, 2011 8:59 AM   in reply to Scott Chichelli

    Thanks.  So if I wanted to do 2 RAID 0 arrays what hard drives would you recommend using and what's your experience with long term stability?  I backup nightly to an external 2 TB drive and clone the drives weekly to a 3 TB since ther eis no mirror.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 12, 2011 9:25 AM   in reply to blackrosekiller

    I like the WD blacks due to the 64meg cache 90% of our NLE systems ship with 2 x2 drive raid 0 with these drives

    as far as reliability we sell a ton of those and a ton of seagates on the audio side of things (quieter) (about 3-400 a month)

    don’t have issues with either.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 12, 2011 9:27 AM   in reply to blackrosekiller

    I just heard back from Adaptec and they are telling me that my Adaptec 5405 is fine to use with WD RE4 drives on RAID0 and that TLER is a good thing too.  I'm hearing such vastly different answers that this is confusing.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 12, 2011 9:34 AM   in reply to blackrosekiller

    TLER is NOT good for raid 0 well its pointless

    TLER is required (if you not want issues) for raid 5,6

     

    I would do an onboard raid 0 (export) and a raid 5 with the Adpatec for media and other

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 12, 2011 9:49 AM   in reply to blackrosekiller

    Not understadning why you would want Two sets of RAID0 drives.

     

    Videoguys recommends the following:

     

    C: Boot drive. 500GB or bigger. A 7200 RPM drive willwork just fine. If you want faster bootup and program opens, right now a 10K RPM drive is a better value then SSD, but not as fast.


    D: RAID for Video.Can be internal or external. For External we recommend G-Tech and Glyph.

    •           Option 1:A pair of drives  RAID0 gives you performance and value. 2 x 2TB= 4TB of usable space, but no redundancy if a drive fails.
    •           Option 2: 4 drives set up as a RAID 5. This gives you performance plus redundancy. 4 x 2TB = 6TB of usable space

     

    E: Export drive. Single 7200RPM drive. Your exports will go smoother and faster if you output the files to a dedicated physical drive, rather then the D: RAID. You can also set up a partition or folder on your C: drive for the exports. Not as good as a dedicated drive, but better then exporting to the same drives as your project resides on. Another benefit of having a dedicated E: drive is that you can use it for back-ups, digital photo library, MP3 library, etc.

     

    You can find this plus a whole lot more info in Videoguys Video Storage FAQ

     

    Gary

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 12, 2011 10:09 AM   in reply to Videoguys

    Hi,

     

    I have a 7200rpm WD Black for my Os which I keep my project file on.

     

    I have an E drive (WD Black) just for pictures and documents.

     

    I have a RAID0  for capture.  Why wouldn't I want my render and preview files on a RAID0 array?  Wouldn't it be faster access when you preview on the timeline?  I also find that HD clips play back choppy on non-raided drives so that's why I store my rendered movies on a RAID0 array.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 12, 2011 10:11 AM   in reply to Videoguys

    HI Gary,

    Balance my man balance

    With the raid 0 for export your export is faster.

    Most of my clients biggest complaint is render(export) times

    A single drive would be dog slow unless you are talking about DV/HDV

    External is good for 1 thing only back up.  Based on cost factor..

    Most cases have enough room for plenty of internal.

     

    Still thinking about your email... not ignoring you.

     

    Thanks

    Scott

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 12, 2011 10:22 AM   in reply to Scott Chichelli

    Got it. I didn't realize the second RAID 0 was for the export. That makes perfect sense.

     

    Have you guys tested exporting to an SSD drive? That would be even faster and even a 128GB SSD should be big enough for any export files.

     

    GAry

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 12, 2011 10:31 AM   in reply to Videoguys

    HI Gary,

    We tried multiple configs with SSD

    As OS, as a tempfile/cache only drive (no one needs this at all anyway) 2 sets raid 0 etc etc

    Its was only a few seconds faster with the 2 sets raid 0 SSD than standard 2 sets raid 0 sata.

    From a 30 minute time so complete waste of $

    Its more that A: the cpu is a bottleneck at that point and B: also have reached bus/drive thruput saturation.

    Had i  tried it with red4k it might have been different.

    Now heavy animators can definitely take advantage of SSD

     

    Scott

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 12, 2011 3:30 PM   in reply to Scott Chichelli

    WOW, I have just returned from a very busy week (you may have heard about our riots). Anyhow, to 21 emails and some fascinating info.

     

     

    Having just ordered:

     

     

     

    CS5.5 Production Premium

    Antec 902 v3

    1050w Corsair

    Rampage lll Extreme

    i7 990x with Akasa Venom h/s

    24GB (6x4) Corair XMS3

    Gainward GTX580 1536Mb GDDR3

     

     

    WD6000HLHX 10k o/s programmes

    3 x WD1001FALS Video work (2 intended to be RAID 0)

    1 x WD1001FALS

    Stills/audio/graphic design work

    1 x External 1TB Buffalo (back-up data)

    LG BH10LS30

     

     

    ASUS 27" 2MS monitor

     

     

    Around my drive set up - has anyone got any criticism?

    Anything I have missed/could do with?

    Maybe you have an idea or two to suggest an efficient set-up for the above?

     

     

    It's not too late for me to make changes.

    Peter

     

     

     

    Date: Fri, 12 Aug 2011 11:33:55 -0600

    From: forums@adobe.com

    To: peterbaylis@live.co.uk

    Subject: Re: System requirements for Premiere Pro CS5 System requirements for Premiere Pro CS5

     

    HI Gary,

    We tried multiple configs with SSD

    As OS, as a tempfile/cache only drive (no one needs this at all anyway) 2 sets raid 0 etc etc

    Its was only a few seconds faster with the 2 sets raid 0 SSD than standard 2 sets raid 0 sata.

    From a 30 minute time so complete waste of $

    Its more that A: the cpu is a bottleneck at that point and B: also have reached bus/drive thruput saturation.

    Had i  tried it with red4k it might have been different.

    Now heavy animators can definitely take advantage of SSD

     

    Scott

    >

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 12, 2011 4:44 PM   in reply to PeterB55

    Peter,

     

    Your system spec. sounds great!

     

    I would suggest spending just the slightest bit more ($27 using Newegg pricing as a reference, and actually less if you send in for the rebate) to go with an Intel 510 series 120GB drive for OS/programs. Of course if you really need more space for the OS drive, this would not work, but if 120GB is enough the SSD read speed and seek performance blow away the VR. Yes I realize many here say VR is a great OS drive and more affordable than SSDs, but once you get to the price point for the 600GB size they are not less $ (only less per $/GB). SSDs do not work well for video work, but they are awesome OS/program drives.

     

    Another minor point, I prefer Cooler Master's deeper chassis design with the large, slow, quiet fans for drive cooling and rear exhaust (i.e. HAF 932, HAF-X, etc.).

     

    Jim

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 13, 2011 5:55 AM   in reply to JEShort01

    Thanks Jim I will check those out now.

    Peter

     

     

    Date: Fri, 12 Aug 2011 17:44:42 -0600

    From: forums@adobe.com

    To: peterbaylis@live.co.uk

    Subject: Re: System requirements for Premiere Pro CS5 System requirements for Premiere Pro CS5

     

    Peter,

     

    Your system spec. sounds great!

     

    I would suggest spending just the slightest bit more ($27 using Newegg pricing as a reference, and actually less if you send in for the rebate) to go with an Intel 510 series 120GB drive for OS/programs. Of course if you really need more space for the OS drive, this would not work, but if 120GB is enough the SSD read speed and seek performance blow away the VR. Yes I realize many here say VR is a great OS drive and more affordable than SSDs, but once you get to the price point for the 600GB size they are not less $ (only less per $/GB). SSDs do not work well for video work, but they are awesome OS/program drives.

     

    Another minor point, I prefer Cooler Master's deeper chassis design with the large, slow, quiet fans for drive cooling and rear exhaust (i.e. HAF 932, HAF-X, etc.).

     

    Jim

    >

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 14, 2011 11:11 AM   in reply to blackrosekiller

    Do not ever, ever, ever use RAID 0.  It may be the fastest, and one of the

    cheapest, but you get what you pay for, the most UNRELIABLE.  Yea, I can

    here it now, I have been using it for years with no problems, it works well

    for me, and all of that stuff.  Don't be fooled, it is twice (almost) as

    fast as a single drive, but also twice as likely to fail and loose data.  If

    you are doing this as a profession, then use the slower RAID 1 so you can

    have the added reliability even though it is slower.  If you want the speed

    of RAID 0 the use the RAID 10 which will give you speed of RAID 0 and

    reliability of RAID 1 together.  Believe me, if you loose important data the

    is not recoverable of very time consuming, you will quickly understand the

    importance of what I said.  However, RAID 10 needs 5 or more drives.

     

    Also, you can capture and render on the same drive setup, but it does take

    up more space.  Capturing and rendering on separate drives or drive systems

    give a little more reliability which is not needed for RAID 10, but better

    for RAID 0.

     

    Tom

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 14, 2011 11:24 AM   in reply to Photo_1985
    Do not ever, ever, ever use RAID 0.

    I beg to differ.  I have 2x 1 TB RAID0s; one for media and one for Projects/Renders.  The trick is to have reliable and frequent backups.  I have a 4 TB RAID5 as a backup destination, and I use StorageCraft's ShadowProtect as my backup software.  It's set to automatically make a full backup twice a week at 2 AM, and to make incremental backups every 2 hours daily.  Because of the way that ShadowProtect makes backups, at the sector level and writing only changed sectors, most of my 2-hourly backups take less than 3 seconds.  And when it occasionally turns out that hundreds of MBs or even a couple of GBs need backing up when the scheduled backup starts, ShadowProtect runs in the background with minimal (read: almost unnoticeable) performance degradation and is still incredibly fast.

     

    So you *can* use a RAID0, you just have to be smart about it.

     

    -Jeff

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 14, 2011 11:47 AM   in reply to Jeff Bellune

    Well, you should always back up and you made a very good point.  However,

    depending on how time crunched you are with your work load, recovering from

    a back up is not the fastest process in the world.  Just replacing a hard

    drive is much quicker.

     

    Let me give an example of what I mean:

    1)  If you are working on a project and you have a hard drive failure, doing

    your way requires replacement of a hard drive, loading the hard drives to

    where you were up to two hours ago, redo all the work that was not on the

    backup (up to two hours) and then you are back to square one and ready to

    continue.

     

    2)  If you are working on a project and you have a hard drive failure, doing

    my way requires no action at the time and no data lost.  Just a little

    slower for a short time while the drive is loaded up, but you can continue

    on with your work without stopping.  Then when you have time, you can

    replace the hard drive.

     

    It is important to remember that you are twice as likely to have data loss

    failure with RAID 0 then a single drive non-RAID setup.  I don't know about

    you, but that slow down is not worth the little added cost going to RAID 10.

    And for those that have not recovered from a hard drive failure, let me

    just say this, it ain't fun.  In fact it is lost revenue, revenue that could

    have been put on the RAID 10 set up to began with.

     

    Tom

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 14, 2011 12:08 PM   in reply to Photo_1985

    I can mount my backup image from 2 hours ago (worst case) as a virtual drive and be back to work in literally seconds.  (And since I can choose the backup interval, I can cut that worst case time down to 30 minutes or less if I really wanted to.)  At the same time, I can start copying the files from the RAID5 back to the new RAID0, provided I have a spare drive (I have 3 on the shelf right now).  So in 40 minutes, give or take, my RAID0 will be back to normal.

     

    Multitasking rules!

     

    -Jeff

     

    EDIT:  It would be less-than-fair of me if I didn't acknowledge that your setup is a little (or a lot) faster for recovery in almost all cases.  However, I wanted to point out that with good backup software and a good backup plan, the phrase "Do not ever, ever, ever use RAID 0" simply does not apply.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 14, 2011 12:14 PM   in reply to Jeff Bellune

    Understand.  But why not spend a little extra for RAID 10?

     

    You are using RAID 5 and 0 for a reason and RAID 10 is such a short hop to

    the top.  I know, because the speed of RAID 0 is addictive.  Using Solid

    State drives, RAID 0 is soooooooo Fast but....  That's why I went to RAID 10

    because i want speed too with added reliability along with backup.  Anyways,

    I do agree that if you are using RAID 0, you need to be smart about it or it

    may be a lot of work you do not want.

    Tom

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 14, 2011 1:52 PM   in reply to Photo_1985

    So here's where I'm at.  I had ordered 4 Western Digital RE4 drives to do (2) 2 TB RAID 0 arrays to replace one array that failed.  These were to be mounted on an Adaptec 5405.  In the iterim, I have hear a lot of people saying in this thread not to use the RE4s in RAID 0 because of the TLER feature.  Western Digital, my computer company and Adaptec have all told me that there should be no issues due to TLER.

     

    That being said, as soon as my Premiere Pro CS5.5 DV project began to load the array dropped offline.  I have run several verify tests (each time getting a compare error on one of the drives in the array) and rebuilt the array and restored the data twice only to have the same issue happen.  I want to point out that the array that fails is not the same array that failed previously causing me to replace the drives.

     

    I'm now in the process of doing a secure erase (which seems to be equivalent to a low level format) on each drive in the array before once again creating the array and restoring the data one last time for a test.  I found a note on Adaptec's site saying that this is a last resort to determine if there is a hard drive problem. This problem will ensure that all data is cleaned from the drive and com[pletely wipe out the stripe. I'm on the fence if this issue is due to compatability, a bum new drive or a failing controller card.  The card is only 2 years old.

     

    I restored the backup to the 2nd array and it seems to be fine so it doens't seem to be bad data.

     

    When I set the drives up I left the stripe at 256k.  I turned on MaxIQ which is a cache enhancement.  The allocation size was set to 32k.

     

    Any thoughts as to what the problem might be?

     

    I can't fit another drive in to do a RAID 10.  I do backup files nightly and do a clone weekly.  I know this is not the most reliable.

     

    Any suggestions on what the best current drives on the market are to do a RAID 0?  Not sure I can afford Velociraptors.  Besides I have heard that they run hot.

     

    I have 6 case fans but really don't wnat to push my machine too hard.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 14, 2011 3:23 PM   in reply to blackrosekiller

    From my point of view try using your drives as a single drive and see if

    they work ok, then test ok.  If they work fine, then I would replace the

    controller card.  I don't think your errors are compatibility issues.  Make

    sure you can return the card if it does not help, but I feel this is going

    to be the problem.  Ya, I know it is such a pain when there are problems.

     

    Make sure you back up all the time, and back up when you take a break for a

    little while.

    Tom

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 20, 2013 3:03 PM   in reply to Harm Millaard

    I have a Dell Optiplex 760 I got for $60.00 it has 4 gb ram 500gb hard drive intel quad 3.0ghz CPU. I want to run premiere pro cs5.0 do you see any problems I might have. I plan on running Vista business 64 bit. and I am going to upgrade to 8gb of ram.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 20, 2013 3:58 PM   in reply to roddiehorton

    Great machine for your kids. Lousy for editing anything.

     

    Tweakers Page - What kind of PC to use?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 20, 2013 4:22 PM   in reply to roddiehorton

    Hi roddiehorton,

     

    Ya I see lots of issues.  I have 24 gb of ram and often wished I had more.  First I would not go to 8 gb of RAM but go to 16 Gb.  Also, I would go to 1 Tb of hard drive and a fast hard drive as well.  I use only Solid State and in a RAID 0 Config for added speed. 

    This is a great program, but it will be click and wait with poor playback without rendering if you dont have the memory and fast hard drive.  Its like having a Corvette Stingray C7 with a 2 speed transmission and a 4 cylinder engine and most importantly only a AM radio.

     

    Important to note, the cost of memory and hard drives (even SSD Hard Drive) are rather low.

     

    Tom

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 20, 2013 6:28 PM   in reply to Photo_1985

    This is for starting out until I learn to edit using Premiere. Best of all the price was only $60.00 and I took the 500gb hard drive out of my Dell Optiplex GX620. I ordered the 64 bit version of Vista yesterday off ebay for $12.99 (Dell Windows Vista restore disk.) So for $72.00 I get to play with Premiere until I actually pay for it. I saw a Full Suite for $1000.00 on ebay. So I guess I'll buy it or something, then upgrade at a later date.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 20, 2013 6:31 PM   in reply to roddiehorton

    I thought I would add I have an older version of Adobe Premiere 6.5 installed on a 2 ghz Centrino CPU with 2 GB RAM but it works...LOL....

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 22, 2013 2:18 PM   in reply to roddiehorton

    Hi again,

    The problem with using underpowered computers to test software like this is it turns you off because of slow and unexpected response.  The only way to get a good feel how it is going to work for you is to have the system you intend to use.  Also, you can purchase the full suite using the Adobe Cloud for $79 a month or $29 per month for Pre Pro only.   If I was to start today, that's how I would do it.  Then it is always updated and believe me, Pre Pro CC is a fine machine but you better have lots of memory.

    Also, the full suite on the cloud is free for 30 days.  Go to https://creative.adobe.com/products

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 22, 2013 3:05 PM   in reply to roddiehorton

    >64 bit version of Vista yesterday off ebay

     

    That may or may NOT work... Vista is not a tested-supported OS for CS5 and later, only Win7

     

    >Full Suite for $1000.00 on ebay

     

    Be careful of buying software on eBay!!! http://forums.adobe.com/message/1636890

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 23, 2013 6:57 AM   in reply to Photo_1985

    Hey 84 photo_1985,

    You just saved me $1000.00. Is adobe Premiere Pro Cloud supported on windows 8?  I would assume it is. Just asking to be sure. I can upgrade to windows 8 pro for less than $60.00. I am a computer tech in a former life. Therefore I can install Windows 8 pro myself. After I upgrade to 8 gb ram. My machine only holds 8 gb. it will have to do for now. I will only be doing small AB with few transitions no special effects or anything major. Just trying to expand on my capabilities. Will upgrade to I-12 CPU with 24 cores and 512 GB ram and 20TB Hard Drive RAID of course and windows 21 when it comes out. Gee, I developed a sense of humor. LOL. You guys have truly been helpful Will go with the subscription for $29.00 for Premiere Pro. Thanks again. You guys are great I believe I will enjoy keeping up with you guys in this forum. Also, rest assured, as I get more familiar with Premiere Pro Cloud, I will invest in a more powerful machine.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 23, 2013 8:28 AM   in reply to roddiehorton

    CC works fine on Win 8. You really want 16GB of ram for CC and HD media when you can. That would be the first goal at some point.

     

    Eric

    ADK

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 23, 2013 11:39 AM   in reply to roddiehorton

    Strongly suggest Win 8.1 if you were considering 8!

     

    Jim

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 24, 2013 2:27 AM   in reply to roddiehorton
    roddiehorton,

    Yes for Windows 8 but upgrade to 8.1 for the better performance.  For the desktop I still perfer Windows 7, but everyone has the favorite.  Both Eric and Jim  are correct and offer some good advice too.

     

    Tom

     
    |
    Mark as:
1 2 3 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)