Skip navigation
derekfeddon
Currently Being Moderated

AIR 2.6 SDK : APKPackager.setDebugHost Error

Mar 22, 2011 6:16 AM

I've had no problem at all launching my Android AIR app on my Samsung Vibrant phone.

 

However, I just downloaded installed the new AIR 2.6 SDK, updated my application descriptor to 2.6 and can test without issue on the desktop; however, attempting to either Run or Debug on my phone avails the following error:

 

An internal error occurred during: "Launching Rhuz - Mobile".

com.adobe.air.apk.APKPackager.setDebugHost(Ljava/lang/String;)V

 

If I switch my compiler settings back to 2.5 and revert the descriptor, I can still test on desktop and phone.  The issue only appears with the 2.6 SDK.

 

Google is no help at all, so I'm giving it a shot here.  I'm running Flash Builder Burrito on Win 7 x64.

 
Replies
  • Currently Being Moderated
    Mar 22, 2011 6:27 AM   in reply to derekfeddon

    Same problem here. On OS X 10.6.6.

     
    |
    Mark as:
  • Chris Campbell
    9,456 posts
    May 4, 2010
    Currently Being Moderated
    Mar 22, 2011 9:38 AM   in reply to oposit_dk

    Hi guys,

    Thanks for the report.  I'll look into this and get back to you asap.

     

    Chris

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 22, 2011 12:03 PM   in reply to derekfeddon

    Hi drekfeddon

     

    Thank you for reporting your issue. I am a QA in AIR Android team and would like to investigate your issue further but I will need your help.  Could you provide us your zipped source code and your Android AIR application?

     

    Regards,

    Hiroko

     
    |
    Mark as:
  • Chris Campbell
    9,456 posts
    May 4, 2010
    Currently Being Moderated
    Mar 22, 2011 12:10 PM   in reply to derekfeddon

    If you'd like, you can email them to ccampbel@adobe.com and I'll forward them along to Hiroko.

     

    Chris

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 22, 2011 3:05 PM   in reply to derekfeddon

    Hi,

     

    Flash Builder Burrito (Preview release) does not support AIR SDK 2.6 because some APIs have changed in the AIR SDK 2.6 and Flash Builder Burrito does not aware of those changes. Therefore, what you are seeing is an expected behavior.

     

    Please let me know if you have any other questions.

     

    Thanks,

    Sedat Akkus

    Computer Scientist, Flash Builder

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 22, 2011 3:58 PM   in reply to derekfeddon

    FB 4.0.1 does not support mobile application development. If you would like to build AIR applications for Android platform, FB Burrito Preview Release is pretty much the only option until the final product, which supports AIR SDK 2.6, gets released.

     

    Another option is to build your application using Burrito and package output swf and assets with AIR SDK 2.6 command line tools.

     

    -Sedat

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 22, 2011 8:43 PM   in reply to derekfeddon

    i got a same problem, too.

     

    On Mac OS X 10.6.7

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 24, 2011 3:41 PM   in reply to oposit_dk

    Hi, i have the same problem on:

    - Win Vista,

    - AIR 2.6

    - FB Burrito

    - Motorola Droid

     

    regards

    Lucas

     
    |
    Mark as:
  • Chris Campbell
    9,456 posts
    May 4, 2010
    Currently Being Moderated
    Mar 24, 2011 4:42 PM   in reply to lucasbuyo

    For those interested in using 2.6 with Flash Builder 4, please check out Christian Cantrell's blog where he describes a compiler argument that can be added to your project that will allow you to work around the problem:

     

    How to Use AIR 2.6 with Flash Builder 4

     

    Chris

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points