Skip navigation
Currently Being Moderated

No access to CF administrator after installation

Mar 28, 2011 10:49 AM

CF9 has been installed on  Windows server 2008.

Successfull.

 

I can see CF9 files on disk C:\ColdFusion9

 

I have the CFIDE structure installed on disk D:\wwwroot\CFIDE

 

And when launching :

http://127.0.0.1/CFIDE/administrator/index.cfm

can't find the file

I tried the Sever IP adress :

http://85.14.138.81/CFIDE/administrator/index.cfm

same, can't find the file.

 

Can someone help/explain where could be the problem ?

It seems to be a problem of  IP pointing ?

 

Thanks for any help.

I do not have the hand on the IP.

Pierre.

 
Replies
  • Currently Being Moderated
    Mar 28, 2011 10:55 AM   in reply to plarts

    Try to access the page using the following URL. This is the same URL with port number.

    http://127.0.0.1:8500/CFIDE/administrator/index.cfm

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 28, 2011 12:08 PM   in reply to plarts

    What web site (IIS I presume) do you have associated with that webroot, "D:\wwwroot\"?  If it is NOT the 'default' web site, the local loopback IP of 127.0.0.1 will not work.

     

    You would use the domain name and|or IP{:port} address to that web site.

     

    If you have NO web site configured to that webroot, then your browser is NEVER going to find it.

     

    If you do not have ColdFusion connected to that web site with the "Web Server Connector" tool, then the ColdFusion code is not going to work.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 28, 2011 12:50 PM   in reply to plarts

    plarts wrote:

     

    Yes I am using IIS v7.

    Pointing on D:\wwwroot,

    port is : 80

     

    WHAT is pointing to D:\wwwroot?

     

    plarts wrote:

     

    I have never seen this in previous versions.

    What it is ?

     

    Well it HAS been there since version 6.  It is a tool that is used to create the connections between the web server (I.E. IIS) to the ColdFusion Java Server.  If all goes well, AND you are just using one connection, then it is run as part of the installation process.

     

    But, if you desire more then one connection OR something does not go well.  It is advisable to be familar with the Web Server Connector Tool.  It can often be found in the ColdFusion directory under the Windows START menu.  Or one can search for the "wsconfig.jar" file.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 28, 2011 12:56 PM   in reply to plarts

    The web server connector is not new in CF 9. It's been there since 6.

     

    Can you clarify: you report this as being a problem with the CF Admin, but are you able to run any CF code at all? If not, then since you mention being on IIS 7, and you said you were on CF9, let's be more specific: are you on 9.0? or 9.0.1 (the free updater)? If not the latter, then your problem is probably simply that CF 9 doesn't support IIS 7 (out of the box). You can make it work with several manual steps.

     

    But the easiest solution is simply to implement the update (and no, it doesn't matter if you downloaded "CF9" from the Adobe site yesterday: they did NOT rebuild the CF 9 installer, so you need to install first CF9 and then the 9.0.1 updater). During the install of the updater, you will be asked about integrating with IIS and at that time you should find things will work.

     

    If not, or if you're saying that either you ARE on 9.0.1 or regardless that CFML code works other than the CF Admin, then I would assert the problem is something related to where the Admin lives (where you think it is is not where IIS thinks it lives). Here's a simple solution: find the web site where you think it should exist, and in IIS after selecting the site, choose the "content view" tab at the bottom of the screen (to show the files and directories in that site's docroot). Then find the CFIDE directory, then the Administrator directory under that, and right-click on the index.cfm file there and choose "browse".

     

    That will cause IIS to open what IT thinks is the correct URL for the Admin. What happens then?

     

    /charlie arehart

    charlie@carehart.org

    Providing fast, remote, on-demand troubleshooting services for CF (and CFBuilder)

    More at http://www.carehart.org/consulting

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 28, 2011 2:31 PM   in reply to plarts

    Pierre, you say that for your test of an html page, " i have in the URL : D:\wwwroot\CFIDE\administrator\test.html".

     

    To be clear, when you do that, you ARE NOT BROWING the html file using IIS. You are requesting the file directly using the browser and your local file system.

     

    Please review the last email I sent, where I gave specific details of how to have IIS open the file for you. If it cannot (when it tries, using what it thinks to be the correct URL), then you may have a bigger problem. I would suggest you use the same approach to open your test html file. If THAT does not work, then you KNOW that the problem is not about CF. Let us know, and perhaps we can help from based on what you report.

     

    /charlie

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 28, 2011 6:25 PM   in reply to plarts

    Hi Pierre,


    The thread mentions "Web Server Configuration Tool" however I do not see the result of running such in the thread or perhaps I missed something?

     

     

    If  you run tool eg:

    C:\ColdFusion9\runtime\bin\wsconfig.exe

     

     

    You should get something like:

     

    Capture.JPG

     

    HTH, Carl.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 29, 2011 8:58 AM   in reply to plarts

    But Pierre, those steps should not all be required if you installed CF 9.0.1. That's why I said that CF 9 (9.0) did not support IIS 7 directly and required such extra steps. When you said you had installed 9.0.1, that should have relieved the need to do those things. Anyway, thanks for sharing the link. I just added a comment to this effect there, to help others finding it in the future.

     

    And if you are saying that you did install 9.0.1 and STILL needed to follow the steps there, I would find that odd. If you want to elaborate here perhaps others can learn from what you experienced. But I'll understand if you just want to move on now that your problem is solved.

     

    /charlie

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 24, 2013 9:11 PM   in reply to plarts
     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points