Skip navigation
ClayStudio34
Currently Being Moderated

Content on this page requires a newer version of Adobe Flash Player.

Apr 14, 2011 7:14 PM

when I upgraded to internet explorer 9 my flash content displays the text "Content on this page requires a newer version of Adobe Flash Player."

But in Firefox and internet explorer 8 I don't get this message showing up. Can anybody explain to me why this message shows up in IE-9. My website is http://www.claybernard.com/WEBSITES/studio34_0311/animation.html. The html code is:

 

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="170" height="128" id="FLVPlayer6">
    <param name="movie" value="FLVPlayer_Progressive.swf" />
    <param name="quality" value="high" />
    <param name="wmode" value="opaque" />
    <param name="scale" value="noscale" />
    <param name="salign" value="lt" />
    <param name="FlashVars" value="&amp;MM_ComponentVersion=1&amp;skinName=Clear_Skin_1&amp;strea mName=animation_6&amp;autoPlay=true&amp;autoRewind=true" />
    <param name="swfversion" value="8,0,0,0" />
    <!-- This param tag prompts users with Flash Player 6.0 r65 and higher to download the latest version of Flash Player. Delete it if you don’t want users to see the prompt. -->
    <param name="expressinstall" value="Scripts/expressInstall.swf" />
    <!-- Next object tag is for non-IE browsers. So hide it from IE using IECC. -->
    <!--[if !IE]>-->
    <object type="application/x-shockwave-flash" data="FLVPlayer_Progressive.swf" width="170" height="128">
      <!--<![endif]-->
      <param name="quality" value="high" />
      <param name="wmode" value="opaque" />
      <param name="scale" value="noscale" />
      <param name="salign" value="lt" />
      <param name="FlashVars" value="&amp;MM_ComponentVersion=1&amp;skinName=Clear_Skin_1&amp;strea mName=animation_6&amp;autoPlay=true&amp;autoRewind=true" />
      <param name="swfversion" value="8,0,0,0" />
      <param name="expressinstall" value="Scripts/expressInstall.swf" />
      <!-- The browser displays the following alternative content for users with Flash Player 6.0 and older. -->
      <div>
        <h4>Content on this page requires a newer version of Adobe Flash Player.</h4>
        <p><a href="http://www.adobe.com/go/getflashplayer"><img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.g if" alt="Get Adobe Flash player" /></a></p>
      </div>
      <!--[if !IE]>-->
    </object>
    <!--<![endif]-->
  </object>

______________________________________________________________________ __________

 

does it have something to do with the conditional statement

 

"<!--[if !IE]>-->
     </object>
     <!--<![endif]-->
   </object>"

 

Your help would be great

 
Replies
  • Currently Being Moderated
    Apr 14, 2011 7:37 PM   in reply to ClayStudio34

    Download the latest version from this link and then try again:

     

    <http://get.adobe.com/flashplayer/>

     

    Whenever a new browser comes out, I always get an alert message to

    download the latest version for that particular browser. So this

    suggests that flash player needs to re-register itself for it to work in

    a new browser.

     

    hth

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 27, 2011 1:30 PM   in reply to ClayStudio34

    I'm having the exact same problem.  Windows 7 IE 9 gets the video rendered properly, an .flv file, and then the error message is displayed just below the video.  Not an issue with Chrome.  I'm using DreamWeaver CS4 and just re-created the problem by building a new site with nothing on the home page except the one inserted .flv.  I've not made changes to my site until today and I don't recall this happening before now.  At this point, I'm dead in the water about rolling out any chages.  I can't break all my IE 9 users by showing such a nasty gram.  I'm guessing I could just delete the param that shows that message but something is broken and I'm at a loss as to how to handle it.  This is pretty bad and I'm glad I'm not alone...

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 28, 2011 12:29 AM   in reply to ClayStudio34

    And DID you update your player and try again?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 28, 2011 1:51 AM   in reply to Nini Tjäder

    Yes, prompted for and re-installed 3 times.  Same experience as others.  Note that the video is actually rendered successfully and does play.  You just get the error message as well under the video.  Repeatedly.

     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2011 11:54 AM   in reply to ClayStudio34

    I can't stand when I'm looking for a solution and I get to a forum like this and every reply is someone saying, "I'm having the same problem."  Yet, here I sit, typing that I'm having the same problem.  I have been working on a site for a while now that has a small .swf embedded at the top.  Since I upgraded to IE9, I get the upgrade Adobe flash warning and the video above it.  I'd hate to just take that warning out, but I'm tempted.  I've gone and fully removed any trace of adobe flash and reinstalled the most recent versions.  Even if that did fix it, other people would run into the same problem if they had any other version of Flash on their machine.

    This is the ONLY place I've found anyone discussing this issue.

    Thanks for any help.

     
    |
    Mark as:
  • Currently Being Moderated
    May 11, 2011 11:44 AM   in reply to elliottDesign

    This is so frustrating. I did find something that worked for me and even made Claystudio34 site render correctly.

     

    In IE 9, you can turn on the compatability view. The little icon on the address bar next to refresh and cancel. It's a little "broken page" icon. If you select it, it turns on compatability view mode and my issue was solved as was the one on your site.

     

    I know in general what that is doing but I don't understand why the DW generated code is having issues with IE 9 that didn't exist before. I'd like to know if this "solution" works for others.

     

    Regards,

    Travis

     
    |
    Mark as:
  • Currently Being Moderated
    May 11, 2011 12:29 PM   in reply to tlpresley

    One more comment.  You can add the tag:

     

    <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE8" >

     

    as the first tag in the <head> section.  That will force IE8 emulation and the user doesn't have to do anything.  It didn't seem to break Safari, Chrome or Firefox either.  Still not convinced that's the thing to do but at least maybe its the right track.  Still seems Adobe needs to fix their code to handle the right mode in IE9.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 10, 2011 10:31 AM   in reply to tlpresley

    Hi, I tried adding the tag suggested by tlpresley and when I selected "Live View" in DW (CS4), I see the message: The Flash Plugin was not found and an instruction to download the plugin from adobe.com but I can only find the browser player, not a specific plugin for DW.  Having added the above tag, Flash content on my page still behaves the same.  I have also downloaded the latest version of Firefox 4.01 and I now get the same issue with Firefox.  The previous version of Firefox works fine as does IE8 or earlier.

     

    Using IE in "compatability mode" is unsatisfactory as the Flash content runs very slow.  I use 4 frame menu buttons which take too long to reset from "mouse over" state.

     

    Update since my earlier morning's post: I deleted Flash Player and re-installed from firefox after searching for the Firefox plugin.  This version is 10.3.181.22 whearas the IE version is 10.3.181.23.  Firefox now works fine but IE is still unusable.  I downloaded Google Chrome and that works fine with no additional plugin.  I guess this proves it's an IE problem, arather than Adobe.  Very annoying though sine so many people use IE.

     

    If anyone has a fix, I'd be very grateful to know it, as I'm sure would many others.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 10, 2011 5:07 PM   in reply to KGMcNeil

    Using Live View in DW is not the same as what you get on the web site.  What is your web site url?  Does it work OK from the actual web.  It is an Adobe problem that seems to have been largely ignored by them till now.  Browser wars are fun!

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 11, 2011 2:09 AM   in reply to tlpresley

    Yes, I understand that Live View is different to what you would see in a browser.  The site doesn't display correctly from the web either.  Interesting the problem is only manifesting itself in IE now.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 11, 2011 3:33 AM   in reply to KGMcNeil

    The site doesn't display correctly from the web either.


    So what's the website URL?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 11, 2011 5:23 AM   in reply to ClayStudio34

    Hi

    I've had this start to appear too, following upgrade to IE9.

    Oddly, I had some pages that weren't affected and some that were, so after a bit of comparison work I realised what the key difference was and have been able to sort it out.

    I found that the pages with the problem had the <object>...</object> block (containing all the flash stuff) within a <p>...</p> tag. Not sure why that was, but the pages that were fine didn't have this.

    Simply taking out the <p></p> from around the object did the trick, and the warning message has gone away.

     

    Hope this works for you.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 11, 2011 5:56 AM   in reply to Longwave123

    Hi

     

    I am a little late in joining in with this, but as the problem is in IE9 and not earlier IE browsers, this points to the activex filtering being enabled which was only introduced in IE9.

     

    See my post regarding this, here - http://forums.adobe.com/thread/838891.

     

    PZ

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 6, 2011 8:45 AM   in reply to Longwave123

    I don't know about anyone else but Longwave123's solution did the trick.

     

    It seems if you have an .swf object contained in a <p> tag it displays the message "Content on this page..." in IE9.

     

    I thank you for helping solve this mystery, at least for me.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 25, 2011 5:36 PM   in reply to Longwave123

    Wow, thnx to longwave, it worked for me, too!

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 25, 2011 11:56 PM   in reply to philbu2

    Yes, removing the <p> tags as Longwave123 suggests works (many thanks for your help).  I'm very much a novice and I find it very frustrating that Dreamweaver is so keen to put them back in for you!  Manually removing the tags and replacing with <br> is very time consuming.  Wouldn't life be simpler if Microsoft would just fix the code?  My site is www.casaroja.co.uk Firefox and Google Chrome work perfectly.  Come on Microsoft!

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 26, 2011 5:36 AM   in reply to KGMcNeil

    Your site still does not work with IE9 unless you switch to compability view.

     

     

    From: KGMcNeil <forums@adobe.com>

    To: Travis Presley <tlpresley@yahoo.com>

    Sent: Tuesday, July 26, 2011 2:56 AM

    Subject: Re: Content on this page requires a newer version of Adobe Flash Player. Content on this page requires a newer version of Adobe Flash Player.

     

    Yes, removing the

    tags as Longwave123 suggests works (many thanks for your help).  I'm very much a novice and I find it very frustrating that Dreamweaver is so keen to put them back in for you!  Manually removing the tags and replacing with


    is very time consuming.  Wouldn't life be simpler if Microsoft would just fix the code?  My site is http://www.casaroja.co.uk Firefox and Google Chrome work perfectly.  Come on Microsoft!

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 26, 2011 10:23 AM   in reply to tlpresley

    Yes, I'm aware - many thanks.  I had more of these errors per page than you could imagine.  Fixed a few so I know the <p> tag fixes the problem but I haven't had time to do them all.  What I'd like is a global tag replacement

     

    I'll get to it sometime this week.  I have 3 other sites with the same problem.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 24, 2011 11:00 AM   in reply to ClayStudio34

    I had a similar problem. On my testing server, the FLV file played fine, but on the actual website, I got this message. Finally I found the problem: Dreamweaver added a file to the local site (FLVPlayer_Progressive.swf) but didn't tell me about it. Since DW's ftp function is not so hot, I use Filezilla to upload the updated web pages. However, I only uploaded those files that I was aware of. Hence the Internet site was missing this file, so it didn't work. Make sure that you upload FLVPlayer_Progressive.swf file to your online root folder. Adobe!!

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points