Skip navigation
Currently Being Moderated

FMS 4 Not Working After Installation (WAMP Installed Before FMS)

Apr 17, 2011 11:08 AM

I've searched this forum, and unless I skimmed over it, I can't find a solution to this problem; I apologize in advanced if this question HAS been answered previously.


SIDENOTE: This problem occured both before and after WAMP was installed on my computer.


Basically, after I installed FMS 4 and load the homepage in the browser, I receive this message: "We are unable to connect to the network.  We apologize for the inconvenience."


My computer specs are as follows:


OS: Windows 7 Ultimate

Processor: AMD Turion X2 Ultra Dual-Core Moblie ZM-82  2.20 GHz

Memory: 4.00 GB (3.75 GB Usable)

System Type: 64-bit OS


SIDENOTE: During the installations, I've tried both ports 80 and 8080, along with 1935 and 443.


Is there something I'm missing or doing wrong?  Please let me know.


Thank you in advanced!

Adrian-Cortez Jackson

  • Currently Being Moderated
    Apr 18, 2011 10:59 PM   in reply to acjackson_ceo

    Did you install FMS4 with Apache or without Apache?


    Also which port does your external Apache (WAMP) listening to. If its listening to 80, i would suggest stop the FMS and External Apache. Change fms.ini to remove 80 from listening port and also remove :8134 from HTTP Proxy. Once done that start both FMS and Apache.


    Also make sure your firewall allows 1935 if you are trying to open the home page from external machine.

    Mark as:
  • Currently Being Moderated
    Apr 19, 2011 11:39 PM   in reply to acjackson_ceo

    I have never used Windows 7 anytime but assuming it might be same as Windows 2008 - i think steps would be somewhat like below


    Control Panel -> Systems & Security -> Windows Firewall -> Advanced Settings -> Inbound Rules -> Add new rule

    Mark as:
  • Currently Being Moderated
    Apr 20, 2011 1:20 AM   in reply to acjackson_ceo



    Thanks for trying FMS 4. I don't think your problem of no connection to FMS is related to WAMP or firewall settings. Here are few steps that you should try and confirm before we find what's the exact issue :


    Go the FMS installation directory of FMS (if you have taken a 64 bit FMS installer, it will be under c:\program files\adobe\flash media server\ by default, and check under program files (x86) for 32 bit installation), and check the logs folder. There are few log files that would already be generated and they can give some information about connection failures as well as any port bind failures. So if your WAMP is causing any issues, the port binding to 80 should fail which will be logged in one of the log files (edge.00.log).


    The other important task to try is that, on Windows 7, the services (especially the FMS) are not started automatically even though the installer finishes and tries to start the services after the installation is done. This is due to the Windows 7 changes which need explicit admin privileges to start/stop the services. Do the following to start the FMS service properly.


    Type cmd in the start up search box on windows 7. Right click and select run as administrator.
    Once the cmd is opened with admin privileges, type the commands :

    c:\> sc qc fms

    This command confirms the FMS service is installed correctly and its path.

    c:\> net start fms

    c:\> net start fmsadmin

    These two commands should now start the services.


    Now, try and make a connection, you should be able to see successful events.
    Let us know if that helped.

    Thank you ! 

    Mark as:
  • Currently Being Moderated
    Apr 26, 2011 1:20 AM   in reply to acjackson_ceo

    Hi Adrian,

    Good to know that you are able to see some playback

    Did you revert back the changes you made to apache configuration file ? (httpd.conf ). Please make sure the the apache is listening on 8134 ( by confirming in httpd.conf) and also make sure that this is the same port assigned for apache service in fms.ini file .


    fms.ini file (under the fms installation dirrectory\conf folder) should have the following entries :



    HTTPPROXY.HOST = :8134


    This will make sure apache is listening on 8134 and fms is listening on 80. This should solve your HTTP Playback problem.

    The dynamic streaming problem also is little related to the above change because the dynamic streaming playback expects to read from a xml file which is served through apache ! Unless it is properly served, the rtmp connections will not be made. So your one change should solve both of the problems.


    Please let us know.

    Thank you !

    Mark as:
  • Currently Being Moderated
    Apr 26, 2011 2:38 PM   in reply to acjackson_ceo

    No more changes or configurations are needed. The playback for the sample players are supposed to work out of the box as soon as the installation is done.

    Are you trying the playback from the same machine (localhost? ) or from some other machine ? It might as well be some issue with crossdomain.xml if you are trying from some other machine, but thats a very far away guess.


    I am unable to think of any other probable cause for your problem. Windows 7, FMS 4 , default installation, its vanila ..


    let me know if i can help you in any ways to get out of this.

    Thank you !

    Mark as:
  • Currently Being Moderated
    Jun 6, 2011 6:27 PM   in reply to Nikhil Pavan Kalyan

    Having the same problem.  Installation with no changes to settings, RTMP works, HTTP and Dynamic stream do not.


    Tried both FMS 4 and FMS 4.0.2.


    I am running it on Windows Server 2003 Standard x64 Edition.


    Thank you in advance.



    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points