Skip navigation
Currently Being Moderated

PNG showing up with black background

Mar 26, 2009 5:55 PM

All of a sudden my png images with transparent backgrounds are only showing up with black backgrounds in Captivate. I thought it was the photoshop at first but when I tried to pull old png images in that showed up fine before, the black background showed up. ANy ideas? Hopefully I am explaining this clearly.
 
Replies
  • Currently Being Moderated
    Mar 26, 2009 6:02 PM   in reply to rokenn3rd
    Hi there

    Have you tried editing the image properties and choosing a color to be rendered as transparent?

    Cheers... Rick
     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2009 2:32 AM   in reply to rokenn3rd
    Hi there!

    I have the same problem. If you use the transparent functionality in the options all black areas of the picture are transparent. Not the outline area only. That won't help at all!

    Regards
    Markus
     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2009 4:50 PM   in reply to MarkusVolker
    Hi all

    Please report this to Adobe as a bug using the link below.

    Click here to view the Wish Form/Bug Reporting Form

    Cheers... Rick
     
    |
    Mark as:
  • Currently Being Moderated
    Mar 30, 2009 12:52 PM   in reply to rokenn3rd
    I am having the same problem only it's a white background. What the =
    heck? Why do my transparent gifs that I made in Fireworks appear with a =
    background in Captivate? Surely Captivate supports transparency. And =
    if not .. then why the heck NOT?

    I can't believe I never ran into this before.... :(


    --=20
    Nancy Gill
    Adobe Community Expert
    Author: Dreamweaver 8 e-book for the DMX Zone
    Co-Author: Dreamweaver MX: Instant Troubleshooter (August, 2003)
    Technical Editor: Dreamweaver CS3: The Missing Manual,
    DMX 2004: The Complete Reference, DMX 2004: A Beginner's Guide
    Mastering Macromedia Contribute
    Technical Reviewer: Dynamic Dreamweaver MX/DMX: Advanced PHP Web =
    Development

    "rokenn3rd" <webforumsuser@macromedia.com> wrote in message =
    news:gqh866$kng$1@forums.macromedia.com...
    > All of a sudden my png images with transparent backgrounds are only =
    showing up=20
    > with black backgrounds in Captivate. I thought it was the photoshop =
    at first=20
    > but when I tried to pull old png images in that showed up fine before, =
    the=20
    > black background showed up. ANy ideas? Hopefully I am explaining =
    this clearly.
    >
     
    |
    Mark as:
  • Currently Being Moderated
    Mar 30, 2009 12:57 PM   in reply to rokenn3rd
    Oh .. I see .. I can set white to be the transparent color and now it =
    works .. but the type that goes with the button now looks like crap .. =
    and the white within the picture also now is the background color .. =
    which I didn't want. May as well remake them to all be .jpgs with the =
    background color around them. This is disappointing. =20

    Nancy

    "Nancy" <nancy@webwish.com> wrote in message =
    news:gqr7u9$8i6$1@forums.macromedia.com...
    I am having the same problem only it's a white background. What the =
    heck? Why do my transparent gifs that I made in Fireworks appear with a =
    background in Captivate? Surely Captivate supports transparency. And =
    if not .. then why the heck NOT?

    I can't believe I never ran into this before.... :(


    --=20
    Nancy Gill
    Adobe Community Expert
    Author: Dreamweaver 8 e-book for the DMX Zone
    Co-Author: Dreamweaver MX: Instant Troubleshooter (August, 2003)
    Technical Editor: Dreamweaver CS3: The Missing Manual,
    DMX 2004: The Complete Reference, DMX 2004: A Beginner's Guide
    Mastering Macromedia Contribute
    Technical Reviewer: Dynamic Dreamweaver MX/DMX: Advanced PHP Web =
    Development

    "rokenn3rd" <webforumsuser@macromedia.com> wrote in message =
    news:gqh866$kng$1@forums.macromedia.com...
    > All of a sudden my png images with transparent backgrounds are only =
    showing up=20
    > with black backgrounds in Captivate. I thought it was the photoshop =
    at first=20
    > but when I tried to pull old png images in that showed up fine before, =
    the=20
    > black background showed up. ANy ideas? Hopefully I am explaining =
    this clearly.
    >
     
    |
    Mark as:
  • Currently Being Moderated
    May 4, 2009 6:43 AM   in reply to rokenn3rd

    My problem is that the PNG does not appear at all. I can see it in the editor but when i preview the file, its not there.  So, I went ahead and used the jpg version of the same graphic and in Captivate, selected transparent background. I chose "white" and it worked.  the jpg appears with a transparent background!

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 29, 2009 7:55 PM   in reply to rokenn3rd

    In my experience, Captivate 3 seems to interpret the transparency in an image as black if the file size is large.  It seems to happen in the resizing compression.  There are two ways I have found to overcome this:

    1.       The most effective is to reduce the file size to less than 100kb.  For most Captivate projects this still offers a good quality resolution in PNG format.

    2.       Using PhotoShop, lock the transparency then save the file again.  If the save was previously interlaced then choose the opposite (none) this time – reverse if interlaced previously.  Then reimport the file.  This is not always effective but for some quirky reason, sometimes it works.  It will not work with very large files but seems to work with stubborn smaller PNG files, where Captivate is interpreting transparency as black.

    I hope this is of assistance to you.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 7, 2009 7:30 AM   in reply to *designer

    The solution I've found is to just ensure that the image you're importing is smaller than the slide size. If Captivate has to resize or crop your image it (for some reason) interprets transparent space as black. Just resize the image to have a width and height less than that of the slide before importing and all should be well.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 11, 2010 8:34 AM   in reply to rokenn3rd

    I know this is an old thread, but I just came across this problem and found a different solution that I thought I would share just in case it helps someone else.

     

    I used the same custom png button with a transparent background (made in fireworks) for more than 50 projects with no problem.  Suddenly, the black background (with a white border) that others mentioned appeared on the 56th project but only after it was published.  It all appeared fine in the workspace.  None of the solutions above would work.

     

    my solution:  I just merged the image button into the background and then placed a transparent button over it to create the action that I needed.  Hope that helps someone in the future!

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 14, 2011 1:00 AM   in reply to rokenn3rd

    I found solution where I was having the same problem on browsers.

     

    Problem at my end:

     

    I was creating a transparent png's with image editor for web but in internet browsers it was showing a black background instead of transparent background.

     

    Solution as per:

     

    I find problem in my css file. Please check 'img' class in css modify or delete. it will remove the background.

     


    Cheers!

     

    Arsalan

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 25, 2011 10:07 AM   in reply to schematicartist

    I am using Captivate 5. My .png files were not transparent in the web browser exports. The problem was in the properties of the image. Uncheck "Allow Smoothing" and the gradient transparencies all work. This also resolved an issue with transparent text captions that were placed on layers above the .png showing color flashes during transitions.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 7, 2011 11:35 AM   in reply to D L D

    Make sure you have an empty layer below the cropped image before you save as a .png. Turn off the visibility of the layer below before you output. Do not use the "Save for web and devices feature, make sure you use File/Save as...

     

    I'm assuming you're creating the image in PS.

     

    Steve

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 24, 2012 9:34 AM   in reply to Itzelm

    I was having the same problem today (with a 5KB file). I ended up using PS to re-save the .PNG in .GIF format instead. I still had to switch on the background transparency in Captivate. But it turned out relatively well. (Relative to the .JPG that I tried it with---the anti-aliasing with that file format was terrible.)

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points