Skip navigation
Currently Being Moderated

flashbuilder/php/zend partially working

Jun 9, 2011 7:23 PM

I've made a simple application that uses the php service and the zend framework on wamp

The database has three fields, one primary index.

The project creation process works fine and when I create the data service with the wizzard, I get all the CRUD

that I need.


I set up a data grid and bind it to getAll<tablename>.  I run the app and all is fine (I see an empty table)

My network monitor indicates I made a getAll query and it shows an okay result


I set up a Data>generate form wizzard and bind it to create<tablename>(item...)


I run the app and get the datagrid and the form with fields to enter my data, a button to create the item in the table and a result text box


When I enter data and press the create button, I do not get any results ( I should get a 0)  I've stepped through the program and I never get a return token.

My network monitor does not inidicate that I had any network traffic (nothing from my client to the php code on the server)


To make things more interesting, when I do a Data/Services>Test Operation on the create function, I can load a set of data, run the test and it works! Data shows up in my table and the test response code is 0


My question is, how do I debug the php service call on the client side as it does not seem to be working.






More information:


I loaded flashbuilder 4.5 on another windows system with wamp and zend and got exactly the same result.

I now have two systems that do exactly the same thing.  I have a zipped directory of the project and can send it to someone who might

be interested in this bug.


As I step through the code I reach the operationManager object and the debugger can no longer see the code (it is part of the mx libraries I guess).

At any rate, there is never a network call for the create<>(item...) operation so it must be in the,,




Very frustrating.

  • Currently Being Moderated
    Jul 14, 2011 6:12 PM   in reply to paula_ke



    Thanks A LOT!!! this issue was driving me nuts, Re-cheling every thing for the past week, you really help me out


    Good bye

    Mark as:
  • Currently Being Moderated
    Aug 16, 2011 7:43 AM   in reply to paula_ke

    Hi  Paula,


    Thanks so much for your answer and solution.

    I had the same problem/bug and couldn't resolve it till now.

    Adding the commit() function solved it.


    Thanks again for your time!!!

    Mark as:
  • Currently Being Moderated
    Mar 27, 2012 12:25 PM   in reply to paula_ke

    Hi Paula.....


    Thank you very much paula.... It was really helpful.... Thank you again..... You saved me before getting frustrated for days......

    Mark as:
  • Currently Being Moderated
    Aug 1, 2012 11:41 AM   in reply to paula_ke

    Hey Paula,


    Now I have the "commit();" code before the return of each function in the "" file but I I still get this error and my php-mysql data connection settings are there:


    Error Dialog:


    Channel disconnected

    Channel disconnected before an acknowledgement was received


    If you have any suggestions of what can this be I would truly appreciate your help.  Thank you.

    Mark as:
  • Currently Being Moderated
    Aug 1, 2012 2:34 PM   in reply to paula_ke

    I downloaded a program CHARLES to monitor traffic and find out what’s going on.  Could you elaborate a little bit about Python Service.  Sounds interesting enough J

    Mark as:
  • Currently Being Moderated
    Apr 2, 2014 6:47 AM   in reply to paula_ke

    i dont understand, should I just add "commit();" before return ? i have the same problem, except mine doesnt work even when testing

    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points