Skip navigation
Currently Being Moderated

Framemaker 10 - newer version odd suffix error

Jun 10, 2011 1:31 PM

ERROR MESSAGE: The document was saved to a temporary file, but FrameMaker can't rename it to have the correct name. The newer version has an odd suffix.


I had this problem with Framemaker 9 and never resovled it. What is the problem? I can't see buying Tech Suite 3 with this problem still out there.


I need a resolution.

  • Currently Being Moderated
    Jun 10, 2011 1:39 PM   in reply to Rick Poole

    What are you doing when this occurs?

    Are you doing a save or save-as,

    or is this an auto-save or .recover

    creation failure during a crash?


    What is the object open?


    book component .fm file?


    Are you using the default .book and .fm extensions?


    Are you using anything unusual in the filename prefixes,

    i.e. anything other than latin characters, numbers, and

    punctuation never special-cased or reserved on any

    current or legacy Frame platform?


    Comma, for example, is a problem printing to file

    from Frame on Windows.

    Mark as:
  • Currently Being Moderated
    Jun 10, 2011 1:50 PM   in reply to Rick Poole

    The other thing I'd be looking at would be permissions in whatever location it's trying to manipulate it in.

    Mark as:
  • Currently Being Moderated
    Jun 10, 2011 3:01 PM   in reply to Rick Poole

    Do you use any backup or recovery utilities, SVN, whatever, that run in the background? If so, they could be temporarily grabbing the file just at the same time that FM is trying to write the save, resulting in a collision.


    Are there any messages in your system's event log at the same time? If so, they might help identify the issue.

    Mark as:
  • Currently Being Moderated
    Jun 10, 2011 5:07 PM   in reply to Rick Poole

    I am updating a book.


    Are you doing a save or save-as, or is this an auto-save or .recover creation failure during a crash?




    Well, the Update Book operation, as you probably know, is doing ordinary opens and saves, complete with generating or replacing .backup files.


    What are the remnants of the failure? If you start with no .backup files about, do they get created? Do they open intact?


    I don't have FM10, and have never seen that error message. I have seen file permission problems, but never resulting in that msg.


    Any difference if all the book component files are already open during the Update Book?

    Mark as:
  • Currently Being Moderated
    Jun 10, 2011 7:56 PM   in reply to Rick Poole



    This a function of FM's autosave utility. If this is enabled, then when the time comes to save, FM copies the current file to (where xxx is a random hex value between 000-FFF), then deletes the prior auto-saved file if succcesful and finally renames the .xxx to the file. This three-step is to avoid corruption.


    However, sometimes if there is network congestion, greedy/aggressive virus scanning or you're low on disk space or permissions/policies/ownership aren't properly set (especially under Win7 even when you have admin rights), then the temp file can't be renamed to the proper name and FM complains with the "odd suffix" mesage and leaves the .xxx version as is.


    This issue is totally system dependent and something is interfering with FM's ability to rename at a low level.


    AFAIK, this behaviour has been around FM from at least the first Windows version back in '92


    See also this old thread:

    Mark as:
  • Currently Being Moderated
    May 21, 2013 1:45 PM   in reply to Arnis Gubins

    This is still occuring in FrameMaker 11 and Windows 7.


    So we can put it down to stupid Microsoft and IT tricks.

    Mark as:
  • Currently Being Moderated
    May 22, 2013 7:08 AM   in reply to Rick Poole

    I can't change my anti-virus software, Corporate IT policies.


    However, I do believe that the culprit in my case is either the permissions, or very likely network latency.


    The reason I believe the latter is that our IT department has our My Documents folder linked to a network drive location for our My Documents folder. This means that the local information in that folder is mirrored to a network location.


    I verified correct file saving operation by moving my working files from My Documents to a folder under the C:\ root. This gave two advantages, first being increased speed, the second being that the file extension error immediately disappeared.

    Mark as:
  • Currently Being Moderated
    Jan 14, 2014 9:42 AM   in reply to Rick Poole

    I had the "odd suffix error" problem, and played around with various things to try to fix it. Finally I had success with this: I had deleted an appendix file, and it was reappearing. This time I deleted it a different way and it worked. Previously I had gone into the book file, right clicked on the file and chosen delete. This time I went into the book file, selected the (grayed-out) file, and then using the menu at the top I did Edit...Delete. This seems completely unrelated to the "odd suffix error" message, but when I did this, it cleared up the odd suffix error problem, and I am now able to save the book file.

    Mark as:
  • Currently Being Moderated
    Jan 14, 2014 12:45 PM   in reply to tomslakey



    Both approaches (either from the context menu or from the main menu) in the book file should have deleted the file entry from the book file. If the entry was showing as greyed-out, it means that FM couldn't find that file, e.g. it might have been deleted/moved at the system file level.


    I'm not certain what you mean by the file "reappearing" in your description? Did you save the Book file after deleting?


    Regardless, things were physically changed, which affected what FM was able to write to, so that would have also affected the odd-suffix error.

    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points