Skip navigation
Philip_Lam
Currently Being Moderated

Install self-signed Application without internet connection

Jun 13, 2011 8:12 PM

I am in Window Xp. I build a simple adobe air application(myapp.air which is self signed). I have my PC installed with the latest Adobe Air Runtime. Disconnected from the network, And install myapp.air. The install process is finished without any error. But then I can not see any screen of my application. I can see the process is running with Ctrl+Alt+Del, but no application is running. It happen them same when I click the exe file.

 

I try this over different other application and found that:

 

1) in Marketplace which is signed do not have this problem

http://www.adobe.com/cfusion/marketplace/index.cfm?event=marketplace.o ffering&offeringid=11541&marketplaceid=1

 

2) in Marketplace which is self-signed do not have this problem

http://www.adobe.com/cfusion/marketplace/index.cfm?event=marketplace.o ffering&marketplaceid=1&offeringid=10309

 

3)  third party software which is self-signed have this problem

http://code.google.com/p/gmdesk/downloads/list

 

Below is the log when I install the GMdesk which I didn't see any error:

 

[2011-06-14:11:09:51] Application Installer begin with version 2.6.0.19140 on Windows XP x86
[2011-06-14:11:09:51] Commandline is: "C:\Documents and Settings\Administrator\Desktop\GMDesk-1.01(1).air"
[2011-06-14:11:09:51] Installed runtime (2.6.0.19140) located at c:\Program Files\Common Files\Adobe AIR
[2011-06-14:11:09:52] Unpackaging file:///C:/Documents%20and%20Settings/Administrator/Desktop/GMDesk-1. 01(1).air to C:\Documents and Settings\Administrator\Local Settings\Temp\flaB7.tmp
[2011-06-14:11:09:53] Application signature verified
[2011-06-14:11:09:53] Unpackaging/validation complete
[2011-06-14:11:09:53] No app located for appID 'robertnyman.gmdesk' and pubID 'D5F5507284D8257BC26108689093DFA1D0D2BABB.1'
[2011-06-14:11:09:55] Converting unpackaged application to a native installation package in C:\Documents and Settings\Administrator\Local Settings\Temp\flaB8.tmp
[2011-06-14:11:09:56] Native installation package creation succeeded
[2011-06-14:11:09:56] Starting app installation to C:\Program Files. Installing app robertnyman.gmdesk.D5F5507284D8257BC26108689093DFA1D0D2BABB.1 version 1.01 using the source file at file:///C:/Documents%20and%20Settings/Administrator/Desktop/GMDesk-1. 01(1).air
[2011-06-14:11:09:56] Installing msi at C:\Documents and Settings\Administrator\Local Settings\Temp\flaB8.tmp\setup.msi with guid {071038FB-83F6-7491-F6E9-B2C552BDEDF3}
[2011-06-14:11:09:57] Launching subprocess with commandline C:\Program Files\GMDesk\GMDesk.exe
[2011-06-14:11:09:57] Application Installer end with exit code 0

 

 

Did the same situation happen on your PC? I am not sure with the signing is the reason? Or I missing some step when release my application?

 
Replies

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points