Skip navigation
Currently Being Moderated

problem when build cairngorm from source

Jul 12, 2011 2:26 PM

Hi,

 

I checked out cairngorm from SVN and try to build it using Maven 3.0.3. But I encounter these problems:

1, mvn complaints that "external" scope is not recognized. (see attachment 1)

cairngorm_1.png

2, maybe because item 1 above, the build cannot resolve dependencies and failed (see attachement 2)

cairngorm_2.png

3, in the libraries/pom.xml, the flex sdk version is still 4.1. How can I make it work with flexsdk 4.5.1?

 

Can you help me to figure out how to compile the cairngorm3 correctly?

 

Thanks!

York

 
Replies
  • Currently Being Moderated
    Jul 14, 2011 1:10 PM   in reply to stablizerr

    FYI trunk already supports Flex 4.5.1 already but we've not done a Maven release on that yet.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 18, 2011 9:34 AM   in reply to stablizerr

    are you referncing trunk? Trunk is here just now:

    http://sourceforge.net/adobe/cairngorm/code/827/tree/cairngorm3/trunk/

    You can use the web based SVN via the "Code" button in the top menu bar on SF or http://sourceforge.net/adobe/cairngorm/code/

     

    I see only Flex 4.5 in the top level pom in trunk.

     

    The Popup library comes in different versions. Popup itself doesn't contain a reference to Parsley but there's also a PopupParlsey version. This is only really useful in the older Parsley version that are provided via the wiki because in later Parsley versions, Parsley added the PopUp tag that makes this obsolute.

     

    The Parsley distribution only references the non-Parsley Popup library.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points