Skip navigation
Currently Being Moderated

Away3D 4.0 update for Flash Player 11 beta

Jul 14, 2011 7:15 AM

Congrats to the Flash Player team on the new release!

 

To mark the occasion, we have created a new repo for Away3D 4 that has a few minor updates to run correctly in the new player. update your sources by pointing your clients at:


This will be the repo we will be developing in from now on, so please bear in mind that the broomstick repo will have no more updates as of today. It's been a wild ride, but we had to bid farewell at some point!


over the next few weeks we will be working towards an official beta release for Away3D 4.0. Any questions, please ask!


cheers


Rob

 
Replies
  • Currently Being Moderated
    Jul 16, 2011 10:26 AM   in reply to rob.bateman

    Hi Rob,

     

    Congrats on the milestone and thank you so much for the awesome framework! My Broomstick/Molehill demos no longer work with FP 11 beta. Is there a quick fix for them you can suggest?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 16, 2011 3:45 PM   in reply to rob.bateman

    I've noticed this too, they compile great, but I just get a black screen at runt time...

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 16, 2011 4:56 PM   in reply to Sean S Murphy

    I just recompiled a molehill demo with the new Away3D branch off gitHub and it works great. No problems, just rest my include paths to the new framework and compiled. Still have to compile to -swf-version=13 and of course have the FP 11 beta player installed and active. Demo:

     

    http://www.blam3d.com/demos/f16fp11test.html

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 17, 2011 9:50 AM   in reply to rob.bateman

    I'm just getting started with away3d, and a few problems that I ran into with my setup were the following,

     

    When attempting to incorporate an away3d example in a flex app I kept only seeing a white screen.

    Which after some googling,

     

    http://groups.google.com/group/away3d-dev/browse_thread/thread/5e13cb2 f0d21b5f2

     

    turns out I just needed to set my application's backgroundalpha to 0.

     

     

    I was then faced with only rendering a black screen as well, which for me turned out to be a problem rendering objects as default wireframes.

     

    When I set a color material on my reference cubes and spheres all was well.

     

    I'm sure there are other reasons why the sceen would render only black but hopefully for those having similar simple scene setup problems this will save them some time.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 23, 2011 4:38 AM   in reply to rob.bateman

    Hi,

    I'm trying to use the Away3D 4.0 engine with Flash Player 11 (playerglobal.swc updated & swf-version set to 13), but I get the following errors (see image attached). Can someone please give some guidance as to how to fix these errors? I found this article, but it doesn't address any of these problems. I was able to get Yogurt3D working with Molehill, so I think the problems are on the Away side. Thanks a lot! I'm very excited about the great engine Away3D and FP11!

     

    Screen shot 2011-07-23 at 1.29.39 PM.png

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)