Skip navigation
Didierkaade
Currently Being Moderated

Batch automation with actions.

Jul 15, 2011 9:57 AM

Jeffrey,

 

Thanks for getting back to me, here is what the issue I am having looks like.

 

1) I had Photoshop CS5 on my Dell Precision Laptop.

 

I created an action named "Vintage + BW" that went through these following steps.

 

1) Run "vintage action" that I created beforehand

 

2) save file in a specific location called Vintage (c:\desktop\newfolder\vintage) with all the photoshop details (jpg, Quality 12, as a copy ...etc)

 

3) run another action named "BW" again another action that I had created.

 

4) save file in a specific location called BW (c:\desktop\newfolder\BW) with all the photoshop details (jpg, Quality 12, as a copy ...etc)

 

5) close original file without saving

 

2) I run an automated batch process where I choose action "Vintage + BW"

 

Everything works well, the world is a happy place.

 


This was last week.

 

This week, I remove CS5 from my old Dell, and install it on my new Precision, activate it, and move over the actions from my old system.

 

I run the same action that was working perfectly before, and now it saves everything in the BW folder, as a BW photo.

 

I go into the folder to see what's up, and i see it clearly running the Vintage part of the action, then saving it as as it should, but it is saving it in the root  folder (New Folder).  Then it continues running the 2nd part of the action (BW action), and saving it in the "New folder" as well, thus overwriting the vintage picture.

 

Now, normally, I would understand that it would do that if that box "Override Action "save As" commands" was NOT checked, but as you can see in the picture, it is checked, which means that the save as commands running in the action would take precedence.  Unless I'm not clear on that.

 

Adobe Photoshop CS5 Extended 15072011 121655 PM.bmp.jpg

 

I tried creating a whole new set of actions giving it a different name, following the same steps as before.

 

I had one file open, and started recording a new action. Running Vintage, saving as (vintage Folder), running BW, saving as (bw folder), closing file.

 

I ran the batch again, and this time, what it does is, it saves in the right folder Vintage for Vintage, and BW for BW, but every file in the Batch folder uses the same filename as the one in which I created the action. Which means that every file that gets run through the batch, gets overwritten by the next file that runs through the action.  So while the batch runs, even if I had 100 pictures, there would only be 1 picture in each folder.

 

So no matter what I try, It is not allowing me to run the action properly, and I'm stumped at what I need to do now!

 

Any help would be super appreciated.

 

Thanks a lot,

 

Didier-

 
Replies

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points