Skip navigation
JustinofSLC2
Currently Being Moderated

Error message: Please upgrade your plug-ins to their latest version...

Aug 4, 2011 6:32 PM

Okay,  I'm new.  I don't think I've ever installed plug-ins but apparently I need to update them.  Can anyone direct me to instructions?  I'm running InDesign CS4 6.0.6

 

Much Thanks

 
Replies
  • Currently Being Moderated
    Aug 4, 2011 7:23 PM   in reply to JustinofSLC2

    What plug-ins? Show a screen shot of the error message? Are you, perhaps, trying to open an InDesign file created by a later version of InDesign?

     
    |
    Mark as:
  • John Hawkinson
    5,572 posts
    Jun 25, 2009
    Currently Being Moderated
    Aug 4, 2011 10:16 PM   in reply to JustinofSLC2

    To amplify Scott's answer, a CS5 or CS5.5 file will report "missing plugins" if opened in CS4.

    You'll need to ask the originator to export the file as IDML in order for you to read it, and it's possible there may be text reflow or other problems if CS5 or CS5.5 features are used.

     

    This is a very bad error message -- it doesn't say what it means. Known problem.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 31, 2013 8:32 PM   in reply to John Hawkinson

    App version: CS4 6.0.6

    OS X: 10.6.8

     

    I have encountered the same error message just today and 19 Plug-ins were listed in the "Cannot Open" dialogue box when attempting to open a File.

     

    While awaiting response from File originator on the InDesign version used, my question is whether a Plug-in in question, for example:

    "Assignments.IndesignPlugIn"

     

    does not really exist in CS4, but "Assignment UI.InDesignPlugin" does, under

    (USER) > Applications > Adobe InDesign CS4 > Plug-Ins > InCopyWorkFlow > Assignment UI.InDesignPlugin

    Or,

    • is there a place to download such (and other 18 Plug-Ins asked for in Error Dialogue Box) separate from CS4 6.0.6 upgrade patch to fix error?

     

    • does it, on the other hand, confirm that the File in question asking for those Plug-ins was created on a higher InDesign version and that I should ask for an .inx / IDML file instead?

     

    Thank you.


    Just for the record, the following Plug-Ins were asked for, arr. alphabetically:

    Assignments.IndesignPlugIn

    CJKGrid.IndesignPlugIn

    Document Framework.IndesignPlugIn

    Dynamic Documenst.IndesignPlugIn

    FormField.IndesignPlugIn

    FontManager.IndesignPlugIn

    Generic Page Item.IndesignPlugIn

    Graphics.IndesignPlugIn

    Group.IndesignPlugIn

    InCopy Shared.IndesignPlugIn

    Master Page.IndesignPlugIn

    Path Type.IndesignPlugIn

    Scripting.IndesignPlugIn

    Spread.IndesignPlugIn

    Spline.IndesignPlugIn

    Table Model.IndesignPlugIn

    Text Attributes.IndesignPlugIn

    Text.IndesignPlugIn

     

    Message was edited by: krvilla

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 31, 2013 10:55 PM   in reply to krvilla

    Yes, they need to export the file as Idml for you to open it. Adding the plugins from a later version will not work.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 31, 2013 11:04 PM   in reply to MW Design

    Thank you. Small but informative, helpful info (emphasis mine):

    MW Design wrote:

     

    Yes, they need to export the file as Idml for you to open it. Adding the plugins from a later version will not work.

    I just got a reply and the FIle indeed was created on InDesign CS5 and I've requested for an updated one saved as IDML.

     

    Much appreciated. Cheers ~

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points