Skip navigation
Currently Being Moderated

FM10 Can't generate the TOC with leading dots

Aug 21, 2011 11:15 PM

Hi everybody,

 

I have read some useful threads here about this problem but I still can't seem to be able to resolve this leading dots issue for my TOC.

 

I have already ensured that the reference page for all of my frame files in my Book have the same Reference page TOC entry. When I generate my TOC the leading dots are missing!

 

I then open the Reference page for the TOC file as well and paste in the same TOC entries from my other frame files, and then update the book to regenerate the TOC.

 

This also does not solve the problem.

 

Any help resolving this issue would be really appreciated!

 

Here are screen shots of my Reference page for my TOC(below). I have ensured that this same section is present for all of my book's frame files too (in their Reference page sections for TOCs).

 

ChapterTitleTOC

ChapterTitleTOC.png

Heading1TOC

Heading1TOC.png

Heading2TOC:

Heading2TOC.png

And my generated TOC

Generated TOC.png

 
Replies
  • Currently Being Moderated
    Aug 22, 2011 2:08 AM   in reply to mushhoodpuffer

    A couple of things you should check:

    • Do your paragraph formats Heading1TOC (etc.) have a tab setting in them? It is not sufficient to have the tab setting on the reference page; it must be in the format. (Do an “update all”.)
    • It looks to me as if your page set-up for the TOC has margins that would mean your right-hand tab stop is outside the text box. You need to set it at or inside the right margin.
     
    |
    Mark as:
  • Currently Being Moderated
    Aug 22, 2011 7:26 AM   in reply to mushhoodpuffer

    You need to insert a tab character (i.e. press the TAB key) at the appropriate point in the lines that appear on your reference pages. Then update.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 23, 2011 12:49 AM   in reply to mushhoodpuffer

    I’m puzzled as to what this <PageNumber> is on your reference page. Where did it come from?

     

    Since it’s not a FrameMaker code I’d expect it to show up as exactly that in your TOC, i.e. the word PageNumber between angle brackets. It suggests that for whatever reason there is no link between the reference page and the body pages.

     

    Also, my reference page in a TOC document doesn’t have the words Table of Contents Specification on it. Do you know where that came from?

     

    I’d be tempted to make a new table of contents. Save the one you have as Copy_of_TOC.fm. Then delete it from the book and start again. Don’t bother at first with the paragraph formats, just add the TAB mark in front of the page number on the reference page and see if it is carried over when you generate the TOC.

     

    Bear in mind that it won’t right-align the page numbers at this stage, since no tab has been set in the paragraph. You just need to see if the large bold arrow mark indicating the existence of a tab is there.

     

    If it works to that point you can take it to the next stage and tackle paragraph formats. Importing them from Copy_of_TOC.fm will save some time.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 23, 2011 1:33 AM   in reply to mushhoodpuffer

    Oh, yes, I am being stupid there. The <PageNumber> is a FrameMaker code: it applies the PageNumber character format. Sorry about that.

     

    And I see that the templates have explanatory labels on the reference pages, including Table of Contents Specifications. So that explains that.

     

    If you tell me which template you are using I could try it out this end.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 23, 2011 2:56 AM   in reply to mushhoodpuffer

    Just wondering how you are making the TOC.

     

    You should not be using the TOC file in the templates (except as a source for formats).

     

    Put all your chapters in a book, then, with the book active on-screen, pick from the horizontal menu Add > Table of Contents. A set-up screen appears. Move Heading1, Heading2 and Heading3 from “Don’t Include” to “Include” (i.e. from the right-hand side of the dialogue box to the left-hand side).

     

    Can you confirm that this is what you are doing?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 24, 2011 12:19 AM   in reply to mushhoodpuffer

    Well, I found the same template, and it works as expected for me.

     

    I made a TOC and imported the formats from the TOC template. My TOC did not then have leader dots (but the template isn’t designed that way). Adding tab settings to the paragraph formats and a TAB mark on the reference pages, then regenerating produced this.

     

    screenshot1.png

    To sum up: as far as TOC formats are concerned you can ignore the other book documents. You need:

     

    • in the TOC document: paragraph formats (ChapterTitleTOC, Heading1TOC and Heading2TOC) which have right tabs and leader dots defined
    • also in the TOC document: a TAB mark (shown as >) on the reference page before the <$pagenum> code. (To keep the leader dots the same size and style it would be good to put the TAB before the <PageNumber> character format, but that’s an unnecessary refinement at this stage.)

     

    … and then update the book.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 24, 2011 2:51 AM   in reply to mushhoodpuffer

    If you check my profile you should see my e-mail address. Send me yours and I’ll mail you the TOC file for you to look at.

     

    I am sure this is something simple that I am wrongly presuming you are doing.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 24, 2011 9:33 PM   in reply to mushhoodpuffer

    Mushhood, looking at the screen captures that you posted in your first post, it looks to me like the reason that your tabs aren't working is because they are set to be too far out to the right for them to "take effect" on the paragraph tags.

     

    As a test, I would suggest changing the tab value from 5.76 to something like 3 in your Heading1/2/3TOC tags, apply the change to the paragraph tags and update all. Then save the chapter and regenerate the book.

     

    The value that's used in the tab is calculated from the start of the left of the text frame, so your case the text frame starts at approx 1.75 from the left margin of the page, so your tab would be 5.76 from that, meaning 1.75 + 5.76 = way out in right field, too far for the tab to have any visible effect.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 25, 2011 12:04 AM   in reply to mushhoodpuffer

    >>haven't enabled your email address to be visible

     

    Oh, I thought it was.

     

    Never mind. I have e-mailed you the TOC I made.

     

    Unless you are very lucky, you can’t just rename it to match your book and expect it to work. There is a mysterious relationship between FrameMaker books and related generated files.

     

    Either see if you can tell where the difference is between my version and yours, or import all the formats from mine to yours.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 25, 2011 11:55 PM   in reply to mushhoodpuffer

    The leading space isn’t significant. It’s just that I find sometimes that the dots start a bit too close to the text. A matter of personal preference.

     

    If your document isn’t confidential you could always send it to me. (It would need to be in version 9 format.)

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 29, 2011 2:04 PM   in reply to mushhoodpuffer

    I have this happen all the time in FM9.

     

    Do you already have a TOC in your book file with the correct reference pages?

     

    Sometimes I have to do it twice, I don't know why, but if you have a TOC in your

    book file and then make another TOC, mine usually works...just a thought..

     

    ls

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 11, 2012 6:34 AM   in reply to lsk2002

    I came across this post while looking for an answer to this exact same problem. It looks like it was never successfully resolved though...

    I am also using Framemaker 9, and cannot get the dotted tab leader to display in my TOC, despite having the tab set in the paragraph style and the tab characters on the reference page, and following all the tips here.

    I too can insert the tab manually, the tab just does not get carried over automatically into the real TOC.

    Can anyone shed any more light on this?

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 11, 2012 10:23 AM   in reply to CSIfan

    I have not been following this thread, so maybe this was suggested before.

     

    Check the paragraph style for the TOC entry and make sure that the number of tab stops in the paragraph style is the SAME as the number in the reference page entry.

     

    Having to enter a tab stop manually in the TOC indicates to me that either the tab stop in the paragraph style is too close to the left side OR there is an extra tab stop that is close to the left margin. If this is true, the tab stop created by the TOC reference page is taking its value from the first tab stop in the paragraph style, which may be too close to the left for there to be any space. Adding a tab manually causes the second tab to take its value from the second tab in the paragraph style.

     

    When looking for extra tab stops, use the paragraph style dialog NOT the ruler.

     

    Van

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 10, 2013 1:00 PM   in reply to mushhoodpuffer

    The answer is there http://www.adobe.com/products/adobemag/archive/pdfs/98auqafm.pdf READ THE RIGHT COLUMN of the PDF

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 26, 2013 12:03 AM   in reply to mushhoodpuffer

    Windows/Mac/UNIX: I couldn’t find an option for adding dot

    leaders to my table of contents. Is there a way?

    Yes, you can add leaders (dots or other symbols that come between

    the TOC entry and its page number), but it’s not very obvious—

    as you’ve already discovered. Though it involves editing the

    reference page of your table of contents, once you go through the

    procedure, it’ll seem fairly straightforward.

    sertion point (the cursor) where it is.

    4. Choose Designer from the Paragraphs submenu of the Format

    menu. In the Paragraph Designer dialog box, choose Basic

    from the Properties pop-up menu.

    5. Specify the position of your leaders: Select Tab Stops in the upper

    right corner, select New Tab Stop, and then click Edit. In the

    Alignment section of the Edit Tab Stop dialog box, select Right.

    In the New Position text box, enter a number (in whatever

    units you’ve specified as display units for the document) for

    the position of the page number on the right of the TOC page,

    which will determine the length of your leaders. For an 8.5-by-

    11-inch document, for example, you might specify 6.5 inches

    for your tab position.

    In the same dialog box, select one of the predefined leaders

    from the Leader section or create a custom leader by selecting

    Custom and entering a character. Click Continue.

    6. In the Paragraph Designer dialog box, click Update All. A leader

    now appears between the <$paratext> and <$pagenum>

    building blocks in the reference page. It doesn’t appear on the

    body page, however, until you regenerate the TOC in step 8.

    7. Repeat steps 1–6 for each line that includes the <$paratext>

    and <$pagenum> building blocks.

    8. Close the Paragraph Designer window, choose Body Page from

    the View menu, and then save the TOC file. Open the book file

    for your publication and choose Generate/Update from the

    File menu to regenerate the TOC, which will now include the

    dot leaders you specified.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 26, 2013 3:16 AM   in reply to mushhoodpuffer

    Please do. I'll try to make dots in Reference Pages view and send it back to you with my explanations

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 26, 2013 5:11 AM   in reply to englishextra

    Open in View - reference pages and find all occurances of

     

    <$paratext> <$pagenum>

     

     

    delete space between tags then press tab once then make sure that you selected view - toolbars - paragraph formatting to see the paragraph panel on your right then cahnge authoring mode to design one so I see there you already have tab stops 5,76 then click it and make sure before that the cursor vertical line is there <$paratext>(there should be an angular sign after you pressed tab)|<$pagenum> so now click your 5,76 and play change right to left OR CHANGE WIDTH see screenshot AFTER YOU PRESS CONTINUE you should update all in paragraph panel being in reference pages view

     

    Untitled-1.png

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 5, 2013 2:36 AM   in reply to mushhoodpuffer

    Hi, All

     

    This article (http://blog.sina.com.cn/s/blog_540316260101axux.html) described how to resolve FM can't generate Leading dot problem.

     

    The writer suggests

    1 applying useless paragraph tag to <$paratext> and <$pagenum> building blocks
    2 Updateing or Regenerating TOC. FM will create new <$paratext> and <$pagenum>.

    3 Deleting old <$paratext> and <$pagenum> blocks, and apply correct paragraph tag to new blocks.

    4 Regenerating TOC

     

    However, the article language is Chinese.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 5, 2013 5:48 AM   in reply to ShaneChen

    Try picking up a copy of Matt Sullivan’s FM bible – Publishing Fundamentals FM11

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points