Skip navigation
rowanjf
Currently Being Moderated

[Flash Pro CS5/.5] Debugger Launch Failed

Sep 18, 2011 7:18 AM

Tags: #cs5 #debugger_launch_failed #debugger

When I press Shift+Ctrl+Enter, I get this message:

 

http://img7.imageshack.us/img7/4755/messagesx.png

 

Happens with:

  • Adobe Flash Professional CS5 and CS5.5 (I have both, happens with both)
    • Happens with fresh installs of either - I haven't set any weird settings
  • Actionscript 3 (any functional AS3 scripts)

 

Operating system:

  • Windows 7 x64

 

I used to be able to debug, around April 2011, but for many months I have not been able to.

 

I've search every thread on the internet regarding this problem and none of them have helped.

 

I've tried:

  • Uninstalling CS5 (or CS5.5), including deleteing preferences
  • Uninstall Flash and ActiveX and reinstall the latest
  • Changed my Windows "hosts" file to include "127.0.0.1 localhost"
  • Uninstalled many programs such as VirtualBox, WinPcap, Wireshark
  • Reinstalled Flash, Java, Adobe AIR
  • I have no anti-virus or firewalls what-so-ever, there is no malware on my PC
    • I have previously installed ClamWin AV and Malwarebytes, but they are now uninstalled
  • Latest drivers for all my hardware - my PC is new (few months old)
  • Running CCleaner
  • I have used ComboFix on my PC
  • Played with settings on my network adapter (disabling IPv6, change advanced options etc)
  • I am able to ping myself successfully (ping 127.0.0.1, ping localhost) - both work

 

What could be causing this problem?

Are there any known software conflicts with Flash Professional?

 

If anyone can help resolve this, you will certainly win thousands of internets. I've been at this problem for months.

 
Replies
  • Currently Being Moderated
    Oct 24, 2011 6:42 AM   in reply to rowanjf

    I had this same issue just this morning after updating from cs5 to cs5.5. I took a sort of shotgun torubleshooting approach to it, so I'm not sure what actual step did fix it but it did start working. I checked for updates through adobe help and updated(didn't fix it). I did the host thing as stated above, and restarted flash, didn't work. So i undid that. I then moved my cs5 fla file to a new folder only taking my images that were associated with it along too. I then cleared the debug log. I tried debuging and it worked. I think what really fixed it though was that I also go rid of the old debug xml file that gets created. When I moved to the new folder, I didn't take that file with me. It recreated when I tried debugging after the move. Hopefully this helps someone else that had this issue.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 25, 2011 6:29 PM   in reply to joedan06

    Hi joedan06,

    If you still have the files and the bad xml, can you please forward it to me? Please zip your files, change .zip extension to .zzz, and email the attachment to my attention at FlashAuthBetaBugs@adobe.com. I'll take a look.

     

    Thanks,

    Quynh

    Flash Pro, QE

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 3, 2012 1:35 PM   in reply to *Q

    If it's helpful to anyone, I encountered this issue after a power failure.  The *-app.xml file that was generated for my AIR program had become corrupted.  I deleted the file and re-published my app and everything worked from there.

     

    Hth,

    Aaron

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points