Skip navigation
Currently Being Moderated

Clipboard error when copying from Ai to Ps CS5.

Sep 23, 2011 3:57 PM

Tags: #illustrator #photoshop #error #macintosh #photoshopcs5 #(10.7.1) #clipboard

I just started receiving an error message when I attempt to copy vector objects from Ai to Ps. I try to paste it as a Smart Object and I get this message:

"Could not complete the Paste command because the clipboard data is empty or invalid."

 

I've also tried to paste it as the other options and still get the same message. I tried to copy/paste an image from the web into the same Ps document and that worked fine. Just seems to be from Ai.

 

MacBook Pro

3.06 GHz Intel Core 2 Duo

8 GB 1067 MHz DDR3

NVIDIA GeForce 9600M GT 512 MB

Mac OS X Lion 10.7.1 (11B26)

 

Ps CS5 12.0.4 x64

Ai CS5 15.0.2

 
Replies
  • Currently Being Moderated
    Sep 23, 2011 4:48 PM   in reply to joseph_is

    Check the clipboard options in Illustrator, and make sure it is exporting AICB *and* PDF data on the clipboard.

     

    Another possibility is that some other app or utility is messing up the clipboard contents (yes, it happens, like JDownloader).

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 25, 2011 5:14 AM   in reply to joseph_is

    In case the problem persists you could also use File > Place to place the Illustrator-file.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 27, 2011 1:21 AM   in reply to joseph_is

    I was having the same problem and it was driving me mad. I checked the illustrator AICB and PDF and they were both checked. I ended up closing all of my programs and then I reopened them a few minutes later. No more error messages after that.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 5, 2011 1:56 PM   in reply to joseph_is

    not a solution but similar problem: it isn't just AI. if i copy a snipet of text from Mail, i get the same error message when i paste in PS.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 6, 2011 1:47 PM   in reply to joseph_is

    Having the same issue in CS5 - copy from Illustrator,paste in Photoshop. I closed Safari (5.1) and it pasted fine. I've had similar issues before which were resolved by closing a browser. In my experience, suspect browsers have been Chrome and Safari. Not sure why this occurs, but something to try next time. :-)

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points