Skip navigation
Currently Being Moderated

XML import deletes whitespace after xref element

Sep 29, 2011 7:57 AM

Hi,

 

FM10 not patched, WinXP SP3

 

I've bumped into a very serious problem that I am able to replicate, but not solve. When I import (custom) XML, any whitespace following <xref> elements is deleted. I don't know if it exclusive to crossreference elements or any no-content elements... but for sure it is happening with xrefs.

 

Here is a zip with sample files with which I am able to replicate this. The XML file has two <xref>s separated by "and". When you import the XML (using the DTD, rules, and template provided), the whitespace before the "and" is deleted.

 

http://www.weststreetconsulting.com/downloads/test.zip

 

I disabled all my personal plugins and all DITA plugins that I could find, same thing.

 

I don't know if anyone has the time to look at this, but I'd be very appreciative if anyone could confirm the problem. This has caused a real mess in my source files that I can go fix using non-breaking spaces, but this is really a pain and very much suboptimal.

 

Thanks,

Russ

 
Replies
  • Currently Being Moderated
    Sep 29, 2011 9:09 AM   in reply to Russ Ward

    Hi Russ...

     

    This is a known problem for DITA files, and may also be the cause of the problem you're seeing. This has been fixed in the latest patch, as long as you're using an import/export client that has been rebuilt with the latest FDK libraries. (Presumably if you're using the default client, it should "just work" once you install the update.) I posted this to the framemaker-dita Yahoo group some time ago ..

     

    ----------------------

    If you're using FM10 DITA (with DITA-FMx or not), you may have noticed that the spaces after inline conrefs are missing. Apparently FM10 introduced some whitespace normalization, that was a little too aggressive.

     

    This may be fixed in a future update, but in the mean time you can fix it by making the following edit to the maker.ini file. In the Preferences section, change this ..

     

       RemoveExtraWhiteSpacesOnXMLImport=On

     

    to this ..

     

       RemoveExtraWhiteSpacesOnXMLImport=Off

     

    And all is right in the world once again.

    ---------------------

     

    Hopefully this will fix your troubles .. but I'd install the update anyway, since that fixes a number of other bugs.

     

    Cheers,

     

    ...scott

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 29, 2011 10:14 AM   in reply to Russ Ward

    Russ...

     

    Yeah .. that's the update that "fixes" the problem. At least it did with DITA. I suppose it's possible that they (Adobe) didn't recompile the default import/export client with the updated FDK libraries. As far as I know, this was a problem in the libraries that were used with those clients.

     

    The only reason that you'd want whitespace normalization is if you're working with XML files that are edited in other editors where extraneous whitespace may get added via "pretty printing" or other such nonsense. If your files remain in FrameMaker, you should be fine to leave this setting off .. I think it's basically the "old" method from earlier FM versions.

     

    Cheers,

     

    ...scott

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 30, 2011 12:15 PM   in reply to Russ Ward

    Russ,

     

    File a bug report at: https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform&product=6 3

     

    Also send a message to Kapil Verma (Product Manager - http://forums.adobe.com/people/Kapil%20Verma%20(FM%20PM)) and Rajat Bansal (Engineering Manager - http://forums.adobe.com/people/Rajat%20Bansal) for FM via the Forum private messaging.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 1, 2011 1:04 PM   in reply to Russ Ward

    Hi Russ,

     

    Did you evaluate using the "xml:space" attribute for elements that require preservation of spaces. If the xml:space attribute is set to preserve (i.e. xml:space="preserve")

    FrameMaker would preserve the whitespaces in that element during XML import.

     

    You might want to read more about it in the documentation link mentioned below:

    http://help.adobe.com/en_US/framemaker/using/WSD7FBA378-86FB-49ad-82EA -CCCFF5CC9524.html#WSfdd6fcd1027c990f-2e97d56212bdf47911c-7fff

     

    And some more info on w3.org- http://www.w3.org/TR/xml/

     

    Regards,

    Nakshatra

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points