Skip navigation
TdeV1 91 posts
Nov 25, 2005
Currently Being Moderated

Save as PDF generates SPLWOW64.EXE error

Nov 16, 2011 11:58 AM

Tags: #splwow64

Just moved to new Windows 7 box

Using Frame v 8.0p236

 

Have book, used Save as PDF option, click "Set".

Get a popup box with big red "X" says: c:\windows\SPLWOW64.EXE

 

Ideas?

 

TIA,

Theresa

 
Replies
  • Currently Being Moderated
    Nov 16, 2011 12:17 PM   in reply to TdeV1

    Just moved to new Windows 7 box

     

    What Windows 7?

    Hopefully Professional, Enterprise or Ultimate.

     

    Running in 32- or 64-bit mode?

    If 64, do you have XP[32] Mode handy?

     

    Using Frame v 8.0p236

     

    FM8 isn't supported on Windows 7.

    You may be able to get it to work.

     

    See: My FrameMaker 8 Keeps Crashing in Windows 7

    http://forums.adobe.com/message/3940299#3940299

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 16, 2011 12:20 PM   in reply to TdeV1

    Theresa,

     

    searching Google for SPLWOW64.EXE "Windows 7" you’ll find several posts on Microsoft forums and elsewhere. It makes me believe there is an issue with your printer driver. FrameMaker is a 32 bit application and under certain circumstances Windows 64 bit can not handle certain things, it seems.

     

    On a different note (and most probably unrelated to this problem): Your FrameMaker 8 installation is not patched to version 8.0p277, please do that.

     

    http://www.adobe.com/support/downloads/product.jsp?product=22&platform =Windows

     

    - Michael

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 16, 2011 1:14 PM   in reply to Michael Müller-Hillebrand

    It also appears that splwow64.exe is target for malware.

     

    Infection or replacement by a trojan splwow64.exe needs to be ruled out before taking other steps.

     

    If the problem can't be resolved in native Win7-64, an alternative is to re-install Frame in a virtual Windows XP (32-bit) running under Win7 ("XP mode"), which is freely available from MS if (big if) you paid enough for your Win7.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 16, 2011 2:24 PM   in reply to TdeV1

    My system is Win 7 Professional 64 bit.

    You qualify

     

    I think I have 32 mode, but I don't know anything about it.

    http://en.wikipedia.org/wiki/XP_Mode#Windows_XP_Mode

     

    Can I set up 32 bit for one application only?

    Yes

     

    Can you tell me where I go and find out about it?

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=80 02

     

    Before doing that, another work-around to try would be print to PostScript and separately Distill (if you have the full Acrobat product).

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 16, 2011 4:54 PM   in reply to TdeV1

    Have you tried printing to the Adobe PDF printer instead of using Save

    as PDF? Save as PDF is known to be problematic for many. Printing to PDF

    is much more dependable.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 17, 2011 4:19 AM   in reply to TdeV1

    How does this work?

     

    Sometimes in this forum we just toss out potential lifejackets. The swimming part is up to you. I've never run XP mode myself, but it's provided by MS precisely for situations like yours.

     

    I now have Win XP mode (maybe w/ Virtual PC)

    Do I have to reinstall Frame to this "pc"?

     

    Presumably. and depending on how Adobe implemented the DRM on FM8, you might have to uninstall it from Win7-64 first.

     

    Do I uninstall it from the regular Windows 7 box?

     

    Presumably.

     

    Do I have to open xp mode in order to be able to run Frame?

     

    Presumably, although it's possible that MS implemented XPM in such a way that apps installed within it are visible to Win7, and when you run an app that requires XPM, XPM is dispatched automatically.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 17, 2011 9:00 AM   in reply to TdeV1

    BestScenes wrote:

     

    I've used Save as PDF flawlessly for a year or two. Printing to the Adobe PDF doesn't work at all;

     

    However, that's exactly what SaveAsPDF does (albeit behind the scenes)! It sounds like there's a configuration issue with your PDF port or perhaps the permissions for the location that has been specified for output. Win 7 is a real PITA when it comes to providing simple access to locations. Also being on FM8, as others have mentioned, is probably exacerbating the situation.

     

    When you print to the AdobePDF from other applications, do you get asked where to place the PDF file or does it just always go the same location regardless of the application? Have you gone through your AdobePDF printer properties and configured it since it was installed?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 17, 2011 4:38 PM   in reply to TdeV1

    Theresa,

     

    You have to configure things so that default settings aren't being used. In the AdobePDF printer Printing Defaults, set the Adobe PDF Output Folder to prompt you for the destination:

     

    AdobePDF_settings.png

    Note: you also have to make the same settings for the printing preferences.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 18, 2011 7:35 AM   in reply to TdeV1

    Stuck files in the queue sounds like a problem I had with Acrobat X. The

    10.0.1 patch broke the Adobe PDF printer, so that it tried to use the

    COM1: port, instead of the Documents or Desktop port. (You can check for

    this by right-clicking the Adobe PDF printer, choosing "Printer

    Properties," then selecting the "Ports" tab.) In fact, it deleted those

    ports! (Here's a link to that problem:

    http://kb2.adobe.com/cps/893/cpsid_89330.html). The result was PDFs that

    would not print, and would be left stuck in the printer queue. The fix

    was to delete the Adobe PDF printer, then run the Acrobat repair option

    to regenerate it. You might want to do this. Following are the

    directions for Windows 7. Windows XP instruction are included at the

    link above.

     

     

              *Windows Vista (UAC on, nonadmin user), Windows 7 (UAC on,

              admin user)*

     

    1. Close all PDF files.

    2. Go to Printers and Faxes (Windows XP), Printers (Vista) or Devices

        and Printers (Windows 7).

    3. Right-click the Adobe PDF printer and click Delete (Windows XP,

        Vista) or Remove Device (Windows 7).

    4. Enter the admin credentials. This step deletes the Adobe PDF printer.

    5. Go to Programs and Features (Vista and Windows 7).

    6. Select Adobe Acrobat X Pro or Standard and click Change.

    7. Select Repair and follow instructions to complete repair.**

     

    By the way, I don't think this was mentioned earlier, but another cause

    of problems with PDF generation is having more than one installation

    and/or version of Acrobat, Adobe Reader, or the PDF creation add-on that

    comes with FrameMaker installed simultaneously. If you have Acrobat, you

    should NOT have Adobe Reader or the PDF creation add-on installed on the

    same computer, and you should have only one version of Acrobat installed.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 19, 2011 6:50 PM   in reply to TdeV1

    Theresa,

     

    It sounds like the port info is getting clobbered on your installation. The Adobe PDF printer instance should be set to the "Adobe PDF" port, e.g.

    AdobePDFPort.png

     

    You should have a Port labelled "Adobe PDF". If you don't then you'll have to click on the "Add Port..." button and then manual create a port called "Adobe PDF Port Monitor". You then specify a destination folder folder for this port, which is where Distiller where drop off files by default. You can overeride this by specifying the "Prompt for PDF filename" as shown in the Printing Deefaults panel of the previous message.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 19, 2011 7:55 PM   in reply to TdeV1

    You should not have both Acrobat and Reader on the same computer,

    ESPECIALLY when they are not the same version. Adobe warns against this

    and does not support it. Uninstall both, then reinstall only your

    Acrobat 8 or you will lose your PDF printer.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 21, 2011 11:08 AM   in reply to TdeV1

    Theresa,

     

    Sorry, I missed the part about Acrobat 8 earlier.

     

    Acrobat 8 doesn't have that info for Win7 (that's why it's unsupported for Win7). With supported versions of Acrobat, you need to specify the AdobePDF.inf file, typically found in the Acrobat\Xtras\AdobePDF folder. You will probably need to print to file and then manually use Distiller to create PDFs in your configuration.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 21, 2011 1:57 PM   in reply to TdeV1

    Have you tried uninstalling Acrobat, uninstalling Reader, then

    reinstalling Acrobat ONLY, and then following the repair steps listed

    above (if necessary)?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 21, 2011 2:29 PM   in reply to TdeV1

    As Mike says, you can't have two different versions of Acrobat and Reader installed. You have to uninstall both and then re-install Acrobat 8. However, for a Win7 64-bit environment, I would only recommend Acrobat X Pro for things to behave properly.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 21, 2011 3:46 PM   in reply to TdeV1

    Sometimes it works, but Adobe reps have warned us not to do it. Acrobat

    and Reader installations, especially different versions, step all over

    each other when they install, and cause problems that you may not see

    until you eventually try to use a feature or program setting that you

    normally don't use, or until you run an updater. Add in operating

    systems changes and you further increase the chance of failure. And I've

    noticed that recent Acrobat updates actually reset some of my

    preferences back to defaults without asking.

     

    The installers are actually supposed to uninstall old versions before

    installing the new, but don't always do so. I especially imagine that

    they don't do it when, for example, you reinstall Acrobat 8 on a machine

    that has Reader X, since version X didn't exist when the installer was

    created.

     

    Anyway, there are many that say they have multiple versions functioning

    fine for them on the same machine. There are also many that we have

    helped here, simply by having them follow Adobe's recommendation to have

    Acrobat only or Reader only.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 21, 2011 3:47 PM   in reply to TdeV1

    I forgot to mention that I agree with Arnis that the upgrade to Acrobat

    X would be wise for Windows 7/64.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 21, 2011 5:47 PM   in reply to TdeV1

    Theresa,

     

    You can also install a penny in a fuse box and things will appear to work, but there may be unintended consequences down the road...

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points