Skip navigation
Currently Being Moderated

Blazeds Http1.1 Problem

Nov 28, 2011 7:30 PM

Hi,

When I use Blazeds,it can't push data to my browser,but  it  can send to others.

logs like that:

[BlazeDS]Endpoint with id 'my-streaming-amf' cannot service the streaming request made with  HTTP 1.0. Only HTTP 1.1 is supported.

 

I use IE8,and settings like this:

搜狗截图_2011-11-29_11-12-55.png

 
Replies
  • Currently Being Moderated
    Nov 29, 2011 2:40 AM   in reply to PeterWangStick1

    What version of BlazeDS are you using?

     

    Rohit

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 29, 2011 9:33 PM   in reply to PeterWangStick1

    Try using a Web proxy tool like Charles, to capture the request and response between the browser and the server and see what request headers are being sent to the server. From your initial post, it looks like the browser is sending across a HTTP/1.0 requests across to the server. Streaming channel requires a HTTP/1.1 protocol for communication.

     

    Rohit

     

    PS. BTW, as per the attached image, I don't know what locale you are using, but certainly the English locale IE 8 browser Internet Options looks a lot different. I can't read what checkboxes have been selected in the dialog.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points