Skip navigation
dq212
Currently Being Moderated

Multiple Errors when trying to downgrade from 4.5.1 to 4.1

Nov 30, 2011 9:44 AM

Tags: #flex #osmf #robotlegs #flashplayer #10.1 #advancedstyleclient

Hello.

 

I built a project in Flash Builder using the 4.5.1 SDK. My client also needs the project in 4.1 in order to play in Flash Player 10.1.

This change will not compile.

 

I am using robotLegs 1.5.2 and OSMF

 

I tried simply changing the SDK in the compiler settings, but to no avail.

 

I have tried swapping the the Version of OSMF.swc in my local libs folder and I get varying results.

 

With OSMF 1.5 I get errors relating to:

 

StageVideoEvent

 

 

With OSMF 1.0 I get:

 

VerifyError: Error #1014: Class mx.styles::AdvancedStyleClient could not be found.

 

 

Others erros I have gotten throughout my debugging have been Verify Errors relating to:

 

softKeyboardEvent

 

stageVideoEvent

 

Anyone familiar with these types of errors speific to FlashPlayer 10.1?

 

Thank you.

 

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points