Skip navigation
Currently Being Moderated

Track Text Edits inserts a deletion in the first space when adding text

Dec 31, 2011 7:50 AM

Tags: #framemaker_9 #track_text_edits

This "feature" is driving me crazy.

 

When I am adding text with TTE enabled, if I place my cursor at the end of the last word before where I start adding text, FM inserts a deletion in the first space.

 

If I place my cursor at the beginning of the last word before I before where I start adding text, everything works fine. Here is an example of what I mean. In the first sentence, I started with my cursor behind the "the." In the third sentence, I started with my cursor in front of the "before."

 

ScreenShot00128.png

 

This error seems to be document-specific. I tested in a new document (New > Portrait), and this behavior did not occur. Does anyone know how to disable this "feature?"

 

FrameMaker 9

Windows 7 64 bit

 

Thanks!

Karen

 
Replies
  • Anjaneai Srivastava
    1,028 posts
    Oct 17, 2011
    Currently Being Moderated
    Jan 2, 2012 1:22 PM   in reply to farrelldoc

    Hi Karen,

     

    I notice one thing that there is a "red hyphen" between "the end" in the first sentence which means there was a Deletion of a Space done, with TTE enabled.

    What I believe is happening, that deletions are getting accepted over here, in this specific FrameMaker document, hence you are missing a space between them.

     

    I would like you to do a test on the same document, so that we may verify if this is something specific to the document or not?

     

    1) Delete a compelete word/phrase from the same sentence, repeat the same procedure that removed the space and notice this time, is the word too getting ommited along with that space?

     

    2) Disable the TTE insert two spaces between 'the' and 'before', the Enable the TTE and write the same way as you had earlier, but begin adding text like as follows--

     

    I placed my cursor at the ONLY_NEW_WORD_INSERTED before where I started adding text.

     

    I wish,   I could illustrate these steps in a less confusing manner, But please try them and let me know if it clears few things for you?

     

     

    Good Luck, Karen.

     

    Thanks,

    Anjaneai

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 12, 2012 5:37 AM   in reply to farrelldoc

    Hi Karen,

     

    The reason for the deletion is this. In Format | Document | Text Options you have Smart Spaces activated.

    When you insert the cursor before a space and type another space FrameMaker deletes this space as only a single space is allowed.

    But FrameMaker cannot insert a new space as there is already one there. Track Text Edit applies only conditions. The text is still there.

     

    Try it without Smart Spaces. Then everything should be fine.

    But if you want to keep Smart Spaces, then you must accept this behaviour and always start typing after a space.

     

    Best regards

     

    Winfried

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points