Skip navigation
Currently Being Moderated

trying to boost load time performance on a spark TileGroup for flex 4.5 mobile

Jan 9, 2012 11:32 AM

I have many components (up to 150) rendered with addElement and would like to know if there is a faster way (or at least a direction to investigate) a way to boost this performance.

 

I basically take an arraycollection dataprovider and load the custom TileGroup. Right now loading about 15 elements in the tilegroup seems to take up to 15-20 sec. I can only imagine the performance at 150 components. Anyone have any ideas on how to optimize the performance?

 
Replies
  • Currently Being Moderated
    Jan 9, 2012 12:56 PM   in reply to bmilesp

    What does the profiler say?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 21, 2012 3:39 PM   in reply to bmilesp

    What components are you adding?  Are all 150 of these elements in view at the same time?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 8, 2013 12:18 PM   in reply to bmilesp

    I just had my machine at work upgraded from Windows XP to Windows 7 and noticed the Profiler would not connect anymore. The solution for me was to remove (delete or rename) my existing mm.cfg file. Hope this helps.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points