Skip navigation
MariaNiku
Currently Being Moderated

Ubuntu 11.10, Flash Access and DRM

Jan 14, 2012 6:28 AM

Hi,

 

I'm attempting to play a video download I purchased at a British video-on-demand service called Digital Theatre. The service uses a player which is an AIR application:

 

http://www.digitaltheatre.com/desktop-player

 

DigitalTheatre uses DRM with Flash Access.

 

I have Ubuntu 11.10 64bit and flash plugin 11. I successfully installed both the latest available Adobe Air version for Linux as well as the player. For Flash Access support, I followed the findings reported in the last post in this thread: 

 

http://forums.adobe.com/message/4049620

 

The adobe-flashplugin package and HAL are installed (I also tried the flashplugin-installer from Ubuntu repositories). The test video mentioned in the first post of the thread works fine, and DRM events show no errors. However, when attempting to play the video purchase I get "Unfortunately the playback has failed. You are not authorised to view this production". I can't see anything informative in the Adobe Air install log, and running the player from command line gives no data. Previously I had Arch Linux installed, and there in command line I saw DRM error id 3344.

 

Attempting to launch the f4v file of the purchase in Firefox, it complains that the following two plugins are missing (and cannot be found in the search):

 

video/x-gst-fourcc-encv decoder

audio/x-gst-fourcc-enca decoder

 

I have a 32 bit Ubuntu 11.10 on my netbook, the same version of flashplugin and with HAL installed, and there I can play the video purchase without problem. This would indicate that it's a 64 bit issue, but I'm puzzled as to why it is not working on my 64 bit machine, since the writer in the above thread apparently was able to solve the problem with HAL and adobe-flashplugin and since I can play the test video just fine.

 
Replies
  • Chris Campbell
    9,446 posts
    May 4, 2010
    Currently Being Moderated
    Jan 23, 2012 2:43 PM   in reply to MariaNiku

    Hi Maria,

    I unfortunately don't know enough about Linux to be of any help here.  I'll run this by one of our Linux guys to get his take.  Would you also mind creating a new bug with your system details and a link to this thread over at bugbase.adobe.com?

     

    Thanks,

    Chris

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 23, 2012 3:42 PM   in reply to MariaNiku

    a drm error 3344 would suggest that the player you are using doesn't match the voucher you have downloaded.  make sure you are running a release version of the Flash Player, not a beta.

     

    determine running version

    http://www.adobe.com/software/flash/about/

     

    next, delete the contents NativeCache

    ~/.adobe/Flash_Player/NativeCache

     

    reattempt to play the content.

    the drm module and voucher files will be downloaded.

     

    hope this helps...

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 24, 2012 4:20 PM   in reply to MariaNiku

    i have reproduced your issue on Ubuntu 11.10 and entered an internal bug #3097114.  you won't have access to the bug, but if you would like to be notified you can enter a bug in our external bugbase. 

     

    http://bugbase.adobe.com/

     

    let me know the bug number or that you posted and i'll bug group them.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 25, 2012 5:26 PM   in reply to libflashplayer.so

    it turns out i did not have HAL installed.  after applying HAL 0.5.14-6 and verifying my flash version install 11,1,102,55, the video plays as expected (see screenshot).

     

    Screenshot at 2012-01-25 153721.png

     

    would you mind to confirm your installations through the Ubuntu Software Center?  make sure to have the Partner repositories enabled and search on Flash Player 11 and HAL respectively.  thanks...

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 27, 2012 7:29 PM   in reply to MariaNiku

    my apologies, i thought the issue was across both the browser and the air app.  btw, air linux support stopped at version 2.6.  i wanted to see if i could get the video to play on the same player swf on AIR, but was not able to complete my test using the AIR 2.6 SDK.

     

    i will be on vacation the next two weeks, but will ask someone on the DRM team to follow up.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 30, 2012 5:45 PM   in reply to MariaNiku

    Hi MariaNiku,

     

    Apparently, when the x32 bit AIR is being run on your x64 bit OS, the DRM DLL is unable to access the x32 bit version of HAL.

    Please try this workround to see if it addresses your situation.  Create a text document and put these commands into it:

     

    #!/bin/bash

    export LD_LIBRARY_PATH=/usr/lib32

    '/opt/Digital Theatre Player/bin/Digital Theatre Player'

     

    After that, add executable permissions on the your document via chmod +x <your doc name> using Terminal.  You should be able to double click your doc and the DTP program should run.

    If you launch your AIR application with the LD_LIBRARY_PATH to include /usr/lib32, then your application should work correctly.

     

    Regards,

    Nobo

     

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points