Skip navigation
felixoscar
Currently Being Moderated

can't update acrobat.com's mandatory update

Jan 20, 2012 9:43 AM

Tags: #ie964bit

error code #16820 - acrobat.com mandatory update available download will not install from version 2.1.0.0 to 2.3.0.0. When I try to download the update it fails with error code 16820.  I can't install the update.  Is there anyway to force the update to install.   This occurs when I use IE9 64 bit.   I do not get this error with IE9 32 bit or chrome. O/S is Windows 7 Ultimate.  Original install date is 2010.

 

More Like This

  • Retrieving data ...

Bookmarked By (1)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points