Skip navigation
jlwhite
Currently Being Moderated

ColdFusion 9 Web Server Configuration Tool  problem

Feb 13, 2012 12:02 PM

I am using:

ColdFusion 9.01

Oracle iPlanet Web Server 7.0.13

Windows 2008 R2 Standard

 

 

When I try to use the Web Server Configuration Tool, I get the following message:   warning "connectors/nsapi/intel-win64/prebuilt/jrun_nsapi.dll".  Could it be an incompatability with the versions of software that I am using?  Has anyone successfully configured ColdFusion 9.01 with Oracle iPlanet Web Server 7.0.13?

 

I can't get past this message (see below).

 

 

The wsconfig.log file has the following:

02/14 00:39:57 debug Parsing Sun ONE Web Server (iPlanet) configuration file G:\Program Files\Oracle\WebServer7\https-CFAdmin\config\magnus.conf

02/14 00:39:57 debug Parsing Sun ONE Web Server (iPlanet) configuration file G:\Program Files\Oracle\WebServer7\https-CFAdmin\config\obj.conf

02/14 00:39:57 error connectors/nsapi/intel-win64/prebuilt/jrun_nsapi.dll

java.io.FileNotFoundException: connectors/nsapi/intel-win64/prebuilt/jrun_nsapi.dll

    at jrunx.connectorinstaller.JarUtils.extractToFile(JarUtils.java:72)

    at jrunx.connectorinstaller.CIUtil.extractConnector(CIUtil.java:274)

    at jrunx.connectorinstaller.iPlanetInstaller.installConnector(iPlanetIns taller.java:136)

    at jrunx.connectorinstaller.ConnectorInstaller.installConnector(Connecto rInstaller.java:341)

    at jrunx.connectorinstaller.ConnectorInstaller.doIt(ConnectorInstaller.j ava:275)

    at jrunx.connectorinstaller.ConnectorInstaller.main(ConnectorInstaller.j ava:765)

 
Replies
  • Currently Being Moderated
    Feb 13, 2012 12:08 PM   in reply to jlwhite

    According to ze documentz, iPlanet is not a supported webserver for ColdFusion. I reckon that's your answer.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 13, 2012 12:35 PM   in reply to jlwhite

    Ah, that changes things then. In which case yes, could well be an architecture incompatibility. Rather than going for CF 32-bit, why not use a 64-bit webserver? Might as well make use of a 64-bit OS.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 4, 2012 7:05 PM   in reply to jlwhite

    Any luck? We are installing CF 9 tomorrow. Wasn't sure about 64-bit or 32-bit, since we also have installed 32-bit Oracle iPlanet Web Server in Windows 2008 R2 platform.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 16, 2013 2:11 PM   in reply to jlwhite

    I'm using  Solaris 10 SPARC, iPlanet 7.0.15, and I'm not going to use Apache!

    Note: I made a slight modification to the LD_LIBRARY_PATH_64 reference in the startup script for iPlanet.

    You have to do this to make the virtual server use the 64-bit libraries.

     

    vi /sun/webserver7/https-<config_name>/bin/startserv

    look for this line:

        LD_LIBRARY_PATH_64="${SERVER_LIB_PATH_64}:${SERVER_JVM_LIBPATH}:${LD_ LIBRARY_PATH_64}"; export LD_LIBRARY_PATH_64
    and change it to this line:

        LD_LIBRARY_PATH_64="${SERVER_LIB_PATH_64}:${SERVER_JVM_LIBPATH}:${LD_ LIBRARY_PATH_64}:/usr/sfw/lib/sparcv9"; export LD_LIBRARY_PATH_64

     

    I'm moving from CF8 ENT to CF9 ENT.

    Here's the problem: iPlanet virtual server is configured for 64-bit operation; the connector in CF9 is 32-bit.

     

    Question: What Program is Making this file ---> libjrun_nsapi.so ??

    I'm assuming CF is creating it, so try to follow my logic here.....

     

    CF9 doesn't want to produce libjrun_nsapi.so in 64-bit mode.

    The file is located here:
    /opt/coldfusion9/runtime/lib/wsconfig/1/libjrun_nsapi.so

     

    Instead it spits out a 32-bit file....

    # file libjrun_nsapi.so

    libjrun_nsapi.so:       ELF 32-bit MSB dynamic lib SPARC32PLUS Version 1, V8+ Required, dynamically linked, not stripped, no debugging information avail

     

    It's supposed to look something like this:

    # file libjrun_nsapi.so

    libjrun_nsapi.so:       ELF 64-bit MSB dynamic lib SPARCV9 Version 1, dynamically linked, not stripped

     

    I found out that when I use CF8, the installer asks for 64-bit configuration during install,

    AND the initial startup makes the 64-bit connector.

    In CF9...no such menu item; it doesn't mention 32/64 bit anything.

     

    How do you force CF9 to produce a 64-bit libjrun_nsapi.so file?

    ??????

     

    This creates the 32-bit file...

    cf_root/runtime/bin/wsconfig -server coldfusion -ws sunone -dir /sun/webserver7/<config-name>/config -coldfusion -v

     

    When I add -ws64 it breaks the script....

    cf_root/runtime/bin/wsconfig -server coldfusion -ws64 sunone -dir /sun/webserver7/<config-name>/config -coldfusion -v

     

    How do you force CF9 to produce a 64-bit libjrun_nsapi.so file?

    ??????

     

    FYI:  I grabbed the libjrun_nsapi.so file from my CF8 ENT install, and used it in my CF9 ENT install.

    No errors from the web server, but it's running dirt-slow now.

    Could be the file because the libjrun_nsapi.so was created to connect with CF8, not CF9 !?

     

    How do you force CF9 to produce a 64-bit libjrun_nsapi.so file?

    ??????

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points