Skip navigation
Doubledutch20
Currently Being Moderated

Password field bug - AIR 3.1

Mar 1, 2012 5:34 AM

Tags: #iphone

I think I found a bug in AIR 3.1. when running on an iPhone. Sequence of events:

 

  1. Add 2 text field to movie clip
  2. Set one to type to password
  3. Publish to iPhone
  4. On iPhone enter data in password field using iPhone text input - text appears as *** (which is fine)
  5. Focus on non-password field and the *** displayed in the password field dissappear
  6. Change (2) to a none password field and it works fine

 

Is there a way around this?

 

Leon

 
Replies
  • Currently Being Moderated
    May 7, 2012 10:49 AM   in reply to Doubledutch20

    The same problem here, publishing to iOS with Flash Professional CS5.5 and AIR 3.1.

     

    Is it solved with AIR 3.2?

     

    Thanks in advance,

    Marcos González.

     
    |
    Mark as:
  • Currently Being Moderated
    May 18, 2012 8:48 AM   in reply to BlocketPC[Marcos]

    Double check the font you are using.  I had the same issue with 3.1.  Come to find out the astericks wasn't included in the font I was trying to use ( Helvetica purchesed from Adobe ).

     

    FB 4.6

    SDK 3.1

     

    Embeded Helvtica purchased from Adobe.

     

    Markus

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points