Skip navigation
Currently Being Moderated

Excel into InDesign

Mar 5, 2012 9:19 AM

Is anyone aware of a way to import an excel table into InDesign? The table must be editable in InDesign after it's imported.

 
Replies
  • Currently Being Moderated
    Mar 5, 2012 9:35 AM   in reply to ohare0512

    File>Import will do this. You have the choice of selecting Import options to choose what part of the sheet to import, and whether to format it to an InDesign table style.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 5, 2012 10:18 AM   in reply to ohare0512

    No idea. When I import exel into InDesign, I get an editable, formattable table. If the file is something you can share, you could upload it to usendit or another file-sharing service and post the link here. I or someone else here could take a look.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 5, 2012 11:57 AM   in reply to ohare0512

    The forum does not allow attached files; can you upload it to a server and send me the link?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 5, 2012 12:55 PM   in reply to ohare0512

    When I put that into my InDesign file, it was editable. Would it be possible to send the InDesign file in question?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 5, 2012 1:14 PM   in reply to ohare0512

    Are you using copy>paste to get the excel info into InDesign? That is the only way I could replicate your problem.

     

    From your InDesign document, go to the File menu, and chose Place. Be sure to check the box for Show Import Options, and choose Formatted Table. that will get you the result you need.

     

    Please let me know if this works for you.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 5, 2012 1:22 PM   in reply to ohare0512

    You're welcome.

    File>place is the way all content from other applications should be added to InDesign. Save copy>paste for moving things from one InDesign document to another, or one page to another.

    I'm glad I was able to help.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2013 2:14 PM   in reply to SRiegel

    When I try this, I get little red dots and no data appears.  Is that beacuse I am trying to import a table that has formulas in it?

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2013 2:18 PM   in reply to phrogg108

    Little red dots mean the text is overset in the cells, i.e. they are not large enough to hold the data as it is formatted.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2013 2:20 PM   in reply to Peter Spier

    Even though it came straight from Excel like that?  I am trying to import a table that has a 6pt font and keep it same size in InDesign.  I had a feeling this was going to be the answer.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2013 2:26 PM   in reply to phrogg108

    Are you placing, or pasting? Have you defined cell styles with the correct formatting?

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2013 2:28 PM   in reply to Peter Spier

    I was trying the "place" option, using the instructions above.  The "paste" option doesn't bring over any of the grid lines - unless I am missing something, which is entirely possible!!

     

    The cells are formatted in Excel how we want them.  It is basically a table/chart of tool sizes and diameters that I wanted to get into InDesign so we can do layouts for our formal catalog.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2013 2:33 PM   in reply to phrogg108

    Show the import options when you place and make sure you've selected Formatted Table...

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2013 2:56 PM   in reply to Peter Spier

    That could still result in overset cells because of InDesign's

    insistence of having cell insets as the default.

     

    Bob

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 22, 2013 5:43 AM   in reply to Bob Levine

    I have tried formatted, unformatted and formatted only once options and I still get the red dots.

     

    Bob - Is it safe to assume there is really nothing I can do other than copy and paste the info and just have to mess with the grid lines some other way?

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 22, 2013 6:11 AM   in reply to phrogg108

    Try selecting the table and set the cell insets to 0.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 22, 2013 6:36 AM   in reply to Peter Spier

    Dave Saunders wrote a script long ago that set the insets of all linked tables to zero. Not sure it would work with CS6.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 22, 2013 12:13 PM   in reply to Peter Spier

    Peter - THAT WORKED!!!  I think I love you!!!

     

    Thank you SO much for your suggestions everyone!!!!  You all just saved me a LOT of anguish!!!

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 27, 2014 10:20 AM   in reply to phrogg108

    I'm having the same issue, where after I place the formatted excel doc into Indesign, I get a red dot and no data. The excel file I'm trying to place is directly exported from Quickbooks Enterprise Solutions. I've tested placing other excel docs and they seem to work fine. Any Ideas why export from Quick books isn't working? Thanks.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 27, 2014 10:26 AM   in reply to ZWise918

    You’ll need to make the cells bigger. The red dot indicates overset.

     

     

     

    The problem is most likely the cell insets. Change them to zero.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 21, 2014 6:39 AM   in reply to Bob Levine

    I have succesfully placed my formatted table in to id, but the purpose of it is for an invoice, so i need values of the table to be editable in an interactive PDF e.g quantity and price, so that a total will be calulated.
    Is there a way to make this table interractive?
    ive tried exporting and formatting in different ways but to no avail

    can anybody help?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 21, 2014 6:42 AM   in reply to DragonLightning

    You’d have to create the proper fields. This is a bit outside my area of expertise but I have done this in the past.

     

     

     

    But…I did the final work in Acrobat pro to add the calculations.

     

     

     

    BTW, this has nothing to do with placing a formatted table from Excel. You’ll need to create the table and then add the text fields.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points