Skip navigation
NilsKnibbe
Currently Being Moderated

Lightroom 4 freezes on import

Mar 13, 2012 4:45 AM

Tags: #install #import #freeze #lr4 #lightroom_4_freeze

Hi,

I just upgraded from LR3.6 to 4.0. When trying to import images the import module freezes for a few minutes and then displays the import screen. However, when selecting a source the program freezes again and eventually crashes.

 

I had the same issue when upgrading to 3.6 some time ago and then found that disabling some USB controllers solved the problem. This works for LR4 as well.

 

As I don't need all USB connections this is a workable solution, however, disabling controllers should not be necessary to run a program.

 

System is an Acer Aspire 7811 64 bits w/ Intel i7, Win 7 Home Premium, 8 GB internal mem and no external drives.

 

If anybody experienced this problem and has a good solution I would be very grateful to hear from you.

 

Thanks!

Nils

 
Replies
  • Currently Being Moderated
    Mar 22, 2012 12:16 PM   in reply to NilsKnibbe

    Which USB controlers did you disable?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 22, 2012 4:57 PM   in reply to NilsKnibbe

    did you find a good way to determine what ones you were using?  it would kinda suck to disable the one your mouse or keyboard was using...   did you have to reboot each time as you disabled them?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 25, 2012 2:36 PM   in reply to NilsKnibbe

    I'm having the same problem.  My system is a Lenovo Thinkpad X220 Tablet running Windows 7 x64.  I tried removing my Expresscard USB 3 controller but that didn't do it.  Control Panel shows 2 USB controllers on the motherboard, or more correctly, 2 instances of Intel 6 Series/C200 Series Chipset Family USB Enhanced Host Controller.  Uninstalling either instance seems to solve the problem.  Uninstalling the 2nd instance took out my mouse, keyboard, phone Blu-Ray drive, etc.  I reinstalled that and uninstalled the 1st instance which also solved the problem without the side effects.  It's likely something isn't working and I haven't found it yet.

     

    It would definitely be nice if Adobe would provide a software fix of this.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 4, 2012 1:41 PM   in reply to Thin Air Images

    I am having the same problem on an HP TouchSmart running Windows 7 x64.  I use most of my USB ports.  Is this the only option to make the program work??

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 4, 2012 10:52 AM   in reply to NilsKnibbe

    One specific item that I now know causes these kinds of problems is an Adroid Phone plugged in.

     

    The android phone can look like an external drive and LR tries to find photos on it.

    There are a number of problems that occur then

    • many files and directories are unreadable (permissions), LR does not appear to like that
    • there is a huge hiearchy of folders and files, this is a full Linux OS plus all the android apps plus all the data
    • starting to access this when its first plugged in can sometimes take a few seconds

    The results are

    • LR4 crashes when you try and enter the import module with the phone plugged in
    • if you plug the phone AFTER you start import, or if import does start then it will freeze for a time each time you try and select a different source or open/close folders -- it keeps attempting to read the phone folders

     

    It gets even worse on some of the newer phones that don't show up as a drive letter so you use "webDav" to force a drive-letter.

    The webDav drive access is slow and often locks up for a time (explorer, not LR even), so when LR sees the drive letter it has even more problems.

     

    My soloution? don't use LR with my phone plugged into a USB port!

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points