Skip navigation
LWillmann
Currently Being Moderated

Adobe PDF printer 'printing' garbage characters

Mar 31, 2012 7:19 AM

Tags: #web #pdf #application #print #distiller #garbage #actobat #9.5.0

Acrobat Professional v9.5.0 (Acrobat reports there are no updates available)

Windows 7 Home Premium 64-bit

 

I print from various applications and web pages to my 'Adobe PDF' printer to save things as PDF files.

 

Over the last several months, I have begun to have issues with printing to my Adobe PDF printer. This issue happened twice just yesterday, actually.

 

I will be looking at a web page, and choose to print it to PDF (a purchase receipt for example). I supply the filename and choose to print, and Acrobat will bring up the newly created PDF and it will have garbage characters in various places.

 

If I try printing it to PDF again, I get the same results.

 

However, if I print the item to Microsoft XPS format, it works just fine and all the characters are readable.

 

I don't know what to do. I saw an article about embedding the fonts, but it appears that all the standard 'web safe fonts' are already set to be embedded in PDF files via distiller (if that is what is actually doing the printing to create the PDF). If I have to choose more fonts to embed into the PDF, it seems to be extremely difficult to determine what fonts are being used by each site or application and choosing them all manually to be embedded in the files.

 

Surely there has to be a simpler solution to this issue.

 
Replies
  • Currently Being Moderated
    Mar 31, 2012 11:02 AM   in reply to LWillmann

    Try changing the Settings to print or press. I suspect the characters you are having problems with are not embedding and you do not have them on your system.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 16, 2012 1:52 PM   in reply to LWillmann

    I too had this annoying issue, usually printing from https sites, although the site address may be coincidental.

     

    What worked for me was:

     

      1. Select Print
      2. In the print dialog box, select Adobe PDF and then Preferences.
      3. In the Printing Preferences dialog box the tab should be Adobe PDF Settings
      4. Uncheck the box next to Rely on system fonts only; do not use document fonts
      5. Select OK

    Preferences.jpg

     

    If the box is already unchecked, it might be caused by something similar. This worked so I went no further. I have not yet checked to see if this must be done each time or how to make it default.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points