Skip navigation
Tinestram
Currently Being Moderated

Having trouble with drawWithQuality

Apr 14, 2012 3:18 PM

Tags: #air_3.3 #drawwithquality

Using Flash CS5.5 with the SDK overlay. drawWithQuality comes up in code view no problem and it compiles fine, but at runtime I get:

 

"ReferenceError: Error #1069: Property drawWithQuality not found on flash.display.BitmapData and there is no default value."

 

Any ideas would be appreciated!

 
Replies
  • Currently Being Moderated
    Apr 19, 2012 5:06 PM   in reply to Tinestram

    publishing for swf version 15?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 19, 2012 6:37 PM   in reply to cnuuja

    I am getting the same issue with flash cs5.5

    tried swf version 15 and 16 with 3.3 sdk and these overlay instructions http://www.flashdeveloper.co/post/20583114199/air32-in-flash-cs-55

     

    ADL:

     

    ReferenceError: Error #1069: Property drawWithQuality not found on flash.display.BitmapData and there is no default value.

        at Untitled_fla::MainTimeline/frame1()[Untitled_fla.MainTimeline::frame1 :8]

        at runtime::ContentPlayer/loadInitialContent()

        at runtime::ContentPlayer/playRawContent()

        at runtime::ContentPlayer/playContent()

        at runtime::AppRunner/run()

        at ADLAppEntry/run()

        at global/runtime::ADLEntry()

     

     

    android device (3.3 runtime installed):

     

    ReferenceError: Error #1069: Property drawWithQuality not found on flash.display.BitmapData and there is no default value.

        at Untitled_fla::MainTimeline/frame1()[Untitled_fla.MainTimeline::frame1 :8]

        at runtime::ContentPlayer/loadInitialContent()

        at runtime::ContentPlayer/playRawContent()

        at runtime::ContentPlayer/playContent()

        at runtime::AppRunner/run()

        at AppEntryCommon/run()

        at global/runtime::AndroidMobileDeviceAppEntry()

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 20, 2012 9:02 AM   in reply to 1901rob

    Did you set the namespace to 3.3 in application xml?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 20, 2012 11:48 AM   in reply to Tinestram

    Please make sure that SWF version is 16, and namespace is set to 3.3. Did you replace airglobal.swc with the one found in AIR SDK 3.3?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 20, 2012 11:22 PM   in reply to Tanya Parkhomovsky

    Ok, well it works now!

     

    Error on my part I suppose.

     

    swf version 16, 3.3 namespace, airglobal.swc replaced, it was showing the code hints, but not compiling. Same with the new BMD.encode()

     

    I simply deleted the Air 2.6 folder and did the procedure again and it works now.

     

    Maybe something was write protected and didn't copy over the first time when replacing the AIR2.6 folder, or maybe I made a mistake somewhere.

     

    Thanks for your help, and a great feature!!!

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points