Skip navigation
Currently Being Moderated

Can't open .CR2 files

Apr 14, 2012 5:54 PM

Tags: #raw #pse9 #.cr2 #cant'_open

After updating to raw 6.6 I can no longer open .CR2 files with PSE9. This a new accourance as I mainly shoot in raw and have had no issues opening these files in the past. I have an Imac and I'm running PSE9. I resenty updated to raw 6.6 to fix a problem I was having with Photo downloader freezing when I tried to change the destination. The issue with Photo downloader freezing has been solved.

 

Now the problem is I can no longer open raw files (.CR2). I have tried opening the file from PSE9 organizer and directly from the folder were it is stored. The message I get is "Photoshop Elements doesn't recognize this type of file" Any help would be greatly appreciated.

 

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points