Skip navigation
Currently Being Moderated

Basic animation not working on IPad

Apr 16, 2012 2:29 PM

I got a very simple HTML5 text animation that moves from left to right. It works fine on Chrome and I can see it works on the desktop viewer but when i view it on Ipad, it just fades in instead of moving from left to right. Anything that I have missed?

 

Thanks!

 
Replies
  • Currently Being Moderated
    Apr 16, 2012 2:56 PM   in reply to ebls2011

    Check out Terry Whites adobeTV podcast called "Go from Indesign CS5.5 to HTML5."  Animation from indesign isn't supported on the iPad.  So if you export your animation as an SWF, and then use Wallaby to convert it to HTML, you can the place it back into your document as web content. Then it should work on the iPad like a charm.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 16, 2012 3:04 PM   in reply to ebls2011

    Your right, FLA not SWF.  I'm not a big flash user, mostly print and HTML.  If the animation is that simple, could you rebuild in indesign, and then use Wallaby?  I have had good success with that process.  A simple slide in from left to right is pretty easy, its a preset in the animation panel.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 16, 2012 6:31 PM   in reply to ebls2011

    I'm not sure, though I admit I have been having some problems the last few days after updating to v19.

     

    You did export the Indesign animation to an fla and convert with wallaby right?  If you did I have a feeling we are hitting some of the growing pains associated with such rapid software development.

     
    |
    Mark as:
  • Bob Bringhurst
    4,649 posts
    May 29, 2007
    Currently Being Moderated
    Apr 16, 2012 6:37 PM   in reply to jkuhns5

    Try using a different animation effect, or creating the effect in a different way. For example, instead of using "Fly in from left," create a simple motion path that flies the object in from the left. See if that works.

     

    Not all HTML is supported in mobile Safari, and not all HTML that's supported in mobile Safari is supported in DPS. Whenever you use Wallaby or Edge or other tools to create HTML, you need to make sure that it works (a) in mobile Safari and (b) in a DPS folio.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 16, 2012 7:54 PM   in reply to ebls2011

    I haven't tried it yet, but you probably can make arial rounded outlines and still get the look you want.  No font = no problems?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2012 1:28 AM   in reply to ebls2011

    I noticed the same. If you use "fly in from ... " then it just appears. But when you use "move left" or "move right" it has no problems. Very weird. I tried this with outlined text and still the "move in from ..."- animation presets didn't work. They just fade in, that's all.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points