Skip navigation
Currently Being Moderated

Unable to login to admin console on FMS 4.5

Apr 18, 2012 7:57 AM

Tags: #4.5

I'm in the process of upgrading our FMS install from 3.5.3 to 4.5.0.  After merging our config settings from 3.5 into 4.5 and starting the server streaming requests are processed as normal.  However I'm unable to access the admin console, attempts to do so result in the "Failed login attempt from <ip address> at <time>" error message in admin.00.log


I've tried follwing the "Edit the Users.xml file to add server administrators" section of fbf351e63e3d119f2925f73-7ffd.html#WS5b3ccc516d4fbf351e63e3d119f2925f73 -7fda


So that my Users.xml starts with





    <User name="newadmin">

        <Password encrypt="false">XXXXXXXXXX</Password>






And the newly added user still gives the same error so I'm looking for suggestions on what to try next to resolve the issue.



  • Currently Being Moderated
    Apr 19, 2012 8:47 AM   in reply to jamesstthompson



    FMSAdmin now in 4.5 does not store your password as clear text as it used to in 3.5. So putting a password in Users.xml will not work.

    For setting the FMSAdmin password here's what you have to do:


         1.  Set the username, which you already have- 'newadmin'

         2.  Make sure FMSAdmin is not already running.

         3.  Assuming you have installed a vanilla FMS on Linux, issue the following command from the shell

                   /opt/adobe/fms/fmsadmin –console –user newadmin

              This will prompt you for a password. Make sure the password is minimum 8 characters.

         4.  Now go to Users.xml and check under the password tag. You should see the Salted Hash of your password placed there.

         5.  Now start your admin server. It should start without any hiccups and you can connect through the admin console.


    That should do



    Mark as:
  • Currently Being Moderated
    May 23, 2012 9:37 PM   in reply to ShivenK

    What is vanilla FMS? I've been trying this but continue to get this message: /opt/adobe/fms/fmsadmin -console -user newadmin failed with return code 255 and error message. The Users.xml file does not update.

    Mark as:
  • Currently Being Moderated
    May 23, 2012 11:15 PM   in reply to agabriel22



    By vanilla FMS, I meant a plain installation of FMS.

    For this command to succeed, please make sure that username entry 'newadmin' has been added to Users.xml as mentioned above in the post.

    If not, then you can use any username. Just make sure that the corresponding entry exists in Users.xml.




    Mark as:
  • Currently Being Moderated
    Feb 27, 2013 3:29 PM   in reply to ShivenK
    • when I run fmsadmin –console –user newadmin the Users.xml is unmodified
      • trying password 37qxrYGaTzkt
      • fms and fmsadmin servers are stopped
    • I'm using  ami-36ada042 fms 
    • I also tried <password encrypt="false">...
    • I also tried chmod 777 Users.xml
    • I also tried different clients ssh on cygwin and putty.
    • When I run fmsadmin in console mode and try to log in I get the message "Failed login attempt from <ip> at <date>"


    Is there some alternative method to generating the salted password?



    Mark as:
  • Currently Being Moderated
    Feb 27, 2013 3:34 PM   in reply to Dana C Benson

    o nm my Users.xml was malformed xmllint ftw

    Mark as:
  • Currently Being Moderated
    Feb 28, 2013 1:43 AM   in reply to Dana C Benson



    Did it work for you or no?



    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points