Skip navigation
Currently Being Moderated

Link problem with Fireworks CS5 - net::ERR_FILE_NOT_FOUND

Apr 20, 2012 3:29 AM

Tags: #help #error #link #chrome #hotspot #revo #fireworks_cs5 #err_file_not_found



I'm having trouble with the hotspot links in Fireworks CS5. When I've added the links I want and click F12 to preview in Chrome, it loads the page without problems. But when I click on one of the links I get the following message:


Webpage cannot be found

There was no webpage at the adress: file:///C:/Users/Margiiie/AppData/Local/Temp/FWTemp/LinkedPage.htm

Error 6 (net::ERR_FILE_NOT_FOUND): Could not find file or catalogue.


(translated by me from Swedish to English, so it might not be 100% correctly translated).


A few days ago I used Revo Uninstaller Pro to remove some files from my computer, and I remember clicking "Remove temporary Internet Files" on all of the web browsers. This might have something to do with the problem, but I can't seem to able to recover the files I removed..


So, I really need som help here! Do you think that the removal of the temp files is the problem? What can I do about it?




  • Currently Being Moderated
    Apr 20, 2012 10:49 AM   in reply to Margiiie

    So when you click on the link in Chrome, it looks for a page entitled "LinkedPage.htm" at the indicated file path... Did you create this page in FW (or another application)? If you did, then I might try previewing that page in Chrome, on the assumption that FW would re-generate a preview for it.


    However, I don't think that the "Remove temporary Internet Files" command would have affected your FW files, as "FW Temp" is probably a folder for Fireworks, not the web browser itself. That's just a guess, though. I'm more inclined to think that the link is incorrect (i.e., it doesn't match the current file name of that page) or that the page itself was never created. Are either of those scenarios possible?

    Mark as:
  • Currently Being Moderated
    Apr 21, 2012 9:27 AM   in reply to Margiiie

    Have you tried previewing in another browser, like Firefox?


    A quick idea: Refresh the page in Chrome the next time you preview it. Maybe it's holding onto a cache of some sort.


    If refreshing the page in Chrome doesn't help, I'd delete the contents of the FWTemp folder. It's just a folder to which Fireworks exports HTML files, images, etc. for the purpose of previewing in browsers. Anything in this folder is just meant to be temporary and likely gets rewritten every time you run a Preview in Browser command anyway.

    Mark as:
  • Currently Being Moderated
    Apr 21, 2012 1:15 PM   in reply to Margiiie

    If you tried a) refreshing/reloading the page within the browser and b) emptying the contents of the FWTemp folder, and neither of those worked, then I'd take another look at the link itself. Assuming there are other links on the page you've created, compare the links within Fireworks: Are there any differences between them? Would it be possible to re-enter or re-establish the problem link's URL?


    One thing I notice in your intial post is that "LinkedPage.htm" seems all by itself within the FWTemp folder, instead of being placed in a subfolder. When I generate a preview in FW, it places the contents in a folder (named with a random number), like this:


    file:///Users/doug/Library/Application%20Support/Macromedia/Fireworks% 208/FWTemp/24327926/00000002.htm


    Generally, a website observes a folder hierarchy. I'd kind of expect "LinkedPage.htm" to be in the same folder as the "index.htm" or whatever your problem page is called.


    I have to admit, I don't use Fireworks to create and preview web pages, so I'm not completely versed in how it works for a full website. I'm not 100% certain that previewing an individual page should result in a functional preview of an entire site. In other words, I'm not certain that links are supposed to work if they lead to another page within the same site (assuming you're previewing one page at a time). If this remains a problem, I'd suggest letting it go for now. Try File > Export instead, and make sure you're exporting all the pages in the site. If that works, then you're in good shape.

    Mark as:
  • Currently Being Moderated
    Sep 21, 2012 9:36 AM   in reply to Margiiie

    I got this same error but fixed it by renaming my pages. I had used # in the page name and fireworks would not properly output the file. Once I removed the hashtag from the page name, the prototype worked perfectly.

    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points