Skip navigation
Currently Being Moderated

Unused Fonts are bloating the size of the document.

Apr 20, 2012 8:16 AM

Good afternoon,

 

I am trying to drastically shrink the size of my file. It jumped from 200KB to 3MG. I tried to standardize all the font sizes.

I went through each field to ensure it was the same font so I wouldn’t have 2 font sizes in the document bloating the size. Looking in the properties screen; however, I still see 4 unused fonts. I tried save>optimize: i still could not remove the unused fonts?

 

How do I remove unused fonts? I have attached a screen shot.

Fonts.jpg

 
Replies
  • DimitriM
    172 posts
    Dec 11, 2007
    Currently Being Moderated
    Apr 20, 2012 8:29 AM   in reply to Milton123321

    Hi Milton,

     

    When you select Save As Optimized, in the follwoing dialog did you select Fonts from the left side and then unembed any fonts listed you are not using?  Also, try selecting the Audit Space Usage button in the top right side of that dialog to get a report on the bytes used for several of the file's components, including how much space is used by Fonts.

     

    Hope this helps,

     

    Dimitri

    WindJack Solutions

    www.pdfscripting.com

    www.windjack.com

     
    |
    Mark as:
  • DimitriM
    172 posts
    Dec 11, 2007
    Currently Being Moderated
    Apr 20, 2012 8:53 AM   in reply to Milton123321

    Hi Milton,

     

    Did you look at the Audit Space feature?  What did it report?

     

    Hope this helps,

     

    Dimitri

    WindJack Solutions

    www.pdfscripting.com

    www.windjack.com

     
    |
    Mark as:
  • DimitriM
    172 posts
    Dec 11, 2007
    Currently Being Moderated
    Apr 20, 2012 10:39 AM   in reply to Milton123321

    Hi Milton,

     

    Sorry, I replied via email so did not see the screenshots.  For some reason Acrobat is not recognizing the fonts that clearly show in the Document Properties. Since Audit Space reports fonts are 99% of space used that indicates the fonts are embedded.  I really don't know what is going on with your file- it may be corrupted.  I would try creating a new form.  Sorry I don't have an easy fix for you.

     

    Hope this helps,

     

    Dimitri

    WindJack Solutions

    www.pdfscripting.com

    www.windjack.com

     
    |
    Mark as:
  • George Johnson
    11,729 posts
    Aug 11, 2002
    Currently Being Moderated
    Apr 20, 2012 11:08 AM   in reply to Milton123321

    Are any of those fonts use in form fields? If you select a non-base-14 font (Helvetica, Times, Courier, Symbol, Zapf Dingbats, and their variations), the entire font will get included in the file and the file size won't get decreased when you optimised, since the complete font is needed for the fields.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 15, 2012 2:58 AM   in reply to George Johnson

    Hi George,

     

    after we create a new pdf document, inserted a text field and saved it, we reopened the pdf, we changed the default font (Helvetica) to another one - for example Times New Roman (right click on the field and selecting Properties --> Appearance --> Text --> Font: [font type combo] ) -

    and we re-saved the file, this new font has embedded to document, as you say, and the filesize increased.

     

    After all the above operations, we re-changed the font of the text field (or also all the text fields) with previous default font (Helvetica)

    and then we saved the document with optimize PDF function, the filesize didn't change but it remained the same, did not decrease to initial size!

     

    Could you tell us a procedure to reset the font of fields and return to initial file size without rewriting the document and all the fields?

     

    P.S.: We have used Adobe Acrobat XI Pro

     

    Than you in advance for your answer,

    Best regards

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 14, 2013 10:42 AM   in reply to xfaber

    I am also looking for a way to mass-reset the form field fonts. I think that once you change it and embed the font by doing so then there is no way to undo it.

     
    |
    Mark as:
  • George Johnson
    11,729 posts
    Aug 11, 2002
    Currently Being Moderated
    Jan 14, 2013 12:20 PM   in reply to MG83

    MG83,

     

    I thnk you're right. I've never found away to fully remove all of the bloat caused by this. If yo can't go back to a previous version, then you can copy and paste the fields now that the font is changed back and paste them into a virgin form. To avoid having to reposition all of the fields since there is no paste-in-place feature (prior to Acrobat11), you can temporarily add a button that's as large as the page to each page and then copy & paste a page of fields at a time, then delete the button.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 15, 2013 1:34 AM   in reply to George Johnson

    The problem is solved with Adobe Acrobat 9 Pro through PDF optimizer function.

    The PDF optimizer function of Acrobat 9 Pro turns out to be better than the same function in the version XI.

    If you using Adobe Acrobat 9 Pro this problem doesn't exist!

     
    |
    Mark as:
  • George Johnson
    11,729 posts
    Aug 11, 2002
    Currently Being Moderated
    Jan 15, 2013 1:47 AM   in reply to xfaber

    xfaber,

     

    Do you know which particular setting in PDF Optimizer causes the unused font information to be removed?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 15, 2013 1:59 AM   in reply to George Johnson

    Someone may have mentioned this, but there is a very important point with form fields's fonts.

     

    Changing Helvetica to Times New Roman may seem a neutral thing to do but it has a huge effect. Helevetica embeds no font, Times New Roman must embed a whole font, and you will possibly end up with many copies. Yet if you had chosen Times Roman there would have been no overhead at all.


    Stick to the 12 fonts at the top of the font list: Courier, Times, Helvetica. These are "magic" and do not need to be embedded.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 15, 2013 2:37 AM   in reply to George Johnson

    Nothing particular settings, if you use PDF Optimizer of Adobe Acrobat 9 Pro, the optimizer removes the unused fonts correctly.

    On the contrary this is not done by the optimizer in Acrobat XI Pro.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 15, 2013 6:21 AM   in reply to Milton123321

    This isn't possible using Acrobat XI Pro?  I'm not too keen on downgrading software for features.

     
    |
    Mark as:
  • George Johnson
    11,729 posts
    Aug 11, 2002
    Currently Being Moderated
    Jan 15, 2013 10:12 AM   in reply to xfaber

    I don't see the same thing. There are a lot of settings available with PDF Optimizer and one of them must be responsible for what you're claiming. Maybe you could tell us exactly which options you have selected.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points