Skip navigation
shmuel67
Currently Being Moderated

Can you use ExtendScript with FrameMaker 9?

May 3, 2012 2:38 AM

The ExtendScript Toolkit 1.0.3 download page does not mention which FrameMaker version you can use it with.

http://www.adobe.com/support/downloads/thankyou.jsp?ftpID=3205&fileID= 3030

 

Can you use this with FrameMaker 9?

 
Replies
  • Currently Being Moderated
    May 3, 2012 4:07 AM   in reply to shmuel67

    Sorry, since FrameMaker 10 ExtendScript is possible only.

     

    - Georg

     
    |
    Mark as:
  • Currently Being Moderated
    May 3, 2012 4:13 AM   in reply to shmuel67

    I would suggest that you take a good look at FrameScript (http://www.framescript.com). It is an excellent scripting environment for FrameMaker 6 and above. I have used it since its first release in 1998 and have written thousands of automation scripts. Even with FrameMaker 10, I find FrameScript easier to use than ExtendScript. I highly recommend it.

     

    Rick

     
    |
    Mark as:
  • Currently Being Moderated
    May 3, 2012 2:24 PM   in reply to shmuel67

    Well, that's not necessarily true. Depends on how comfortable you are with hacking . What you could do is have the script convert the FrameMake files into FM 10, have the script process the files, and then save the files back into FrameMaker 9. Obviously moving from an old relase to a new release and then back to an old release again does raise the prospect of possible corruption. For example, if for whatever reason while the file is in FM 10 it starts using a FM 10 only feature and then is converted back to FM 9, then you are going to have a problem.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points