Unable to login to FMS 4.5 Administration Console

Version 1



    I'm in the process of upgrading our FMS install from 3.5.3 to 4.5.0.  After merging our config settings from 3.5 into 4.5 and starting the server streaming requests are processed as normal.  However I'm unable to access the admin console, attempts to do so result in the "Failed login attempt from <ip address> at <time>" error message in admin.00.log


    I've tried follwing the "Edit the Users.xml file to add server administrators" section of


    http://help.adobe.com/en_US/flashmediaserver/configadmin/WS5b3ccc516d4fbf351e63e3d119f2925 f73-7ffd.html#WS5b3ccc516d4fbf351e63e3d119f2925f73-7fda


    So that my Users.xml starts with





        <User name="newadmin">

            <Password encrypt="false">XXXXXXXXXX</Password>






    And the newly added user still gives the same error so I'm looking for suggestions on what to try next to resolve the issue.




    FMSAdmin in 4.5 does not store your password as clear text as it used to in 3.5. So putting a password in Users.xml will not work.

    For setting the FMSAdmin password here's what you have to do:


         1.  Set the username, which you already have- 'newadmin'

         2.  Make sure FMSAdmin is not already running.

         3.  Assuming you have installed a vanilla FMS on Linux, issue the following command from the shell

                   /opt/adobe/fms/fmsadmin –console –user newadmin

              This will prompt you for a password. Make sure the password is minimum 8 characters.

         4.  Now go to Users.xml and check under the password tag. You should see the Salted Hash of your password placed there.

         5.  Now start your admin server. It should start without any hiccups and you can connect through the admin console.


    This document was generated from the following discussion: Unable to login to admin console on FMS 4.5