Character Animator (Preview 3) – Detailed Changes

Version 1

    New and changed features

     

    General

    • The user interface has been localized into French, German, and Japanese if the After Effects application was installed in that App Language (in the Creative Cloud application preferences).
      Layer and handle names by behaviors still need to be in English. Also, lip syncing is optimized for U.S. English speech.
    • The Getting Started project (available from the Welcome panel’s “Start Here!” link) has been updated, and is now faster to open. When the application is running in French, German, and Japanese, you can view a subtitled, noninteractive video of the project first before trying the interactive project.
    • Some menu commands have moved or been renamed:
      Old Location and NameNew Location and Name
      File > New Empty PuppetPuppet > New Empty Puppet
      File > New Puppet from PhotoshopPuppet > New Puppet from Photoshop
      File > New Puppet from IllustratorPuppet > New Puppet from Illustrator
      File > New SceneScene > New Scene
      Object > Add to New SceneScene > Add to New Scene
      Object > Add to PuppetPuppet > Add to Puppet
      Object > Group As PuppetPuppet > Group As Puppet
      Object > Ungroup PuppetPuppet > Ungroup Puppet
      Object > Blend Take (submenu)Timeline > Blend Take (submenu)
      Object > Compute Lip Sync from Scene AudioTimeline > Compute Lip Sync from Scene Audio
      Timeline > Move Track UpTimeline > Arrange > Move Up
      Timeline > Move Track DownTimeline > Arrange > Move Down
      Other commands that were in the Timeline menu — Play, Record, Stop, Go to Start, Zoom In, Zoom Out, Zoom to Fit, and Set Rest Pose — no longer exist in the menu bar, but still have controls elsewhere in the user interface. Their shortcuts are listed in their tooltips.
    • HTML-based online help is now available (via Help > Character Animator Help), including translated versions.
    • Mac OS X 10.11 and Windows 10 are now supported.

     

    Projects

    • Import items from another project to share or reuse its puppets and scenes.
    • Access recently opened projects from the File > Open Recent submenu.

     

    Artwork

    • Photoshop Large Document Format (.psb) files are now supported for import.
    • In Illustrator files, basic dashed strokes — dash/gap pattern, weight, cap, and corner settings — are now supported without requiring Render As Image.
    • If there is a problem incorporating external edits to an artwork file, the Auto-sync with Artwork option will be unchecked to avoid subsequent error messages when switching back to the application. Check the option to retry.

     

    Puppets and the Puppet panel

    • The Stick tool lets you define rigid segments on a warpable mesh (e.g., upper and lower arms).
    • The layers list (left sidebar) now indicates how many handles are on a subpuppet, if the subpuppet has behaviors applied, and if a trigger key is assigned to the layer. The header for the sidebar is clickable to make it easier to view and edit the behaviors associated with the top-level puppet open in the panel. Also, the sidebar can be widened by dragging its right edge.
    • Easily assign a keyboard trigger to a layer via the Trigger section in the Properties panel, instead of renaming the layer in the Puppet panel (which is no longer supported) or artwork file.
    • Layer handle icons now indicate if they were created in the panel (circle with dot) or in the artwork file and cannot be renamed or moved (circle with no dot — deletable handles as a solid circle, nondeletable origin handles as a dashed circle). Also, handle names have a darker background for improved readability.
    • When Show Mesh is checked, the displayed mesh for a puppet is the same for all layers selected that participate in the creation of that mesh.
    • Edit Original can be used on the selected layer.
    • The first time a puppet is opened in the Puppet panel, enough of its puppet hierarchy will be expanded by default to fill the height of the panel to make it quicker to access nested layers.
    • Clicking the artwork for a layer (in the right side of the panel) now expands the layer hierarchy in the left side of the panel to show the selection.
    • Option-/Alt-drag in the panel now pans its contents, similar to the Scene panel.
    • If a puppet contains only a warpable mesh (i.e., no Warp Independently subpuppets) and the Transform behavior applied, the mesh will now appear fixed in the center. This happened before if Transform values were modified, but now it happens by default.
      Workaround: Remove the Transform behavior, or move the skin layers into a Warp Independently subpuppet.

     

    Behaviors

    • Dragger (replacement for Mouse Tracker): This behavior extends the older Mouse Tracker with multi-touch display support for moving “Draggable”- or “Mousetrack”-named handles. With multi-touch, you can drag, scale, and rotate these handles.
      Supported multi-touch displays include Windows computers with touchscreens like Surface Pro or Windows/Mac computers with an attached Wacom Cintiq touch display.
      Note: Existing puppets that use Mouse Tracker will be identified as “Mouse Tracker (old)”. If you want to use a multitouch display and don’t need to retain existing recorded takes, delete the Mouse Tracker behavior from your puppets and add Draggable.
    • Cycle Layers: Added a Forward and Reverse mode, and the ability for a cycle to finish after the trigger is deactivated. Also, removed and rearranged some parameters and changed some default values for more flexibility with the revised keyboard trigger support.
    • Head Turner: This new behavior allows you to switch between different views of a character (layers named Front, Left Quarter, Left Profile, Right Quarter, Right Profile) by pivoting your head in front of the webcam.
    • Keyboard Triggers: Several improvements, including:
      • Pressing a trigger key now works in any panel — you don’t need to have the Scene panel focused.
      • Triggers can latch, so you can just press the key once to activate the trigger (e.g., show a layer), then press it again to deactivate it (e.g., hide the layer), instead of needing to hold down the key.
      • You can edit trigger settings for a selected layer in the Puppet panel via the parameters in the Trigger section of the Properties panel.
      • Keyboard Triggers applied to a nested subpuppet can now prevent a parent Keyboard Triggers behavior from controlling the content of the nested subpuppet, even when the nested behavior is disarmed.

    Note: Existing puppets that use Keyboard Triggers will be identified as “Keyboard Triggers (old)” to identify that they can’t use the new latch capability. If you want to use latch and don’t need to retain existing recorded takes, delete the Keyboard Triggers (old) behavior from your puppets and add the newer Keyboard Triggers.

    • Lip Sync: Several improvements, including:
      • Audio and lip sync accuracy has been improved. You should no longer need to slip the audio track.
      • Specific visemes can be triggered by pressing the first letter of the viseme name (with the Keyboard Input parameter armed).
      • You can convert a Lip Sync take to individual visemes for finer control of timing (using the Timeline > Split Lip Sync into Visemes menu command).
    • Behaviors can be renamed to make them easier to identify.
      The Rename Behavior command and the existing Remove Behavior command are available in the new Behavior menu in the Properties panel (when the puppet is selected in the Project or Puppet panel).
    • Behaviors that you add to a puppet are now twirled open by default in the Properties panel for quicker access to their properties.
    • Improved the layout of behaviors and their parameters in the Properties panel to make better use of the available space. For behavior and parameter names that are longer than available space, you can hover over them to view the full name in a tooltip. Also, for behaviors on subpuppets for the selected puppet, the subpuppet’s name (in brackets) after the behavior name now shows just the subpuppet’s name, along with the path to the subpuppet if needed to differentiate same-named subpuppets at different levels of the hierarchy.

     

    Timeline and Playback

    • The Recording Speed control allows you to record at slower than normal speed to capture finer movements in your performances. Playback still happens at normal speed.
    • Split track items and takes with the Edit > Split menu command.
    • Duplicate track items and takes with the Edit > Duplicate menu command.
    • Takes for the same behavior parameter now appear within a projection bar, which allows the group of takes to be modified at the same time. Twirl open a projection bar to access the takes within it. Parameter values for the take highest in the stacking order at any time will be used, with lower takes being “shadowed” by it.
    • Take blending allows the starting and ending edges of certain takes to blend smoothly with takes lower in the stacking order, to reduce abrupt changes in a value at take boundaries.
    • Trimming the starting or ending edges of a take now extends the values at those edges.
    • Selection of a parameter’s take now doesn’t, by default, also select related (linked) takes that were recorded at the same time. Control the selection of linked takes with the new Linked Selection button in the upper-left corner of the Timeline panel.
    • Take bars don’t show the take number and parameter name until they’re clicked.
    • The playhead now snaps to frame boundaries, and shows the duration of the current frame shaded in blue (when zoomed in). Override snapping by holding down Cmd (Mac) / Ctrl (Win) while dragging the playhead.
    • A behavior’s Arm for Record button will appear in dim red when the behavior does not have any parameters armed for recording. This allows you to ignore that behavior (i.e., no need to disarm it) if you don’t want any of its parameters captured during recording.

     

    Miscellaneous

    • Improved performance in various places — moving the playhead when the Microphone Input is enabled, modifying behavior parameters when the Puppet panel is visible, and viewing missing skins in the Puppet panel.
    • Warping data is now cached for improved performance, so the “Preparing scene” message (in the Scene panel) should now appear less often and for shorter durations.
    • To improve responsiveness, a scene won’t update (“Preparing puppet” or “Preparing scene” messages) unless and until the scene is visible in the Scene panel and the panel isn’t behind another panel.
    • Projects copied between Mac and Windows platforms should be quicker to open.
    • (Windows only) The Getting Started project or any project created on a Mac machine and opened on Windows is now much faster (approximately 2x) than before.
    • Improved scrolling and zooming, and panel updates during playback and scrubbing, in the Timeline panel.
    • In the Properties panel, tooltips for Arm for Record buttons for behaviors and behavior parameters (input and noninput) have been added or updated.
    • The Set Rest Pose button now has a keyboard shortcut (Cmd/Ctrl+P).
    • Darkened the horizontal lines below each behavior name in the Properties panel to improve readability and consistency.
    • Switching to the default or next camera now shows an on-screen confirmation of the operation to aid troubleshooting.

     

    Fixed issues

     

    Artwork

    • Artwork files with uppercase file name extensions no longer import as audio.
    • Illustrator files with very large guide layers should no longer cause a crash or other failures with a puppet.
    • Imported artwork with empty content for layers no longer causes an “attempt to index a nil value” error.
    • Using the Copy Media Files into Project Folder menu command in a project with missing files no longer causes the operation to fail.
    • Changes made to artwork after closing a project are now incorporated the next time you open the project.
    • For Illustrator artwork, the upper-left corner of the first artboard now determines the 0, 0 origin for the puppet and subsequently its initial position in a scene. Previously, it was using the selected artboard, which could cause unexpected placement if you changed artboard selection.
      Also, some bugs related to different artboard and document coordinates appearing offset when placed in a scene were fixed.

     

    Puppets and the Puppet panel

    • (Mac) You can type spaces again in a layer name in the Puppet panel.
    • Pasting Face Measurements data from After Effects now works for non-English versions of After Effects, as well as when values are edited in a spreadsheet application.
      Note: For non-English versions of After Effects, you’ll need version 13.6 or later for the Paste operation to work properly.
    • Opened puppets and scenes in the Puppet and Scene tab menus are now sorted in the same order as in the Project panel.

     

    Behaviors

    • Breathe: Direction and Offset should work correctly now. Also, the default Offset value is now 0.
    • Dangle: The behavior no longer affects handles it shouldn’t.
    • Dragger (Mouse Tracker):
      • If you pose a character using Hold in Place mode while stopped, then start recording, the initial posed handle locations is now captured. For example, you can pose a character’s hands at exact locations before recording.
      • Playing from the middle of a take or trimming a take no longer causes handles to be moved relative to their current location. Instead, they now play/show what was recorded.
      • When Dragger is used with Dangle, the After Move (Return to Rest, Hold in Place) options now work as intended to return handles to rest or hold them in place.
      • In Hold in Place mode, the correct handles move in puppets and subpuppets when the puppet is repositioned in the scene. Also, several issues related to Return to Rest mode have been fixed.
    • Face, Lip Sync: The Mouth layers used for these behaviors are now restricted to using layers in a “Mouth” group, which prevents unexpected matching of layers (for example, the L viseme no longer matching against a layer named “L Ear” or an “L”-named layer outside of the “Mouth” group.
    • Handle Fixer: Fixed a problem with “Fixed” in the name of a subpuppet allowing its contents (not controlled by other behaviors like Face) to move.
    • Particles: Birthed particles now match the skew of the emitter puppet as specified in the Transform behavior.
    • Changing a behavior parameter’s value by spinning the mouse wheel or vertically swiping the trackpad while the cursor is above the value now changes the value immediately, instead of requiring a click.

     

    Timeline panel

    • On some Mac configurations, selecting or deselecting puppet tracks (to arm and disarm puppets), often in Scene 2 of the Getting Started project, no longer causes a crash.
    • Selecting an audio track item now selects the track as well, no longer leaving an empty audio track if the track item is deleted.
    • Changing a scene’s frame rate now immediately updates the time ruler in the Timeline panel.
    • The error messages for when you do not have a puppet selected for the Paste (Face Measurements data from After Effects) and Compute Lip Sync from Scene Audio operations are now clearer to understand.

     

    Recording and playback

    • Trying to record a performance when the audio hardware input is not working now shows a prompt to confirm that you want to proceed.
    • Turning on Microphone Input during recording after previously turning it off during a earlier recording no longer causes endless “Incorrect time graph formulation. Error code: (EventGraphs.js:450)” error messages or the application to be nonresponsive.
    • An audio track should no longer get created during recording if the Microphone Input is disabled, even if you adjust audio preferences.
    • After recording a behavior parameter change, the Properties panel now updates to show the parameter’s default value (which the Scene panel shows while stopped).

     

    Export

    • Exporting the selected scene in the Project now works even when the scene is not currently open. Now, the scene will be opened first.
    • Exporting a scene after adjusting a nonrecorded parameter (such as the Dangle behavior’s Spring Stiffness) no longer uses the previous (not current) parameter value.

     

    Miscellaneous

    • Errors that were previously unreported (for example, imported audio that becomes missing on disk) are now shown in an error dialog box, along with a “Failed to create scene” message in the Scene panel. Previously, you wouldn’t know a problem occurred, and the “Preparing scene” message would never go away.
    • Various operations in the Project and Puppet panels no longer cause the panel’s vertical scrollbar position to reset.
    • (Windows) The application’s close box and system menu no longer get disabled if you minimize the application to the taskbar and then restore it by clicking its taskbar button.

     

    Known issues

     

    • If a scene doesn’t render (i.e., Scene panel shows only the current background color), try clicking the Refresh button at the bottom of the Scene panel. If that still doesn’t work, try Option-clicking (Mac) / Alt-clicking (Windows) the Refresh button.
    • In an Illustrator file, layers and groups with “Guide” in their name will not be interpreted as guides/handles, and their content still render even if muted in the artwork file. Only paths are supported at this time.
    • Ungrouping a subpuppet might not position the subpuppet’s contents correctly or might show a “?:0: attempt to index a nil value” error message if you then click in the Puppet panel. For now, undo the operation.
    • Background syncing or backup programs (e.g., Dropbox) can cause error messages in Character Animator if the current project’s files are being synced or backed up at the same time. Avoid creating projects in these background-synced locations, or at least avoid working in a project while syncing is enabled.
    • Background virus scanning software might cause the recording of a puppet performance to produce incorrect durations for exported audio (WAV file) or video (PNG sequence).
      Workaround: Exclude the folder containing your Character Animator projects (by default, located in your user Documents/Adobe/Character Animator/Preview (Mac) or Documents\Adobe\Character Animator\Preview (Win) folder) and its subfolders from virus scanning, or at least for write operations.
    • When viewing the mesh for a puppet in the Puppet panel (Show Mesh is checked), and the Mesh Shape is Rectangle (or would be when set to Auto), the mesh doesn’t appear.
    • Emitted particles in a scene set to greater than 24 fps can strobe.
    • (Windows) Soft (on-screen) keyboards are not support for Keyboard Triggers or functionality triggered via key presses (e.g., Cycle Layers) at this time.