9 Replies Latest reply on Feb 7, 2018 12:17 AM by kautuksahni

    AEM 6.4 beta, Apache Sling JCR Resource Resolver not present

    rijoalvi Level 1

      Hi all


      I'm trying to migrate an app so it works on AEM 6.4 beta, but I ran into the following problem:
      When I install my bundle. I get the following error:


      org.apache.sling.jcr.resource,version=[2.4,3) -- Cannot be resolved


      Right now, I'm using version 2.9.2 of org.apache.sling.jcr.resource. Here's the pom dependency:








      I checked in AEM's web console, and searched for that dependency using the dependency finder ( http://localhost:4502/system/console/depfinder ), and It turns out that package "org.apache.sling.jcr.resource" cannot be found in AEM 6.4 beta:



      I checked in AEM 6.3, but I do get a result there:


      It is because of this that I suspect that the problem is that this dependency is not present in AEM 6.4 beta. But still, I'm not an expert on dependencies so I'm not sure if this is the case, or if it's a problem on my project.

      I'd appreciate if someone can point me in the right direction on this. Basically I want to check if the problem is related to AEM 6.4 beta dependencies.