3 Replies Latest reply on Jun 27, 2018 11:01 PM by alank99101739

    Puppet goes crazy

    raphaelk36968236 Level 1

      Hello guys,

       

      I tried to recreate the Walker puppet from Okay Samurai. Unfortunately, the puppet does not react like the original, as you can see here in the video. The crazy running behavior is probably because the feet are not tagged correctly. The twitches on my head I don't understand, especially since the blink layers are set in my opinion.

       

      Can anyone please help me?

       

      The puppet file can you find here.

      https://drive.google.com/open?id=15C32P33migxh-ECAFMIt4orlj1VHEmH3

       

      I did this once in the Animate CC section because there is no character animator in the sections. Corrects that if it's wrong

      I wish you a relaxed day

       

      thank you

        • 1. Re: Puppet goes crazy
          JoãoCésar Adobe Community Professional & MVP

          Now your thread is in the correct place.

           

          I hope someone here can help you.

           

          Regards,

          JC

          • 2. Re: Puppet goes crazy
            alank99101739 Level 4

            Wow! Nice video ;-)

             

            the Head is probably insufficient independent layers for eyes and eyebrows, so blinking warps the Head. I mention it in https://extra-ordinary.tv/2018/04/21/debugging-character-animator-eyess/

             

            not sure about walk behavior, but I would get head right first

            • 3. Re: Puppet goes crazy
              alank99101739 Level 4

              Okay, so some suggestions to help (but I have not got it all working).

               

              I deleted many of the profiles - made no difference to your problem, but it made debugging easier. So you will have to repeat per profile etc, and the screen shots below will only show one profile because I deleted the others. You should keep all the profiles.

               

              Move the "neck" handles a bit lower. There needs to be a bit of a gap between the neck and head for it to warp. I moved it to where the shirt meets the skin on the neck. (It was at the top of the neck before). That helps quite a bit.

               

              I found the "Frontal" under "head" (which is independent) has a "Attach To" value that is not "auto". Change these to "auto", then move the anchor point of the "Frontal" over the neck so it goes green.

               

               

               

              Previously "attach to" was something like "Head" (not "Auto") which was a result of an old bug. Make sure all the attach to's for independent layers are "auto".

               

              Also check the yellow outline for layers maps the layers of the shape. For example, the diagram above is a rectangle. That means the contour is wrong (CH guessed it wrong). If you sent "Mesh Shape" to "Contour" that can force it to be correct. E.g. I clicked on "Body" then changed "Mesh Shape" to Contour" and the green area turned into the correct outline shape.

               

              This does not resolve all the issues (the legs still look weird), but it might help you make some progress. I would get the above going and come back with the new puppet (sorry! too lazy to fix up all those profiles!!)

              1 person found this helpful