14 Replies Latest reply: Aug 6, 2009 6:18 AM by the_wine_snob RSS

    What is it with PrPro playback...???

    fuaho Community Member

      I double click on an avi file from the hard drive (copied over from my camera) and Windows Media Player opens and it plays perfectly at 1280x720x30fps.

       

      I import that same file into PrPro CS4 and open it in the source monitor and it jerks and skips. Makes no difference what the sequence settings are, it will not play back smoothly even though it is less than 1/4 the size of the WMP image.

       

      Same computer, same codecs, same file, same everything...

       

      Why??

        • 1. Re: What is it with PrPro playback...???
          Harm Millaard Community Member

          Strange! When I open an AVI file with Excel it opens without problems and I can enter cell values, recalculate formulas, insert rows, etc, but the same file does not play in PP.

           

          The reason is that AVI is just a wrapper and does not tell what is inside. You need to tell what codec is inside the AVI.

           

           

          If you need help quickly...Guideline for posting an effective question

          • 2. Re: What is it with PrPro playback...???
            fuaho Community Member

            Your example is pretty stupid. Excel is not an avi decoder it is an xls decoder. Word is a doc or txt or rtf decoder. Photoshop is a jpg or psd or other graphics format decoder.

             

            Windows Media Player is an "unwrapper" that decodes multiple digital formats of image, movie and audio files into visible and audible output.

             

            It plays my avi file perfectly in real time so obviously there is a proper codec.

             

            After Effects will open and play the exact same video - also in real time, believe it or not, as long as I have not applied any effects, etc., to the video.

             

            What is inside is therefore totally irrelevant if both Windows Media Player and After Effects will decode the avi file. It simply means that there is a codec available that can be used to recognize what is inside the avi wrapper and decode it.

             

            Obviously PrPro can also recognize and decode the contents, it just does it really poorly. Playback is jerky, intermittent, stuttering and useless for editing.

             

            Why is that? What is PrPro doing that is not happening in WMP or AE? With Quad 3.2GHz processors, 8-GB of RAM and 1-TB of Raid 10 there are no bottlenecks in the hardware as witnessed by the fact that AE will play the file in real time.

             

            So what is wrong with PrPro CS4...???

            • 3. Re: What is it with PrPro playback...???
              Curt Wrigley Community Member

              If you are coping a video file from a camera to you desktop, its likely its AVCHD or other highly compressed format.

               

              Pr has problems playing those types of files back smoothly.   Why the others dont?  Well WMP doesnt have to be able to edit; just playback; whcih is what that type of video codec is really designed for.  Pr on the other hand has to also be able to edit at frame level a format that required multiple frames to be read to display just one frame.  So; this is harder to do.

               

              Perhaps regular playback will get better with future realeases; but thats how it is right now.

               

              The other possibility is your seq preset does not match the source file causeing Pr to have to render every frame on the fly.  If they match; it will playback much easier.

              • 4. Re: What is it with PrPro playback...???
                MarkWeiss Community Member

                I think it is becoming a well-established fact that PPro CS4 does not play well with certain quad core PCs and certain nVidia graphics cards, particularly the Quadro FX series. I was getting about 1 frame per second out of it, and despite 3 months of tweaking and Googling for remedies, I got nowhere and had to remove it and install CS3 instead, which works great. CS4 has all that fancy h.264 GPU assisted encoding stuff, so maybe in the course of optimizing it for that, they gave up performance on non GPU-assisted platforms. Just a guess. All I know is that it was the first version of Premiere Pro that was totally unusable. And I'm in good company--just search the threads for performance problems and you'll find plenty.

                • 5. Re: What is it with PrPro playback...???
                  J. Simon Community Member
                  (copied over from my camera)

                   

                  What model camera?

                  • 6. Re: What is it with PrPro playback...???
                    MarkWeiss Community Member

                    I have two PMW-EX1s and a HVR-V1U at the moment, but the playback problems are evident in DV footage and... audio footage with no video at all! In fact, I would describe it thus: the entire UI stops updating the screen for 8 seconds every 3rd second of play. Ie., the screen updates for about 3 seconds playing stuttered video at about 3-4 fps, then everything halts for 8 seconds, except audio, which continues to play. Oddly, CPU utilization drops to 4% during the 'freezes' and tops out at 38% when it's updating the screen. Very strange. OTOH, CS3 is working perfectly on this machine now.

                    • 7. Re: What is it with PrPro playback...???
                      joshtownsend Community Member

                      MarkWeiss wrote:


                      CS4 has all that fancy h.264 GPU assisted encoding stuff, so maybe in the course of optimizing it for that, they gave up performance on non GPU-assisted platforms.

                      No it doesn't there is are programs (badaboom) and plug-in's (elemental's 2000$ plug-in with bonus video card) but there is NO GPU assisted encoding going on with CS4. There are a few FX and processes that are sped up using the videocard.

                       

                      That said I understand why WMP plays video without a studder (that's what it's for) and Prpro CS4 studders. The thing I find really odd is you can get realtime full res After Effects (with no FX) playback with your file yet Premiere chokes so bad. That is wierd.

                       

                      Also just as wierd is that you still haven't told us what codec, size and length your file is. AVI is to general if you really want some help we need more than 'my avi file studders'

                      • 8. Re: What is it with PrPro playback...???
                        Rizzer Community Member

                        I agree with MarkWeiss, video cards have a lot to do with playback within Adobe products.  The Quatro is awesome for 3D but totally sucks for Premiere and AE.  I had the same issue and when i switched to an 8800 GT Nvidia my playback issues all went away.

                         

                        Fuaho, do you know what codec the file is using?  You might also investigate going to Sequence>Sequence Settings and changing the Codec under Video Previews.  Changing this has helped me in the past with certain problematic file playback issues.

                        • 9. Re: What is it with PrPro playback...???
                          MarkWeiss Community Member

                          All this stuttering/freezing is specific to CS4 however... CS3 runs fine on the Quadro. Not a single problem.

                          • 10. Re: What is it with PrPro playback...???
                            Rizzer Community Member

                            Interesting - because we had issues with CS3 too - especially AE.

                            • 11. Re: What is it with PrPro playback...???
                              Eddie Lotter Community Member

                              Please note that there is are known issues with CS4 and nVidia cards.

                              Cheers
                              Eddie

                              • 12. Re: What is it with PrPro playback...???
                                MarkWeiss Community Member

                                Been there, done that, with multiple reinstalls, different driver versions, etc. as well as two different machines with two different nVidia cards (FX4600, GTS8800).  No version of driver combination allowed Premiere CS4 to operate smoothly. UI lockups every few seconds with sound still playing.

                                Will have to wait until a new version is released and maybe try again. My main reason for CS4 is to work with XDCam footage in AfterEffects, which I can't do now without converting first to uncompressed HD, or accepting degraded images and converting to Apple Photo JPEG Quicktime files before importing. Needless to say, it puts a damper on chromakey projects, as KeyLight is only available in AE.

                                • 13. Re: What is it with PrPro playback...???
                                  JBrown321 Community Member

                                  I experience the same jerky playback. Hopefully we won't have to wait until future releases for this to be fixed. It would be great if Adobe would just step up and release frequent updates to address issues like these, even if it's one small fix at a time.  Adobe seems to be dormant about so many issues that arise.  ZZZZZZZ....wake up Adobe!

                                  • 14. Re: What is it with PrPro playback...???
                                    the_wine_snob Community Member

                                    Well, as there is no Adobe presence here (we're all just users here), there are two avenues available to you:

                                     

                                    1.) File a Bug Report/Feature Request with Adobe. Be prepared with the full details of your system, your Project, your Assets and what you are doing (assume playback). Now, that same info will apply to #2.

                                     

                                    2.) List the full specs of your system, your Project, your Assets and what you are doing here, so that someone can likely help you. As this thread ended up revolving around nVidia cards (back in April, or so), please pay special attention to your video sub-system and exactly which version drivers you are using.

                                     

                                    Problems normally break down this way:

                                     

                                    1.) System

                                     

                                    2.) Assets

                                     

                                    3.) Project

                                     

                                    4.) OE

                                     

                                    5.) Bugs

                                     

                                    With the proper info, it's often pretty easy to eliminate the first 3, and along the way #4 can usually be addressed and hopefully ruled out. There are Bugs - some known and some yet to be discovered. Still, the majority of problems stem from the first 4. Help us to help you. More detail is better.

                                     

                                    Good luck,

                                     

                                    Hunt