28 Replies Latest reply: Jul 18, 2011 8:26 PM by stevetemp77 RSS

    Strange error message when printing to PDF

    Community Member
      I am surprised that no one else has reported this issue. Searching the net, I found only one other mention of it. Using Adobe Acrobat Professional 8.1.2, when printing a document from any application using the Adobe PDF printer, the document will print correctly; however, the printer icon with a question mark will appear in the system tray and the error message "This document failed to print" will appear. When I open the Adobe PDF printer, the document is there with the status "Error - Printing".

      I can successfully delete the document (with error), though the actual .pdf document is created just fine; it is just returning an error and holding the document after every print. I have tried deleting the Adobe PDF printer, reinstalling Acrobat (both using a repair installation as well as uninstalling and reinstalling) all with the same results.

      There is nothing being logged into the system or application logs, either. I have seen this happen with two OSs at work, Vista Home Premium and WinXP SP3. Can someone guide me to a solution?
        • 1. Re: Strange error message when printing to PDF
          Bill@VT MVP
          Try printing to file and see if there is any error. If not, open the file in Distiller and see if there are any messages given.

          I have no idea what is happening, but these steps may help in the diagnosis.
          • 2. Re: Strange error message when printing to PDF
            Community Member
            Thank you, Bill, for your reply. I tried your options. It did not help. Printing to file just creates a .prn file without any issue. I tried opening the document in Distiller, and it aborts with an error message with garbage characters, that is something like:
            %%[ Error: undefined; OffendingCommand: ÐÏࡱá ]%%
            %%[ Flushing: rest of job (to end-of-file) will be ignored ]%%
            %%[ Warning: PostScript error. No PDF file produced. ] %%

            No PDF file is created in this case, evidently.

            If, however, I try to print a document to Adobe PDF, the PDF is created perfectly well, but the printer still comes up with an error message. This is irritating at two levels, (1) All the subsequent print jobs are held back, and (2) even removing the print-job that caused the error is a two step process. First, when I click 'Cancel All documents' or 'Cancel Document', it gives me a message "Deleting..." and then comes up with another error message "Error - sent to printer". I have to click 'Cancel Document' again to make it go away, and use the PDF printer for the next job.

            The trouble is that I don't even know why this problem started!!
            • 3. Re: Strange error message when printing to PDF
              Bill@VT MVP
              Set Distiller to not delete the log file after printing and then post the error message in that log file. It is likely a font issue or such, but the actual error message that is written to the log file is needed to help focus on the cause. There are a few here that are pretty good at reading the log files and you may have to wait for them. (The selection to keep the log file is in the printer properties as I recall).
              • 4. Re: Strange error message when printing to PDF
                Community Member
                All right, Bill. Here is the content of the log file that was generated along with the PDF document:
                %%[ ProductName: Distiller ]%%
                %%[Page: 1]%%
                %%[Page: 2]%%
                %%[LastPage]%%

                That's it. It had no other information. Yet, I still got the same error,
                b after
                the PDF file was generated - just like the previous times.

                Thank you for continuing to help... I am going crazy over this strange issue.
                • 5. Re: Strange error message when printing to PDF
                  Bill@VT MVP
                  Well, that indicates that everything is normal. Thus, there is something hanging up the printer function. I suspect there is some software compatibility issue, possibly with antivirus or such. I really have no more ideas. Hope that someone else will be able to give some light to the issue. The log file shows the process completed and it should have flagged the system that all is well and cleared the buffer in your printer. I might try some things with the various printer options, but I really can't suggest what to try at this point. Let's see if someone else jumps in.
                  • 6. Re: Strange error message when printing to PDF
                    Community Member
                    Thank you for your patience, Bill. It doesn't look like anyone else is going to jump in... As I said, on searching for this error on the Net, I got only one more entry at another website (one which claimed to have the answer, but I could not see the solution since I am not a member of that website).

                    This is probably going down as one of those unsolvable mysteries... And I shall just have to print documents one by one, remembering to clear the errors after every round. That's damn irritating, but I have no choice!

                    Take care.
                    • 7. Re: Strange error message when printing to PDF
                      Bill@VT MVP
                      Since I have no answer, the only thing I know to suggest is a repair on Acrobat. I would also look for anything that may offer a conflict and is running in the background. You might also try switching the Spooling selection in the print driver. It may be that spooling is not properly disengaging the printer. I have that option in the printer properties and with AA5 had turned off spolling. As I recall, I had some problems way back that led to the change. It might be worth a try at least - particularly since no one else has made a suggestion. If I am way off base, this might spark others' responses!
                      • 8. Re: Strange error message when printing to PDF
                        AtinWadehra Community Member
                        Kausik,

                        Am doing the feasbility study for migrating my application to Acrobat 8.1.3 and just printed a sample document to Adobe PDF from Word 2007 and it printed successfully.

                        My Office and Acrobat are configured with the default options. Let me know if you want me to test something.
                        • 9. Re: Strange error message when printing to PDF
                          AtinWadehra Community Member
                          Maybe you can also upgrade to 8.1.3 on for testing purpose and compare the results with 8.1.2
                          • 10. Re: Strange error message when printing to PDF
                            Community Member
                            Thanks, Bill. I did try that option, too - repairing my installation of Acrobat. But it did not help. I wish I knew what exactly is wrong, and how it came about suddenly. I shall look into the spooler question.

                            Atin, thanks for your offer. I shall do a manual update from 8.1.2 to 8.1.3. If that solves this issue, nothing like it. It strikes me that I should check for one more question - whether this is occurring only with the Office programs or with every other program as well.

                            Shall report back with the results.
                            • 11. Re: Strange error message when printing to PDF
                              Community Member
                              Atin, I just noticed that my Adobe Acrobat is at 8.1.3. Now I am slightly concerned... Did the upgrade from the 8.1.2 to 8.1.3 break the distiller printer function, thereby causing the errors?

                              Bill, Vista would not let me turn off the spooler service (spoolsv.exe). If I manually kill it, all my printers disappear. Besides, it does not stay killed, and another instance reappears in a few seconds. This is normal behaviour for all vista machines. If any printer is installed, the spooler has to run.

                              Leads? Ideas? (... solutions?)
                              • 12. Re: Strange error message when printing to PDF
                                Community Member
                                And yes, the problem is not exclusive to Microsoft Word or the other Office programs. It is happening to every other program, whenever I am printing.

                                My physical printers work fine.
                                • 13. Re: Strange error message when printing to PDF
                                  Community Member
                                  Hello,

                                  I was having the same problem (Professional 8.1.3 on Vista); someone posted a solution here (http://www.adobeforums.com/webx/.59b6f641) that solved it in my case. Hope it works for you!

                                  Mohamed
                                  • 14. Re: Strange error message when printing to PDF
                                    Community Member
                                    Mr. Raafat,
                                    You are wonderful. Thank you very much. It completely solved the issue. I am kinda surprised that such a simple solution existed and almost no one knew about it. But anyway, my problem is solved and solved.

                                    Thank you! For those who could not go to the other page, here is the solution.

                                    1 - Open Control Panel / Printers
                                    2 - Right click on the Adobe PDF printer icon
                                    3 - One of the seven visible tabs will be named PORTS
                                    4 Click on it, and you should see the "COM1 - Serial Port" box is checked, simply scroll down and check the "Documents\*pdf - Adobe PDF Port" instead (the other will uncheck itself)

                                    All the best.
                                    • 15. Re: Strange error message when printing to PDF
                                      Community Member
                                      We have seen this also, one workaround is to create a new Local Port, and call it Adobe PDF something, and point to this port insetad of the Com or LPT port that Adobe PDF seem to use.

                                      We get this however both on Acrobat 8.1.2 and 9. Manually installed as admin on Windows Server 2003.
                                      • 16. Re: Strange error message when printing to PDF
                                        Community Member
                                        The solution given above (in my last post) says the same, Mr. Hansen. Only - at least with Acrobat 8.1.3 - it is not necessary to create a separate port, the Adobe PDF port seems to be already there... it is just a matter of enabling it (thereby disabling the connection of the PDF printer to the COM port).
                                        • 17. Re: Strange error message when printing to PDF
                                          Community Member
                                          Thank you so much for this answer. You are wonderful.
                                          • 19. Re: Strange error message when printing to PDF
                                            Community Member
                                            Thank you for this conversation string. I've been having this problem for several months, and for some reason this Christmas morning it got on my last nerve as I was printing little gift poems. Your fix worked, and Mrs. Claus thanks you profusely.
                                            • 20. Re: Strange error message when printing to PDF
                                              Community Member
                                              Thanks for posting this string. I too was having this problem for a month or so, and could only find the "pay for solution" on that other website. But changing the PDF Printer port from LPT1 to DESKTOP\*.PDF port worked for me.

                                              Strange thing is that my co-worker has the same laptop model as mine, same operating system, and same Acrobat version 8.1.3 but his is still selected at LPT1 and he has no problems. And he does not have port option for *.pdf port????
                                              • 21. Re: Strange error message when printing to PDF
                                                grantem2000 Community Member
                                                I had this problem 6 months ago, solved as above and forgot about it. Problem returned last week (after Adobe Updater moved me up to 8.1.4). I had forgotten the fix and found this post on searching again. Thanks to all.

                                                One additional question: I have set the port to Documents\*.pdf. In addition I have 2 other ports both called Desktop\*.pdf in the port list - one appears directly above Documents\*.pdf and the other directly below. What is the distinction between Documents\*.pdf and Desktop\*.pdf and why do I need 2 of the latter? Question asked through curiosity only, and thanks again for posts above.
                                                • 22. Re: Strange error message when printing to PDF
                                                  Community Member
                                                  Hi all,

                                                  Have anyone attempted to fix this on a company wide scale using group policy or the like?

                                                  I have 80 intallations with this issue, and need a clever way of solving it without going to each and every PC.

                                                  I've tried using the Adobe Customizations Wizard, but no options regarding printer driver is available.

                                                  Any response on this is much appriciated.

                                                  br,
                                                  David
                                                  • 23. Re: Strange error message when printing to PDF
                                                    kausikdatta Community Member

                                                    I am forced to revisit this topic, since the recent 8.1.6 update broke the previous customizations, and I started having the same error again. Shrugging, I wanted to try the old trick of changing the port. But guess what! This time around, I could not find any port that says "desktop/*.pdf" or "document/*.pdf" as before. When I tried to add a new port, I found that the entire Adobe PDF port type was missing, and when I tried to install a new port type, it started asking for a .INF file.

                                                     

                                                    A websearch saved the day, and I stumbled onto this solution in the Adobe forums by user Gnavicks in this thread. It involved deleting cached information and letting Acrobat repair itself. It was wonderful. I got back the Adobe PDF ports in the list, and applied the old solution.

                                                     

                                                    Hope this helps someone.

                                                    • 24. Re: Strange error message when printing to PDF
                                                      Bill@VT MVP

                                                      Boy! you have been through the mill. Glad you were able to find the solutions and thanks for posting them. That posting is an important part of making the forum effective. Bill

                                                      • 25. Re: Strange error message when printing to PDF
                                                        mikec727 Community Member

                                                        I tried all of the fixes with no success on my Vista machine until I deleted a port for "bullzip pdf" which was listed along with the adobe pdf port.  Works great now.

                                                        • 26. Re: Strange error message when printing to PDF
                                                          holmebrian1 Community Member

                                                          this is happening to me in server 2003 acrobat 9.1.4 i've tried all of the suggestions here and none of them work is there some new way to fix it or what do i need to do?

                                                          • 27. Re: Strange error message when printing to PDF
                                                            iodp_tech Community Member

                                                            Well I can give you what I did to get around the problem.  I am running Adobe X pro on windows 7.

                                                             

                                                            1.  The print job in queue, cancel it so that it is deleted.  You now should have no jobs pending.

                                                            2.  Go to Control Panel\Hardware and Sound\Devices and Printers(Win7) or just the printer and devices for your OS.  Yes this must be done with Admin privilages.

                                                            3.  Go to Printer Properties for the Adobe PDF printer.

                                                            4.  Select the ports tab.  Mine was on Com3.

                                                            5.  Select Add a Port and call it Adobe Printer or something.

                                                            6.  Select the check box and select apply.

                                                             

                                                            You should now print with no errors.

                                                             

                                                            -G

                                                             

                                                            Yes I am aware this has been a year, but this has happened over several versions.

                                                            • 28. Re: Strange error message when printing to PDF
                                                              stevetemp77 Community Member

                                                              Hi,

                                                               

                                                              I was getting this error and having trouble finding a solution so thought I would post what I did to fix it for people in the future.

                                                               

                                                              Same problem as described in this post with "Error Printing" message.

                                                               

                                                              I found that because the user was not an administrator they could not print to the adobe pdf printer. Admin accounts on the same machine could print fine.

                                                               

                                                              I came across this post:

                                                               

                                                              http://www.appdeploy.com/messageboards/tm.asp?m=33657&mpage=1&key=&#33657

                                                               

                                                              which mentions giving users permissions on a registry key.

                                                               

                                                              Doing this worked perfectly for me and stopped the error (for distiller 7) the key is below.

                                                               

                                                              HKEY_LOCAL_MACHINE\SOFTWARE\Adobe\Acrobat  Distiller\7.0\PrinterJobControl
                                                              I just set users to have full control on this key.
                                                              Hope this helps someone out in the future.