12 Replies Latest reply on Sep 4, 2009 5:19 AM by Bhakti Pingale

    Problem registering a new server


      OK so I'm running CF8 developer on XP Pro SP3. I am using IIS 5.1 as my web server. I installed CF Builder and am trying to add a server. When I bring up the "Add Server" wizard, under "Application Server", the only option is JRun and it's grayed out. Does this mean I cannot setup a server with IIS? Or does that mean my configuration on my machine is screwy to where CF Builder didn't recognize that I am running IIS?

        • 1. Re: Problem registering a new server
          Kiran Sakhare

          For configuring CF server running with IIS as webserver. You need to provide "WebServer port" on which IIS is running in Add Server dialog. "JRun" is grayed out because currently server manager supports adding ColdFusion Server running on JRun ie Standalone, Multi or J2EE on JRun configurations.

          • 2. Re: Problem registering a new server
            ehaemmerle Level 1

            Hmmm I tried that. I put port 80 as that is the port IIS is using. I also went into my CF admin and made sure RDS is turned on and has a password. But when I add the server I get this in the console:


            [localhost], (07/13 at 03:34:49): Error, (07/13 at 03:34:49): Unable to connect to RDS server.

            • 3. Re: Problem registering a new server

              I had the same issue too.  I wanted to run CF via IIS 6 and could not do it.  Is there a how-to on this somewhere?

              • 4. Re: Problem registering a new server
                Kiran Sakhare Level 1

                Go to Menu Window->Preferences->Adobe->RDS Configuration.


                Select the RDS server and click Test Connection. Does it pass? if not, do you see any error?

                • 5. Re: Problem registering a new server

                  I also had the same issue... I filed a bug for this yesterday.


                  I also tried this: Window->Preferences->Adobe->RDS Configuration.


                  Error Message: Unable to contact the RDS Server. Connection refused: connect.

                  • 6. Re: Problem registering a new server
                    Bhakti Pingale



                    The RDS connection is refused in the following cases:


                    1.Server is not running: Check if the server that you have added in the Server manager has its status as running.

                    2.RDS Username/ Password: While Adding the Server, you need to specify the username and password on the first screen. If this is specified incorrectly RDS connection will fail

                    3.RDS is not activated: You might have deselected the option during install and so to enable RDS(or to check if its enabled) go to :{CF_Webroot}/WEB-INF/web.xml and check if the RDS section is not commented



                    This might not be the solution but can you just check if you are successfully able to start and stop server(through console) outside CF Builder and its not throwing any RDS related error on your console.



                    CFBuilder Team

                    • 7. Re: Problem registering a new server
                      ahamad1 Level 1

                      All these are fine...

                      • 8. Re: Problem registering a new server
                        Kiran Sakhare Level 1

                        You will receive the "Unable to contact the RDS Server. Connection refused: connect." Error occurs if CF server is not running or RDS is not enabled.

                        Just to cross check RDS is enabled. Go to {CF-Home}/wwwroot/WEB-INF/web.xml check RDSServlet section is uncommented.

                        1 person found this helpful
                        • 9. Re: Problem registering a new server

                          Make sure HTTP compression is OFF.  We battled that beast for months before figuring that out.  Apparently its an issue with the RDS add-on for Eclipse.  Dreamweaver's RDS connects fine w/ HTTP compression on.

                          • 10. Re: Problem registering a new server
                            ehaemmerle Level 1

                            Ok folks well I got mine working. After I commented out the RDS stuff in web.xml, I rebooted my computer to not only to restart the service, but just because I hadn't in a while. So when it came back up, this RDS stuff still did not work so I gave up and went to go develop one of my sites and noticed that my sites were now not coming up. For whatever reason, after I rebooted, my CF service did not automatically start. Very weird. AND it didn't WANT to start. I had to try two or three times to get it to start. It finally started and after that, all the RDS stuff in CF builder started to work. SWEET! Thanks.

                            • 11. Re: Problem registering a new server
                              dgreywolf Level 1

                              I'm on SuSE 10.3 ( under Gnome.


                              I've been developing software for more years than I'd care to count.


                              I'm really new to ColdFusion.  I'm trying to support a site for a client that was developed using this tool.


                              I'm running ColdFusion 8.01 (Developer Version). from a download done on 6/7/2009.


                              I'm using Eclipse3.4.2 with the ColdFusion Extensions for Eclipse, Version 1.0.191910.


                              I also have version of CFEclipse Project installed.


                              I can provide whatever other version information is required.


                              I had all of the tools installed and playing together nicely back in June.


                              I had my workspace get corrupted, and have been trying to get things back together for a month.


                              It all seemed so simple, and worked the first time when I followed the examples for setting up debugging.


                              I may have been on a different version of Eclipse at the time.


                              I can't seem to get debugging installed and working for ColdFusion, despite Googling myself to death.


                              The Eclipse/ColdFusion versions that I find in the examples don't match, and things seem to rapidly change in that environment.


                              I've installed ColdFusion as a stand alone, with RDS installed and am using Apache 2.


                              I'm stuck trying to connect to the RDS server.  I've checked via netstat -an and don't see anything listening on port 8500.


                              I've got an RDS Dataview tab at the bottom of the screen in which there is a server of 'localhost'.  Trying to open that server results in a message of "Unable to contact the RDS Server 'localhost'.


                              Right clicking the server and selecting "RDS Configuration", I can change the configuration for localhost.

                              I've tried using port 8500 and port 80 and clicking on 'Test Connection' without success.


                              I've checked ../wwwroot/WEB-INF/web.xml to make sure that the RDS section was not commented out.

                              I added a '<load-on-startup>10</load-on-startup>' tag and then saw nine 'user RDSServlet: init' messages in the cfserver.log file, after I restarted ColdFusion.


                              I'll be happy to provide whatever logs or files that are needed to help diagnose this.


                              I'd be happy to hear just how simple it is to change a configuration somewhere so that it all starts working. 


                              I'd be more than happy to install whatever versions of software that would be necessary to get this working.


                              Thanks in advance for any and all help.


                              Don Phillips

                              • 12. Re: Problem registering a new server
                                Bhakti Pingale Level 2

                                Hi Don,


                                Just do one simple thing,

                                Mail us the URL of your CFIDE/administrator page.

                                For e.g.: My administrator page link is http://localhost:88/CFIDE/administrator/index.cfm


                                This way we can check what port is your ColdFusion running on?