22 Replies Latest reply: Jan 19, 2011 9:59 AM by xrjj3322 RSS

    FP 10 ActiveX Failed Install through Group Policy

    hackerjoe19934

                   Around a month or so ago one of the Engineers pushed out Flash Player 10 ActiveX out using Group policy. Over the past week or so we have gotten a few people saying they needed to have Flash Player installed. I went to look and it shows its installed for them but it doesn't work. I went into Add/remove programs and it shows its installed?

                    I tried to remove it an get an error stating --Error 2753.The 'FP_AX_MSI_INSTALLER.exe' is not marked for installation. I tried running a group policy update and rebooted but nothing happens so I have to manually install it at that point to get the user back to work and not waste too much time.

                       One last thing some of the PC's had older versions installed and I think 1 didn't so not sure if that makes a difference. I have done soe searching and can't find anything to answer it correctly or in away I understand it.

      Does anyone have any suggestions or explainations?

      Thanks in advance

       

      Joe

        • 1. Re: Flash Player 10 ActiveX Failed Install through Group Policy
          hackerjoe19934 Community Member

          Wow, no one has an explaination for this ?

          • 2. Re: Flash Player 10 ActiveX Failed Install through Group Policy
            egibson@ritaohio.com

            I receive the same error when updating Flash Player based on the vulnerability. We're trying to upgrade from Adobe Flash Player 10.0.22 to 10.0.32.18. Is there still no help on this issue?

            • 3. Re: FP 10 ActiveX Failed Install through Group Policy
              MeppyHoldings Community Member

              Deploying by GPO is just not working for me either, getting similar results as you are.  Adobe support proving rather painful with no proper help so far.  I think that their MSI is just plain broken and unsure why it's not being fixed.  It might be easier to build our own MSI than rely on the Adobe one?

               

              I get the same error when trying to uninstall that corrupt install.  This must be affecting many many admins?

              • 4. Re: FP 10 ActiveX Failed Install through Group Policy
                egibson@ritaohio.com Community Member

                Morning,

                 

                I've have played with this msi so much I'm not sure how it started working. My organization is broken into 3 parts. 2 environments work out of 3. Nothing different performed for the 3rd group.

                 

                It's going to take patience.

                 

                1). Save the msi to your desktop

                2). Create a network share

                3). Run the desktop msi with an admin install like this msiexec /a "C:\Documents and Settings\egibson\Desktop\install_flash_player_10_active_x.msi" when the wizard asks store or install to the network share you created

                4). From 1 test computer navigate to network share and run the msi manually - if it runs successfully it is good

                5). If the msi fails AP_AX_MSI_....exe is not marked for install error returns (I noticed in Add Remove programs the adobe activeX 10 looks like the install icon) upon failure - I ran our old msi Adobe ActiveX version 10.0.22.87 and received a message "There is a more current version of Adobe. Please visit adobe.com for the latest version."

                 

                But it reinstalled our old version 10.0.22.87 anyway - if I look in Add Remove programs Adobe is there with the red logo instead of the install icon

                 

                Now run the new msi Adobe ActiveX version 10.0.32.18 it ran successfully. I then created my GPO and it appears to be good for now.

                 

                If you can test a pc - link it using the GPO you created from command prompt type gpupdate /force

                Go to the pc and watch it boot. When mine were successful I saw uninstalling Adobe ActiveX ... then installing Adobe ActiveX ...

                 

                I now must try and repair the 1 environment that didn't work.

                 

                It took me an entire day to get this working. I'm sure I will have to explain that to Management.

                 

                Hope this helps. It is quite frustrating. I contacted Adobe support - they gave me no help. I think to problem has to do with the version of Adobe not successfully uninstalling.

                 

                Eleanora

                • 5. Re: FP 10 ActiveX Failed Install through Group Policy
                  xrjj3322

                  I see this is somewhat old, but I had the same problem in our environment.  Had Flash 10.0 deployed via group policy.

                    Removed the policy, but didn't force an unisntall from group policy.  I tried to install v 10.0.42.34 manually and received the same errors as noted above.

                   

                  The final solution was to manuall install v 10.0 again then uninstall.  Once that was done I could install 10.0.42.34 without errors. No to see if I can get this process to work through group policy.

                  • 6. Re: FP 10 ActiveX Failed Install through Group Policy
                    CurtFinley

                    I think I may have found a solution to this.  It seemed to work on two machines.  I'd like to test it out on more but

                    I ran out of known bad machines.  Here is what I did.

                     

                    1) Uninstall flash with the Windows installer cleanup utility.  The cleanup utility can be downloaded from http://support.microsoft.com/kb/290301.  I uninstall it this way because, in my situation,  the regular add/remove programs way doesn't work.

                    2) Delete the C:\Windows\system32\Macromed directory (you might want to back it up before deleting it)

                    3) Reboot and install the latest version of flash.

                     

                    I don't make any promises on this but it seemed to work for me.

                     

                    Curt

                    • 7. Re: FP 10 ActiveX Failed Install through Group Policy
                      Daubeware

                      "Windows Installer Cleanup  utility" has been removed from site :

                       

                      "This article previously contained a link to the Windows Installer Cleanup  utility (MSICUU2.exe). If you were directed to this article to solve a problem  installing a product other than Microsoft Office, please contact your software  manufacturer for installation support on the product.

                       

                      While the Windows  Installer Cleanup utility resolved some installation problems, it sometimes  damaged other components installed on the computer. Because of this, the tool  has been removed from the Microsoft Download Center. The Fix it Solutions in  this article provide the ability to fully remove Office 2003, 2007 and 2010  suites without damaging other Windows components."

                      • 8. Re: FP 10 ActiveX Failed Install through Group Policy
                        pwillener CommunityMVP

                        The Windows Installer Cleanup Utility can still be obtained from various 3rd-party download sites, such as http://majorgeeks.com/download.php?det=4459

                        • 9. Re: FP 10 ActiveX Failed Install through Group Policy
                          Daubeware Community Member

                          Yes, but Microsoft say :

                          "While the Windows  Installer Cleanup utility resolved some  installation problems, it sometimes  damaged other components installed  on the computer."

                           

                          Works for me the solution xrjj3322 :

                           

                          "The final solution was to manuall install v 10.0 again then uninstall."....

                           

                          For each computer (200).... 

                          • 10. Re: FP 10 ActiveX Failed Install through Group Policy
                            steven_azman

                            I have been seeing this same issue on several PCs in my domain. I think the issue is occurring because those PCs may have been installed or manually updated and then when we push out a new update it breaks it completely.

                             

                            The steps I have done to resolve this were mentioned a previous post:

                             

                            Step 1: remove the flash group from the computer object
                            Step 2: reboot and  manually uninstall Flash
                            Step 3: use cleanup util to remove Flash  completely
                            Step 4: add the Flash group to computer object
                            Step 5: reboot  for flash to install

                            • 11. Re: FP 10 ActiveX Failed Install through Group Policy
                              morph2-21 Community Member

                              Just want to add one thing to this old thread. I'm seeing the same problem where I work. Steps that I did were:

                               

                              • Move the problem PC from one OU to another OU that doesn't have Flash Player GPO package
                              • Restart the PC - at this time all packages deployed thru GPO are automatically removed/uninstalled from the PC
                              • Login to PC (or login to domain) and manually remove or uninstall Flash Player. This steps fails to complete. I still get the same error that says Flash Player can't be uninstalled so I continue to the next step.
                              • Manually install Flash Player (any version will do). This is successful.
                              • Manually uninstall Flash Player. This is also successful.
                              • Move PC back to the OU that has Flash Player package.
                              • Restart PC and let it install Flash Player automatically.
                              • 12. Re: FP 10 ActiveX Failed Install through Group Policy
                                egibson@ritaohio.com Community Member

                                After a great deal of frustration.

                                 

                                To solve the issue. I installed Windows Clean up utility and removed flash player or any unwanted item.

                                 

                                From the command prompt type gpupdate /force and respond yes

                                 

                                The current/new gpo for flash player installed.

                                • 13. Re: FP 10 ActiveX Failed Install through Group Policy
                                  FSGDAG

                                  I'm sorry to be posting to an old post, but we are also running into this issue. From my testing it would seem the only way to get it to work is the following:

                                   

                                  - Uninstall from Program and Features

                                  - Install Windows Cleanup Util and remove Flash

                                  - Reinstall Flash using the MSI package

                                   

                                  The difference between my installation and many of yours is that I didn't use a GP to install it. Can anyone help me in being able to accomplish steps 1 and 2 above using a script or batch file? I have 200 machines and to have to do it manually would be gruesome!

                                   

                                  Any help anyone is willing to give is GREATLY appreciated!

                                  • 14. Re: FP 10 ActiveX Failed Install through Group Policy
                                    joemde

                                    Hello,

                                     

                                    I uninstall Flash with the following batch skript:

                                     

                                    set PROGDIR=%ProgramFiles%\Adobe

                                    set INSTDIR=%FILES%\Tools\Adobe Flash Player_UI

                                    set INDIKATOR=%PROGDIR%\FlashUninstall.txt

                                     

                                    if exist "%INDIKATOR%" goto end

                                     

                                    "%INSTDIR%\uninstall_flash_player.exe" -uninstall

                                     

                                    reg.exe DELETE HKEY_CLASSES_ROOT\Installer\Products\00AB3E66D3B6B66469AF36907A4FB20B                   /f

                                    reg.exe DELETE HKEY_CLASSES_ROOT\Installer\Products\690EC210AB6064f4E898B0F409E04797                   /f

                                     

                                    reg.exe DELETE HKEY_CLASSES_ROOT\Installer\Products\30D9D84132D5F4D45B0DAB06034CD5FC                   /f

                                    reg.exe DELETE HKEY_CLASSES_ROOT\Installer\Products\FB0D7F53BA803E244A30FA7927CA12A6                   /f

                                     

                                    reg.exe DELETE HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\00AB3E66D3B6B66469AF36907A4FB20B /f

                                    reg.exe DELETE HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\690EC210AB6064f4E898B0F409E04797 /f

                                     

                                    reg.exe DELETE HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\30D9D84132D5F4D45B0DAB06034CD5FC /f

                                    reg.exe DELETE HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\FB0D7F53BA803E244A30FA7927CA12A6 /f

                                     

                                    echo >"%INDIKATOR%"

                                     

                                    :end

                                     

                                    After the next reboot the actual version of flash will be installed through group policy.

                                     

                                    I hope this helps :-)

                                     

                                    Joachim Emde

                                    • 15. Re: FP 10 ActiveX Failed Install through Group Policy
                                      JoseFehse

                                      Replying to an old topic, I've just tried Eleanora's suggestions it seemed to work. But while I was writing here on this forum, something happened. I had tried to run the about page, it had worked. I removed the flash and the removal worked. Now I went to try to remove it again and it didn't work anymore.

                                      Too weird.

                                      I'll try to figure out and get back to you.

                                       

                                      Thank you,

                                       

                                       

                                      Jose Fehse

                                      MCSE,MCITP

                                      Toronto, ON

                                      • 16. Re: FP 10 ActiveX Failed Install through Group Policy
                                        JoseFehse Community Member

                                        In the next chapter of the Soap Opera, I removed everything from the machine (very painfully, since I had to install the applications manually to be able to remove them) and then removed the computer from the OU, put it back there, redeployed adobe flash activeX and adobe reader X(which by the way,had disappeared from the machine even it was showing on add/remove programs) and Alakazam! Everything works. The question is: for how long?

                                         

                                        Since I don't like myself, I tried to remove the flash plugin...and it seemed to work. No complains...but...a F5 on the Add/Remove programs screen and...there is the freaking Plugin now with the weird default installation Icon (not the adobe one...) .Adobe reader is still there. Was not affected.

                                         

                                        Now I tried a lot of things, since removing using adobe's uninstaller (didn't work, I could still see the entry in ARP (Add/Remove programs).

                                        Tried to remove manually, looking for pieces and bits in the registry. It disappeared from ARP but forcing the policy didn't install it again.

                                         

                                        Well, I'll keep trying will let you all know.

                                         

                                         

                                        Thank you,

                                         

                                        Jose Fehse

                                        • 17. Re: FP 10 ActiveX Failed Install through Group Policy
                                          JoseFehse Community Member

                                          Well, it seems to come down to a few points:

                                          - If you use msi after the administrative installation, it installs right and flash works inside the browser;

                                          - If you try to remove manually on Add/Remove programs, it will remove most of the files but the entry will remain there (with a default computer icon, not the adobe one);

                                          - You can remove it by manually reinstalling the Active Plugin and then removing it.

                                          - The policy won't reinstall it correctly again unless you remove the computer from the OU, refresh the policy, put the computer back in the OU that has the policy and then refresh it (reboot). Then you get your flash plugin working again.

                                           

                                          I believe it's not right and is related to the GPO itself, since removing the policy completely was the only thing that worked in the end,but Adobe's uninstallation procedure is also not right (the uninstaller won't work either).

                                           

                                           

                                          Hope it helps somebody.

                                           

                                          Thank you,

                                           

                                          Jose Fehse

                                          • 18. Re: FP 10 ActiveX Failed Install through Group Policy
                                            CurtFinley Community Member

                                            Instead of removing it from the OU does it work to do a

                                             

                                            gpupdate /force

                                             

                                            Curt

                                            • 19. Re: FP 10 ActiveX Failed Install through Group Policy
                                              JoseFehse Community Member

                                              Nope. Gpupdate /force only worked after I removed the computer. And then run GPupdate, then put it back, and then another GPUpdate /force. Unless I remove it, it will install a crippled version of the player.

                                               

                                              Thank you,

                                               

                                              Jose Fehse

                                              • 20. Re: FP 10 ActiveX Failed Install through Group Policy
                                                xrjj3322 Community Member

                                                what I have found to be the most effective solution to deploying flash via group policy is to NOT use the MSIs as the source for the installations.  No matter how diligent you are to remove the problematic version and get a successful install working based on an MSI, you will eventually run into the same problems after a few upgrades.

                                                 

                                                The solution I have been using for a while now, is to deploy the EXE through a computer startup script in AD.  The script will check the registry for the installed version, and if it is not the desired version, the script will silently install flash.  I tried this method after dealing with several frustrating 10.0.x upgrades deployed with the msi.  I have not had a single upgrade issue using this method.

                                                 

                                                the one caviat - to getting this to work, you have to ensure that you completely remove any existing problematic installs.

                                                 

                                                Here is the script.  Place this script in the Computer/statup scripts.  This runs as the system, so user rights are not an issue.


                                                REM Modify these parameters for most recent versions
                                                REM ----------------------------------------------------
                                                set DesiredVersion="10,1,102,64"     <-- upgrade 1 client manually and check the reg path for flash player to get the version number and update it here.
                                                Set InstallDirectory=<\\pathf to file share where the install is located at>

                                                Set InstallFileName=flashplayer_10.1.102.64.exe


                                                :CurrentVersionCheck
                                                REM Check for existance of Version
                                                REM -----------------------------------------
                                                echo performcing new version check
                                                reg query "HKLM\SOFTWARE\Macromedia\FlashPlayer" | findstr %DesiredVersion%

                                                if %errorlevel%==1 (goto InstallNewVersion) else (goto End)


                                                :InstallNewVersion
                                                REM --------------
                                                echo installing new vesrion

                                                start /wait %InstallDirectory%%InstallFileName% -install


                                                GOTO End

                                                :End

                                                • 21. Re: FP 10 ActiveX Failed Install through Group Policy
                                                  JoseFehse Community Member

                                                  Hey,tks a lot for the advice. I will certainly try that. It may be the best option. The MSI's are pretty frustrating to work with.

                                                  You also do that for the Reader? The reader seemed to work much better with the native MSIs...maybe it's another subject and also another topic...

                                                   

                                                  Thank you,

                                                   

                                                   

                                                  Jose Fehse

                                                  • 22. Re: FP 10 ActiveX Failed Install through Group Policy
                                                    xrjj3322 Community Member

                                                    I have had no problems deploying reader with an msi admin install source. I also use the tuning wizard adobe provides to manage the transform files.  New installs, upgrades, and removals have never been a problem.  Which begs the question, why are the msi installs of flash so terrible?

                                                     

                                                    Hope that script works out for you, it saved me a ton headaches. I got the idea after upgrading our citrix client to version 11.  Our choice was to deploy the exe install via a similar script, or install 6 individual msis in a specific order.