21 Replies Latest reply on Feb 5, 2010 7:16 PM by gordon-peterson

    Content Assist Error

    anoweb Level 1

      While using Flash Builder 4 beta things will be working fine and then all of a sudden I get a popup error saying:


      "Content Assist" did not complete normally.  Please see the log for more information.


      I'm not sure where the log file is, but if I restart Eclipse (i.e. Flash Builder) things will work again, for a little while, then the error comes back.
      Any ideas?

        • 1. Re: Content Assist Error
          teppichleger Level 1



          I have this error too. In my case it helps to remove and add the Flas SDK 4 to the project. Unfortunately this error message is thrown every 30 seconds, so I have to set the SDK all the time instead of do some coding.


          The result is I use FB3.


          @Adobe guys: any ideas?




          • 2. Re: Content Assist Error
            anoweb Level 1

            Interesting, I'll have to try that.


            My work around is to use IntelliJ IDEA....I'm trying to hold hope for Flash Builder (which is why I'm trying the Beta)...but IntelliJ is working really well so far (and it naturally supports Maven, unlike Flash Builder unless you install m2eclipse...although Flex Mojos support is supposed to be in a future version of m2eclipse).

            • 3. Re: Content Assist Error
              Jason San Jose Adobe Employee

              The log file is in your workspace/.metadata/.log. You can also access it in the UI at:


              Help > About Eclipse Platform > Configuration Details > View Error Log


              If you can find the error message still, please file a bug. Thanks!


              Jason San Jose

              Quality Engineer, Flash Builder

              • 4. Re: Content Assist Error
                ZhouTao Level 1

                HI,I had get this error to.

                And this is the log file . Is there any method to fix it?thanks.

                !ENTRY org.eclipse.ui 4 4 2009-09-25 12:32:13.878
                !MESSAGE "Content Assist" did not complete normally.  Please see the log for more information.


                !ENTRY org.eclipse.ui 4 0 2009-09-25 12:32:13.878
                !MESSAGE java.lang.NullPointerException
                !STACK 0
                    at com.adobe.flexbuilder.codemodel.internal.asdoc.ClassCommentRef.<init>(ClassCommentRef.jav a:36)
                    at com.adobe.flexbuilder.codemodel.internal.tree.ClassNode.getDynamicCommentRef(ClassNode.ja va:698)
                    at com.adobe.flexbuilder.codemodel.internal.tree.BaseDefinitionNode.getComment(BaseDefinitio nNode.java:273)
                    at com.adobe.flexide.as.core.contentassist.ActionScriptCompletionProposal.<init>(ActionScrip tCompletionProposal.java:145)
                    at com.adobe.flexide.as.core.contentassist.ActionScriptCompletionProcessor.getTypeProposal(A ctionScriptCompletionProcessor.java:654)
                    at com.adobe.flexide.as.core.contentassist.ActionScriptCompletionProcessor.createProposalsFr omDefinitions(ActionScriptCompletionProcessor.java:903)
                    at com.adobe.flexbuilder.dcrad.core.DCRADContentAssistProcessor.createProposalsFromDefinitio ns(DCRADContentAssistProcessor.java:131)
                    at com.adobe.flexide.as.core.contentassist.ActionScriptCompletionProcessor.createLocalVariab leProposals(ActionScriptCompletionProcessor.java:753)
                    at com.adobe.flexide.as.core.contentassist.ActionScriptCompletionProcessor.computeCompletion Proposals(ActionScriptCompletionProcessor.java:1091)
                    at com.adobe.flexide.mxml.core.editor.MXMLActionScriptCompletionProcessor.computeCompletionP roposals(MXMLActionScriptCompletionProcessor.java:161)
                    at com.adobe.flexbuilder.dcrad.core.DCRADContentAssistProcessor.computeCompletionProposals(D CRADContentAssistProcessor.java:103)
                    at org.eclipse.jface.text.contentassist.ContentAssistant.computeCompletionProposals(ContentA ssistant.java:1832)
                    at org.eclipse.jface.text.contentassist.CompletionProposalPopup.computeProposals(CompletionP roposalPopup.java:556)
                    at org.eclipse.jface.text.contentassist.CompletionProposalPopup.access$16(CompletionProposal Popup.java:553)
                    at org.eclipse.jface.text.contentassist.CompletionProposalPopup$2.run(CompletionProposalPopu p.java:488)
                    at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
                    at org.eclipse.jface.text.contentassist.CompletionProposalPopup.showProposals(CompletionProp osalPopup.java:482)
                    at org.eclipse.jface.text.contentassist.ContentAssistant.showPossibleCompletions(ContentAssi stant.java:1660)
                    at org.eclipse.jface.text.source.SourceViewer.doOperation(SourceViewer.java:835)
                    at org.eclipse.jface.text.source.projection.ProjectionViewer.doOperation(ProjectionViewer.ja va:1533)
                    at com.adobe.flexide.editorcore.editor.FlexSourceViewer.doOperation(FlexSourceViewer.java:15 8)
                    at org.eclipse.ui.texteditor.TextOperationAction$1.run(TextOperationAction.java:131)
                    at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
                    at org.eclipse.ui.texteditor.TextOperationAction.run(TextOperationAction.java:129)
                    at org.eclipse.jface.action.Action.runWithEvent(Action.java:498)
                    at org.eclipse.ui.commands.ActionHandler.execute(ActionHandler.java:185)
                    at org.eclipse.ui.internal.handlers.LegacyHandlerWrapper.execute(LegacyHandlerWrapper.java:1 09)
                    at org.eclipse.core.commands.Command.executeWithChecks(Command.java:476)
                    at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.jav a:508)
                    at org.eclipse.ui.internal.handlers.HandlerService.executeCommand(HandlerService.java:169)
                    at org.eclipse.ui.internal.keys.WorkbenchKeyboard.executeCommand(WorkbenchKeyboard.java:470)
                    at org.eclipse.ui.internal.keys.WorkbenchKeyboard.press(WorkbenchKeyboard.java:824)
                    at org.eclipse.ui.internal.keys.WorkbenchKeyboard.processKeyEvent(WorkbenchKeyboard.java:880 )
                    at org.eclipse.ui.internal.keys.WorkbenchKeyboard.filterKeySequenceBindings(WorkbenchKeyboar d.java:569)
                    at org.eclipse.ui.internal.keys.WorkbenchKeyboard.access$3(WorkbenchKeyboard.java:510)
                    at org.eclipse.ui.internal.keys.WorkbenchKeyboard$KeyDownFilter.handleEvent(WorkbenchKeyboar d.java:125)
                    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
                    at org.eclipse.swt.widgets.Display.filterEvent(Display.java:1191)
                    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1002)
                    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1027)
                    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1012)
                    at org.eclipse.swt.widgets.Control.traverse(Control.java:3658)
                    at org.eclipse.swt.widgets.Control.translateMnemonic(Control.java:3502)
                    at org.eclipse.swt.widgets.Composite.translateMnemonic(Composite.java:1065)
                    at org.eclipse.swt.widgets.Control.translateMnemonic(Control.java:3520)
                    at org.eclipse.swt.widgets.Display.translateMnemonic(Display.java:4401)
                    at org.eclipse.swt.widgets.Display.filterMessage(Display.java:1205)
                    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3469)
                    at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2405)
                    at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2369)
                    at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2221)
                    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:500)
                    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
                    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:493)
                    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
                    at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:113)
                    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:194)
                    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLau ncher.java:110)
                    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.jav a:79)
                    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368)
                    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
                    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                    at java.lang.reflect.Method.invoke(Method.java:597)
                    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)
                    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
                    at org.eclipse.equinox.launcher.Main.run(Main.java:1311)

                • 5. Re: Content Assist Error
                  MLKiiwy Level 1



                  I have the same error too ... => I can't use Flash Builder for my work on Flex 4, so i use Flex Builder 3.

                  But have you a fix for this problem ?


                  For informations :

                  I use the last version of Flash Builder, and Java.

                  I try to update Eclipse but the error still exist.



                  • 6. Re: Content Assist Error
                    Alconis-MY9GnN Level 1

                    Same error for me and all the members of my team.

                    In particular cases, it keeps throwing me the null pointer exception while using content assist via CTRL+Space.


                    This is really annoying my Flex 4 development. Is there a workaround?

                    • 7. Re: Content Assist Error
                      Jason San Jose Adobe Employee

                      Have you seen this error in Beta 2? If so, please file a bug with a reproducable case. In some cases though, a clean workspace fixes the problem. Not the best workaround, but it's worth a try.


                      Jason San Jose

                      Quality Engineer, Flash Builder

                      • 8. Re: Content Assist Error
                        Jason San Jose Adobe Employee

                        What I really meant to say is, please add your comments and workspace log to this bug http://bugs.adobe.com/jira/browse/FB-21566.


                        It's been a tough one to track down, it doesn't happen for everyone. Any additional info you can provide would be great: project type, SDK version (and build number if you're using a nightly), file type, and library path would all be helpful here.


                        Jason San Jose

                        Quality Engineer, Flash Builder

                        • 9. Re: Content Assist Error
                          ZhouTao Level 1

                          this bug never appeard in this two days when i used it.I think it's been fix now.

                          • 10. Re: Content Assist Error
                            Alconis-MY9GnN Level 1

                            No, it's not been fixed. I'm still experiencing it with Flash Builder Beta 2 following configuration :


                            Adobe Flash Builder Standalone: version

                            Flex 4.0.0 SDK: build 10485

                            • 11. Re: Content Assist Error
                              Jason San Jose Adobe Employee

                              Any libraries on your library path? If you're willing/able, please send us your project as an FXP or your workspace .metadata folder for the log and Eclipse/FB caches.


                              Jason San Jose

                              Quality Engineer, Flash Builder

                              • 12. Re: Content Assist Error
                                AdelaCampean Level 1

                                I am having the same problem. Did you find any solution to it?

                                Thanks, Carmen

                                • 13. Re: Content Assist Error
                                  AdelaCampean Level 1

                                  Are any of you using subclipse for versioning? Maybe that is the problem...

                                  On the project I am using subclipse I have this error. On another project where I am not using subclipse I do not have the error.

                                  Anyway... any suggestion would be very very appreaciated!

                                  thank you


                                  • 14. Re: Content Assist Error
                                    Jason San Jose Adobe Employee



                                    Repeating on the bug comments and on the beta forum...


                                    PLEASE try a clean workspace. In detail:


                                    1) Export the project as an FXP from the workspace that has the problem

                                    2) File > Switch Workspace > Other..., choose a new, empty folder

                                    3) Import the FXP

                                    4) Try code hints


                                    We have in the past seen problems with workspace caches. If we can rule this out, it would help us a lot. I'm trying my best to reproduce the issue, but with no success. The error indicates that a class in your project has no ancestor project...which normally isn't possible unless a cache has gone bad. Again, I need more help since I can't reproduce this. Thanks guys.


                                    Jason San Jose

                                    Quality Engineer, Flash Builder

                                    • 15. Re: Content Assist Error
                                      gizmow Level 1

                                      With a clean workspace it's the same (Beta 2)


                                      !ENTRY org.eclipse.ui 4 4 2009-10-13 10:15:27.339
                                      !MESSAGE La commande "Assistant de contenu" ne s'est pas exécutée normalement.  Pour plus d'informations, consultez le journal.


                                      !ENTRY org.eclipse.ui 4 0 2009-10-13 10:15:27.339
                                      !MESSAGE java.lang.NullPointerException
                                      !STACK 0
                                          at com.adobe.flexbuilder.codemodel.internal.asdoc.ClassCommentRef.<init>(ClassCommentRef.jav a:36)
                                          at com.adobe.flexbuilder.codemodel.internal.tree.ClassNode.getDynamicCommentRef(ClassNode.ja va:779)
                                          at com.adobe.flexbuilder.codemodel.internal.tree.BaseDefinitionNode.getComment(BaseDefinitio nNode.java:334)
                                          at com.adobe.flexide.as.core.contentassist.ActionScriptCompletionProposal.<init>(ActionScrip tCompletionProposal.java:151)
                                          at com.adobe.flexide.as.core.contentassist.ActionScriptCompletionProcessor.getTypeProposal(A ctionScriptCompletionProcessor.java:691)
                                          at com.adobe.flexide.as.core.contentassist.ActionScriptCompletionProcessor.createProposalsFr omDefinitions(ActionScriptCompletionProcessor.java:952)
                                          at com.adobe.flexide.as.core.contentassist.ActionScriptCompletionProcessor.createLocalPropos als(ActionScriptCompletionProcessor.java:786)
                                          at com.adobe.flexide.as.core.contentassist.ActionScriptCompletionProcessor.computeCompletion Proposals(ActionScriptCompletionProcessor.java:1142)
                                          at org.eclipse.jface.text.contentassist.ContentAssistant.computeCompletionProposals(ContentA ssistant.java:1836)




                                      • 16. Re: Content Assist Error
                                        Jason San Jose Adobe Employee

                                        A more surgical workaround that allows you to keep your workspace settings:


                                        1) Quit FB

                                        2) Delete this folder: .metadata\.plugins\com.adobe.flexbuilder.codemodel

                                        3) Restart FB


                                        Cleaning out the caches works for most people, but others are still reporting the same issues after the workarounds. We're continuing to track this bug here http://bugs.adobe.com/jira/browse/FB-21566.


                                        Jason San Jose

                                        Quality Engineer, Flash Builder

                                        • 17. Re: Content Assist Error
                                          AdelaCampean Level 1

                                          This works for me.

                                          Thank you!


                                          • 18. Re: Content Assist Error
                                            pajr Level 1

                                            It seems that the following:


                                            "Delete this folder: .metadata\.plugins\com.adobe.flexbuilder.codemodel"


                                            is the current workaround.


                                            Can someone point me to where that folder is on OSX?  I've dug and dug, and removed similar folders, but nothing fixes the issue.


                                            Thanks in advance...

                                            • 19. Re: Content Assist Error
                                              Jason San Jose Adobe Employee

                                              The default location is /Users/username/Documents/Adobe Flash Builder 4/


                                              Jason San Jose

                                              Quality Engineer, Flash Builder

                                              • 20. Re: Content Assist Error- i solved problem~~!
                                                barty82@naver.com Level 1

                                                if you want to solve this problem.

                                                you have to have a well operated workspace....

                                                (i have several workspaces one of them is broken some of them are working well)


                                                all you need to do is copy the folder in well working workspace. (.metadata/.plugins/com.adobe.flexbuilder.codemodel)

                                                and then paste in to current workspace you were working on...


                                                try and hit me back if you have any question~!



                                                • 21. Re: Content Assist Error
                                                  gordon-peterson Level 1

                                                  Every time I export a new swc from Flash I get this error. I don't have to replace any files in the .metadata, I just reboot Flash Builder. Anyone else having this problem?