3 Replies Latest reply: May 15, 2010 1:51 AM by c.pfaffenbichler RSS

    Default Proof Setup Monitor RGB set but not working

    nigelfreeney Community Member

      When I open a photo I want it to be displayed by default in Monitor RGB as I generally work with images for the Internet.

       

      With all image windows closed I have clicked on

      View | Proof Setup | Monitor RGB

       

      correct-menu-choice.gif

      proof-not-applied-correctly.jpg

       

      When I then open an existing photo it is clearly not showing Monitor RGB proof although if I reopen the Proof Setup Monitor RGB is showing with a tick next to it.

       

      If I reclick on this choice, Monitor RGB, the image then displays correctly. I can also get it to display correctly by clicking on Proof Colors or Ctrl+Y on the drop down View Menu. I can't however get images to open with this view setting already displaying correctly.

       

      This was a problem for me in Photoshop/Master Collection CS4 which I have just uninstalled and upgraded to Photoshop/Master Collection CS5.

       

      Any help with this would be gratefully received.

       

      Thanks,

       

      Nigel

        • 1. Re: Default Proof Setup Monitor RGB set but not working
          c.pfaffenbichler Community Member
          When I open a photo I want it to be displayed by default in Monitor RGB as I generally work with images for the Internet.

          I am actually a Mac-user but occasionally drop by in this Forum as some matters are platform-independent.

          And this matter has been discussed more than once in the Mac-Forum … why would you preview with Monitor Profile and not just work in srgb?

          Monitor RGB is not indicative of what other internet users will see (unless they use monitors that accidentally display exactly identically to yours), so what’s the point?

           

          Anyway the Soft Proof setting is not intended to be automatically applied, as far as I know, but only on invoking Proof Colors.

          It might be possible though to use File – Scripts – Scripts Event Manager to automatically invoke it on opening a file (Proof Colors could be inserted into an Action with Insert Menu Item and that Action linked to Open Document).

          • 2. Re: Default Proof Setup Monitor RGB set but not working
            nigelfreeney Community Member

            Hi C.

             

            I realised after I wrote it that Ishould have edited to sRGB but thanks for pointing that out. Unfortunately it doesn't change the question in as much as I wanted to be able to view in sRGB by default as this is the end result of the majority of my output. It's a pity that they have chosen Ctrl+Y as the shortcut for this as it is a bit of a stretch for one hand.

             

            As far as adding a script that's potentially more effort than it's worth but if you think this would be an easy thing to achieve  I would be grateful if you could share that with me - I haven't done any scripting in Photoshop previously.

             

            Thanks for taking the time to respond.

             

            Nigel

            • 3. Re: Default Proof Setup Monitor RGB set but not working
              c.pfaffenbichler Community Member

              No Scripting necessary in this case.

               

              First create an Action to toggle Proof Colors with Insert Menu Item (but don’t forget to turn recording off):

              insertmenuitem.jpg

              Add Proof Colors by selecting it in the Menu:

              insertmenuitemdialog.jpg

              With the Action ready go to File – Scripts – Script Events Manger and select the Action and link it to the Event Open Document:

              scripteventsmanager.jpg

              Subsequently opened Files should have Proof Colors active.

              Now if you want that to only apply to RGB- or L*a*b-images that would take an actual Script, I guess.

               

              Hope that helps.