2 Replies Latest reply on Jun 30, 2010 1:34 PM by Henry Troup

    Transform file not being applied




      I have used the Adobe Customization Wizard to create a MST file that

      - installs without user interaction but with a progress bar

      - without a desktop icon

      - without auto-updates


      When creating the MST I:

      - Opened the MSI file in the Customization Wizard

      - Made my changes

      - Saved the Package

      - Created a Transform


      The MST file's timestamp matches the save time, so I know the MST file is being created in the expected folder.


      When I run the installer from MDT 2010 or from a local command prompt, I have the same problem: The application starts to install but requires input from the user. If I use the /qn switch, that obviously makes the process automatic and silent, but does not apply the other settings (desktop icon removal and block of updates). It seems like the MST file is being completely ignored.


      The command I use is:


      msiexec /i AcroRead.msi /t AcroRead.mst


      I have also tried:

      msiexec /i AcroRead.msi TRANSFORMS=AcroRead.mst

      msiexec /i AcroRead.msi /t AcroRead.mst /qn


      Working directory (contains the MSI and MST files): .\Applications\Adobe Reader 9.3

      (On a local machine I have copied the files to a folder on the desktop, run from command line, and same issue.)


      At this point I'm stumped. Any ideas?